0
Incoming calls issue - Auto switching to 3G not working

  1. Mitchell90
    Cupcake Jan 21, 2021

    Mitchell90 , Jan 21, 2021 :
    Hi all,

    I have the OnePlus8 in2013 edition phone (using a carrier in Ireland), I received the update to 11.0.3.3 2 days ago.

    Since then I have noticed that my incoming calls are not working, I have narrowed down the issue to the preferred network .
    • When I have it set to 2G/3G/4G/5G (automatic), the person ringing me can hear the ringing but my phone has no notification at all (not even a missed call).
    • When I have it set to 2G/3G/4G/(automatic), it eventually rings on my phone but is delayed with the other person hearing it ring a few times before my phone starts ringing.
    • When I have it set to 2G/3G (automatic) it works perfectly.

    So based on this, it seems to be an issue with the auto switching to 3G during a call, has anyone any advice please? I have reset network/bluetooth/wifi setting and tried to force my phone to use voLTE, neither has worked.
     

    #1
  2. Tokolozi
    Most Original Avatar Jan 21, 2021

    Tokolozi , Jan 21, 2021 :
    Hey, check with your carrier if they don't have any issues on their side either.
    When enabling VoLTE like you said do you see the voLTE logo in the top notification bar as well?
     

    #2
  3. Mitchell90
    Cupcake Jan 21, 2021

    Mitchell90 , Jan 21, 2021 :
    Hey

    Thanks for your reply, the carrier doesn't have voLTE, I had to force the phone to use voLTE by downloading a 3rd party app but it was of no use.

    I've been onto my carrier and they have no issues on their side, they've even rebooted my sim to no avail.

    But it doesn't appear to be a carrier issue as I've tried my friends sim who is on a different network and he had the same issue on my phone. I've also tried my sim on his phone and incoming calls worked fine.

    Seems to be a weird bug since I've updated to the latest OS.
     

    #3
  4. Tee_Eee_Bee
    Ice Cream Sandwich Jan 21, 2021

    Tee_Eee_Bee , Jan 21, 2021 :
    If you haven't already tied this, disable Wi-Fi calling and see if it makes a difference.
     

    #4
  5. Mitchell90
    Cupcake Jan 22, 2021

    Mitchell90 , Jan 22, 2021 :
    Thank you, but I don't have it enabled.

    I've contacted OnePlus directly, they've told me to report a bug on the feedback forum which I have done. Since this issue has started since I updated to 11.0.3.3 on my OnePlus8.

    In the mean time, I am unable to use the 5G feature on my phone.
     

    #5