0
Incoming calls only through speaker via OnePlus 7

  1. kp1n
    Cupcake Apr 29, 2021

    kp1n , via OnePlus 7 , Apr 29, 2021 :
    I recently upgraded my OnePlus 7 to Android 11 and realize that every incoming call goes to my speaker phone. I cannot change it to my earpiece. This is a bug. Please advise on how to fix it since I cannot take any incoming calls any more! This is critical. Thx...
     

    #1
  2. Artemus.
    Community Hero 2020 Apr 29, 2021

    Artemus. , Apr 29, 2021 :
    One quick fix is to turn on then off hearing aid compatibility.
     

    #2
    Aaron2017 likes this.
  3. kp1n
    Cupcake Apr 29, 2021


    #3
  4. Artemus.
    Community Hero 2020 Apr 29, 2021

    Artemus. , Apr 29, 2021 :
    Do you not have this toggle under Accessibility?
     

    #4
    Aaron2017 likes this.
  5. kp1n
    Cupcake Apr 29, 2021


    #5
  6. kp1n
    Cupcake Apr 30, 2021


    #6
  7. dkman610
    Donut May 2, 2021


    #7
  8. dkman610
    Donut May 3, 2021

  9. T1577120181331
    Cupcake May 4, 2021

    T1577120181331 , via OnePlus 7 , May 4, 2021 :
    Under the section Bluetooth Paired Devices you will see two settings for the paired devices: phone audio and media audio. Uncheck the phone audio option. This will stop your phone from ringing while connected to the Bluetooth device (speaker) but the music will stop when a call rings.hope this helps!
     

    #9
  10. dkman610
    Donut May 18, 2021

    dkman610 , via OnePlus 7 , May 18, 2021 :
    The issue is happening when the phone is not connected to Bluetooth? This issue you're changing is how my phone calls are handled whole using Bluetooth?
     

    #10
  11. dkman610
    Donut May 19, 2021

    dkman610 , via OnePlus 7 , May 19, 2021 :
    This is not an option for me either I have many Bluetooth devices previously connected am I supposed to do this for every one? Plus currently I'm connected to an external speaker and I don't even have a phone option?
     

    #11