Incoming SMS not working

  1. malancha
    Cupcake Oct 17, 2019

    malancha , Oct 17, 2019 :
    I'm not receiving SMS messages if the default SMS app is set to anything other than OnePlus Messaging. Tried with Textra and Google Messages, but nothing comes through. OTP messages are only received if the Messaging app from OnePlus is the default SMS app.

    Brand new OnePlus 7T, on Airtel.

    Any thoughts?

  2. G_Dylan_Hansen
    Cupcake Oct 17, 2019

    G_Dylan_Hansen , Oct 17, 2019 :
    I just received my OnePlus 7 pro and I am having the same issue. I'm on Verizon and I came from an iPhone. I turned off iMessage and deregistered my number on apples site. Still doesn't work.

  3. Probowl2
    Donut Oct 18, 2019

    Probowl2 , Oct 18, 2019 :
    The one plus 7T phone is not compatible with Verizon. I picked one up at the 7T pop up store last Friday and still can’t get it to work with Verizon.

  4. K1571513447391
    Cupcake Oct 24, 2019

    K1571513447391 , Oct 24, 2019 :
    I am not receiving SMS in any capacity on my new 7T.
    I can make and receive calls, and send SMS, but not receive SMS.
    I put the SIM back into my previous phone (Galaxy S6) and it will receive texts. Any ideas?
    Edit: I am on Verizon

  5. VikasnBhat
    Froyo Oct 24, 2019

    VikasnBhat , Oct 24, 2019 :
    I also have the same issue on Airtel, sms are not consistently delivered to me on first sim. When on dual sim mode, second sim doesn't receive any message at all.
    Last edited: Nov 13, 2019

  6. G_J.T._Shyman_xcYU
    Cupcake Nov 13, 2019

  7. X1574396531157
    Cupcake Nov 27, 2019

    X1574396531157 , Nov 27, 2019 :
    Resolution for Verizon is simple . Login to Verizon > My Account > Device > Activate OnePlus using IMEI . Please try these steps on your old phone before transferring the Sim because Verizon sends a sms to confirm the activation

  8. freestyler_sumi
    Cupcake Nov 27, 2019

  9. pmnipane
    Cupcake Dec 12, 2019

    pmnipane , Dec 12, 2019 :
    I too am facing the same issue in India with Airtel connection. I tried the default sms app as well as SMS Organizer app but no luck. I also changed the SMSC number but that didn't help either.

  10. MidoriyaSenSei
    Donut Dec 12, 2019

  11. pmnipane
    Cupcake Dec 15, 2019

    pmnipane , Dec 15, 2019 :
    I got the correct SMS Center number and updated it in the settings. Now SMSes are working just fine.