Inconsistent Network on 4G for oneplus one but works perfectly fine on 3G Airtel

  1. rohitvermamech
    Eclair Dec 28, 2015

    rohitvermamech , Dec 28, 2015 :
    I am facing network issue on 4G on OPO/Airtel Bangalore.
    Some times my mobiles shows no network at all on 4G but works absolutely fine on 3G..if some one calls me they say that my phone was out of network....

    Anyone facing same issue....and any possible fix ?

    Thanks is advance.

    VasuJain1970 likes this.
  2. Lamner
    Eclair Dec 28, 2015

    VasuJain1970 likes this.
  3. neisor
    Gingerbread Dec 28, 2015

    neisor , Dec 28, 2015 :
    What ROM are you using? Have you tried flashing OxygenOS radio modem on top of your ROM? Does the OnePlus One support the frequencies of your mobile operator on 4G?

  4. riffraff81
    KitKat Dec 28, 2015

    riffraff81 , Dec 28, 2015 :
    very important info to have.

  5. rohitvermamech
    Eclair Dec 28, 2015

    rohitvermamech , Dec 28, 2015 :
    Yes, it seems Airtel supports 2300 MHz (TDD LTE) in India

  6. rohitvermamech
    Eclair Dec 28, 2015

    rohitvermamech , Dec 28, 2015 :
    Yes, it seems Airtel supports 2300 MHz (TDD LTE) in India

  7. riffraff81
    KitKat Dec 28, 2015

  8. Mustufa Gari
    Cupcake Dec 29, 2015

    Mustufa Gari , Dec 29, 2015 :
    Actually i am also facing problems with One plus one. As i have to travel a lot whenever i switch my network zones the device disconnects the earlier network and should automatically connect to the current network but the problem is when the network switches it just dont connect to the current network as it shows no connectivity. I have to restart my phone for it. Same with Internet connection. When i loose connectivity and connect the the cellular network again the 3g just wont connect. The only solution is to keep restarting the phone every time i face this issue which is highly frustating.

  9. MohammadAsifKhan
    Cupcake Dec 29, 2015

    MohammadAsifKhan , Dec 29, 2015 :
    Facing same issue since morning. People calling say I'm not reachable when on 4g/LTE but on 2g/3g it is working fine. Is it the issue with network or OPO??

  10. rohitvermamech
    Eclair Dec 29, 2015

    rohitvermamech , Dec 29, 2015 :
    It seems ...there is a problem with software of OPO....I am facing exactly same issue...and still waiting for the fix...

  11. rohitvermamech
    Eclair Dec 30, 2015

    rohitvermamech , Dec 30, 2015 :

    Try with this & share your feedback!!

    For anyone who is having issues with LTE not working,@@Baymax has figured it out :):
    Step 1:

    Go into Settings > Mobile Networks > Access Point Names > Restore Defaults
    The list should now have many many more choices of APNs. Choose the correct APN. Then go into Settings > Mobile Networks > Network Operators (make sure you are connected to WiFi) click "Choose Automatically". Then turn Aeroplane Mode on and back off.
    Step 2:
    VERY IMPORTANT! Restart your phone.
    Step 3:
    Go into phone and dial *#*#4636#*#* and choose Phone Information. In Phone Information set the Preferred Network Type to LTE/GSM auto (PRL) [even if it says it already, do it again]. Turn off the radio. When the radio is turned off, turn the radio back on. Go down to the SMSC and hit "Refresh" and then "Update".

    ivomendes likes this.
  12. mevicks
    Ice Cream Sandwich Dec 30, 2015

    mevicks , Dec 30, 2015 :
    1. Airtel 4G quality is patchy (using Airtel 4g in mumbai; cant say conclusively about bangalore). Switching to 3g is a much better option if you want to save battery life and want to actually talk on the phone . lol. Airtel 4g = Awesome data speeds ; pathetic call quality.
    2. Icing on the cake is that COS (or any rom using cyanogen modem for opo) has Pathetic radio too. Solution = OOS modem


  13. Lamner
    Eclair Dec 30, 2015

    Lamner , Dec 30, 2015 :
    Dude, I've tried almost everything. Clean CM12.1 nightly, COS 12.1, Oxygen OS, CM13 nightly, and I'm currently running the CM13-sultan version.

    I've tried the 12.1, 12 and 13 native modems, the 44S that some claim as the "best", and Oxygen's, they all had the "deconnection without reconnection" bug when 4G was enabled.

  14. geor14
    Cupcake Jan 1, 2016

    geor14 , Jan 1, 2016 :
    I'm trying to connect Reliance Jio 4G. But when I set the APN to restore defaults, I'm not getting the desired APN 'jionet'. Also when I search for the network, it is showing the network as IND JIO, but it is not getting registered. Any suggestions/help are welcome.

  15. zanyguy
    Cupcake Sep 5, 2016

    zanyguy , Sep 5, 2016 :

    I am facing the same issue on Vodafone since I switched to 4G sim card. No one is able to reach me unless I am on 2G. The problem has worsened with no network at all on 4G or 3G! I am only on 2G now. Have any of you found a solution? The sim card works fine on my wife's Xiaomi.

  16. rushipattni
    Cupcake Feb 5, 2017

    rushipattni , Feb 5, 2017 :
    Does not work !

  17. Ruchindagar1006
    Eclair Feb 5, 2017

    Ruchindagar1006 , Feb 5, 2017 :
    I m having a problem in notification...earlier there was a on screen peeking option and sound option separate..but now it's the same ..if someone wants sound of a particular app but not on screen peeking...so what should they do. bring that back plzzzzz..or tell any alternative