0
IP Configuration Failure

  1. penndavid Honeycomb Apr 30, 2015

    penndavid, Apr 30, 2015 :
    Any time I try to connect to my schools WiFi network, it says "Obtaining IP Address..." And after about 5 - 10 minutes, it will show this IP Configuration Failure message. Is there anything I can do to fix this? I get very poor cell signal in school so this is vital for me.

    Any help would be greatly appreciated :)
     

    Attached Files:


    #1
  2. Nyan_ Jelly Bean Apr 30, 2015


    #2
    lostLambda likes this.
  3. penndavid Honeycomb Apr 30, 2015


    #3
  4. chuckufarleys KitKat Apr 30, 2015

    chuckufarleys, Apr 30, 2015 :
    It's probably a secure wifi access point.
    Have you tried talking to the school IT dept.?
     

    #4
  5. mchon Honeycomb Apr 30, 2015

    mchon, Apr 30, 2015 :
    but it's an unsecured wifi network (no lock icon). still, i'd take it to IT department.
     

    #5
  6. penndavid Honeycomb Apr 30, 2015

    penndavid, Apr 30, 2015 :
    Other kids can connect with their iPhones. You're suppose to be able to connect to the Wifi then sign-in when you try to load a webpage on your browser. I don't know if there's to fix it.
     

    #6
  7. lostLambda KitKat Apr 30, 2015

    lostLambda, Apr 30, 2015 :
    Looks like an unsecured connection. Tap on the network and then tap on advanced and seebif anything looks funny. Barring that, ask the school how to connect. Maybe you also need a password? Are you trying to connect to the correct network?
     

    #7
    PRK.R likes this.
  8. mchon Honeycomb Apr 30, 2015


    #8
  9. penndavid Honeycomb Apr 30, 2015

    penndavid, Apr 30, 2015 :
    BYOD stands for Bring Your Own Device. Kids connect to the school WiFi on their cell phones with that. I've asked a lot of kids and nobody else has this problem. It's not a ROM issue because I've tried several different ROMs and still the same result
     

    #9
  10. penndavid Honeycomb Apr 30, 2015

    penndavid, Apr 30, 2015 :
    Tried that :/
    I would try to connect to the LMHS-Student but it's not a normal username and password.
    We sign in on our iPads with
    username: student/penn.david
    password: *******

    But android has
    Identity:
    Anonymous Identity:
    Password:
    and I don't know how to enter my credentials that way
     

    #10
  11. chuckufarleys KitKat Apr 30, 2015

    chuckufarleys, Apr 30, 2015 :
    Again, it's probably user error, and the school IT dept. would help.
    Also, do you have wifi problems anywhere else, like at home?
    Clearly it's not the OpO, but you don't know what you are doing.
     

    #11
  12. penndavid Honeycomb Apr 30, 2015

    penndavid, Apr 30, 2015 :
    I've never had problems connecting to WiFi anywhere else.
    Sadly I think my Opo may be incompatible with the School Router's
     

    #12
  13. chuckufarleys KitKat Apr 30, 2015

    chuckufarleys, Apr 30, 2015 :
    More likely you need to talk to the schools IT dept.
    Quit being so sad about it and do something.
     

    #13
    lostLambda likes this.
  14. penndavid Honeycomb Apr 30, 2015

    penndavid, Apr 30, 2015 :
    I'll see about it tomorrow. I appreciate the help :)
     

    #14
  15. dege13 Cupcake Nov 15, 2016

    dege13, Nov 15, 2016 :
    Did you ever get it working? Or give up?
    I get this problem a lot. It looks to be a software bug to me, if you are seeing the same thing as me.
    I am on Android 6.0.1/Cyanogen 13.1.2
    This happens when I got from my Wifi at home to the Wifi at work. When I get to work it will never connect with the same "IP Configuration Failure" status. If I turn off WiFi and back on, it will give the same problem. If i Forget the network and re-create it I get "Obtaining IP Address..." for a bit, then "Connecting..." and I get "IP Configuration Failure" again after a while.
    The only solution is to reboot my phone. It fixes it every time. My laptop is here using the same WiFi network just fine. Other people's phone work fine. Even other Android phones. It has not always happened. Likely a bug introduced in an update I have applied on my phone.
     

    #15
  16. smahanta Cupcake Nov 16, 2016

    smahanta, Nov 16, 2016 :
    I face exactly the same issue.
    I am able to connect to my office wifi with all devices.
    I am able to connect to all wifi other than my office wifi.
    Every other user in office are able to connect to office wifi
    It is only my OPO not able to connect my office wifi with following message forever "Obtaining IP Address..."
     

    #16
  17. adnanabid Cupcake Oct 23, 2017

    adnanabid, Oct 23, 2017 :
    Hi Guys,
    I am having the same issue at home. I have been using home wifi forever and just this morning when I checked my phone I see wifi not connected and each time I try I get IP Configuration Failure and it just wouldn't connect. Nothing has changed on my home router or home network. Looks like an issue with OPO 3! Does anyone have a solution? By the way I also tried restarting the phone and it still didn't work.

    thanks.
     

    #17
  18. mittul Cupcake Dec 2, 2017

  19. DerpzPlayz Cupcake Jan 11, 2018


    #19
  20. doddysal Ice Cream Sandwich Jan 12, 2018


    #20