2
[ISSUE] Hard Brick Issue (8974_msimage.mbn: OK problem)

  1. Psk.it
    KitKat Mar 1, 2015

    Psk.it , Mar 1, 2015 :
    @ssafras
    if you can start in fast boot, you will be able to overwrite partitions

    download a full rom
    cm-11.0-XNPH05Q-bacon-signed-fastboot.zip or cm-11.0-XNPH44S-bacon-signed-fastboot.zip
    start OPO in fast boot mode

    make a copy of adb folder,
    unzip the rom and copy all files in the adb folder

    run cmd as administrator and move to that folder -> cd /d "c:\adb" (tipically)
    Code:
    fastboot erase system
    fastboot erase boot
    fastboot erase recovery
    fastboot erase cache
    
    fastboot flash modem NON-HLOS.bin
    fastboot flash sbl1 sbl1.mbn
    fastboot flash dbi sdi.mbn
    fastboot flash aboot emmc_appsboot.mbn
    fastboot flash rpm rpm.mbn
    fastboot flash tz tz.mbn
    fastboot flash LOGO logo.bin
    fastboot flash oppostanvbk static_nvbk.bin
    fastboot flash system system.img
    fastboot flash userdata userdata_64G.img
    fastboot flash boot boot.img
    
    fastboot flash recovery recovery.img
    or (if you want TWRP as recovery)
    fastboot flash recovery openrecovery-twrp-2.8.5.1-bacon.img
    
    fastboot flash cache cache.img
    fastboot reboot
    
    this will restore your Oneplus as factory statur
     

    #21
  2. ssafras
    Cupcake Mar 1, 2015

    ssafras , Mar 1, 2015 :
    @Psk.it

    Thank you for your answer! Unfortunately, for every attempt to "fastboot erase" I get a FAILED response, like the one below:

    erasing 'system'...
    FAILED (remote: failed to erase partition)
    finished. total time: 5.060s


    Note that I am running cmd as admin and I have copied everything to the adb folder (Even though adb is in my PATH and may be run from anywhere).
     

    #22
  3. q8vw
    Gingerbread Mar 1, 2015

  4. Psk.it
    KitKat Mar 2, 2015

    Psk.it , Mar 2, 2015 :
    is the phone unlocked?
    have you enabled debug usb?
    try also giving root access to adb (in the developers setting)
     

    #24
  5. ssafras
    Cupcake Mar 2, 2015

    ssafras , Mar 2, 2015 :
    Hello q8vw!

    Thanks for your answer!

    Yes, I am unlocked:

    (bootloader) Device tampered: true
    (bootloader) Device unlocked: true
    (bootloader) Charger screen enabled: false
    OKAY [ 0.005s]
    finished. total time: 0.006s

    Whenever I try to flash something, I get FAILED (remote: flash write failure)
     

    #25
  6. ssafras
    Cupcake Mar 2, 2015

    ssafras , Mar 2, 2015 :
    The bootloader is unlocked. "(bootloader) Device unlocked: true"

    The phone does not boot. How can I enable debug usb or give root access to adb?

    Thanks :)
     

    #26
  7. Android the Greek
    Jelly Bean Mar 2, 2015

    Android the Greek , Mar 2, 2015 :
    Tr
    Try relocking and unlocking then use the folder I gave you
     

    #27
  8. ssafras
    Cupcake Mar 2, 2015

    ssafras , Mar 2, 2015 :
    Unfortunately the same thing happens.

    I tried relocking -> unlocking -> flashing but I get the same "FAILED (remote: flash write failure)" response. If I couldn't "adb push / shell" I would be sure that it's a H/W failure..

    Does it matter that the phone is not rooted?

    I have access to "adb shell" only after doing a "fastboot boot" of a recovery.

    If the phone should be rooted, is there any way to do this without being able to boot? Through adb/fastboot maybe?
     

    #28
  9. Inzun
    Jelly Bean Mar 2, 2015


    #29
  10. momolin
    Cupcake Mar 10, 2015

    momolin , Mar 10, 2015 :
    Same thing happened to me... my phone has been hard bricked ? one day out of nowhere, when i woke up my phone was already in bootloop! i only have access to fastboot mode and twrp recovery, the moment i get into twrp it asks for a password, which i dont have and i dont know what is, then after entering twrp,
    internal storage shows as 0 mb,
    i can't delete install push pull anything because
    can't mount data,
    can't mount cache,
    i tried this https://forums.oneplus.net/threads/solution-recover-from-hard-bricked-oneplus-one.104943/

    but to no luck, just as the above user, whenever i try to fastboot anything it says
    flash write failure on everything
    even i used the root toolkit for bacon and all the fastboot commands fail..
    please help asap..
     

    #30
  11. momolin
    Cupcake Mar 10, 2015


    #31
  12. frankiecortina
    Ice Cream Sandwich Mar 10, 2015

    frankiecortina , Mar 10, 2015 :
    You sir have balls
     

    #32
  13. ssafras
    Cupcake Mar 10, 2015

    ssafras , Mar 10, 2015 :
    Hello!

    Sorry to disappoint you but I shipped it back for repair :(
    I tried everything I could get my hands on to make it work but failed.

    Good luck!
     

    #33
  14. momolin
    Cupcake Mar 10, 2015

    momolin , Mar 10, 2015 :
    well.. i can't ship it back for repairs.. im from south america .. T.T
    anybody help? anybody please please help?
    Phone condition is bootloop, 1 day woke up to sudden bootloop,

    can go to twrp 2.8.4.1 but asks for password, i never setup any password nor ever setup encryption?
    twrp internal storage is 0 mb, can't mount data
    can't mount cache,
    can't wipe, can't run nothing at all from twrp..

    can go to fastboot mode but no commands wroks whatsoever,
    whentrying to fastboot, says flash write failure in all...
    can't erase can't format..

    tried the recovery tool for 64gb the one that has random letters in the columns and you need to press start... no success either. the bar runs up to 1/2 and then turns red..

    tried qualcomm tool, the same thing..

    is it possible that the internal memory suddenly just died off ? is that possible ?
    or is it possible that cm12 nightly on its self encrypted my phone ? or auto updated ? or flashed a corrupted update? this just happened march 8th.. last time i wanted to download nightly was 20150308 .. twice it failed though..

    btw i can't shut down the phone either, whenever you try to shut it off it just auto restarts to bootloop ..
     
    Last edited: Mar 10, 2015

    #34
  15. momolin
    Cupcake Mar 10, 2015

    momolin , Mar 10, 2015 :
    Now i just tried adb sideload withing twrp as well... also no luck.. T.T omg..
     

    #35
  16. nirmitmehta
    Ice Cream Sandwich Mar 10, 2015

    nirmitmehta , Mar 10, 2015 :
    I'll message you my skype. Add me on there and I'll have a look and try to help if possible.
     

    #36
    momolin likes this.
  17. addam
    KitKat Mar 10, 2015


    #37
  18. momolin
    Cupcake Mar 10, 2015

    momolin , Mar 10, 2015 :
    i also used that tool, where all the FASTBOOT FLASH, shows FAILED FLASH WRITE FAILURE... thanks though.. can't unbrick either, the phone just does not flash ..
     

    #38
  19. momolin
    Cupcake Mar 11, 2015

    momolin , Mar 11, 2015 :
    after tinkering around with nirmit through teamviewer and skype.. we still had no luck..
    anyone else know if cm12 nightly suddenly encrypts and twrp can't read ? and causes bootloop in cm12 logo?

    or my emmc suddenly just died ...
    is there any dev here, maybe help me? any tool that i can you use to completely wipe partition, and start from scratch ?

    right now fastboot can't process any commands, and twrp can't mount storage nor /cache ..
    so basically i can't do nothing with the phone now..

    so maybe a tool to complete wipe and start from scratch everything? partitions and everything?
    or a universal decrypt password for twrp ? for cm12 nightly?
     

    #39
  20. DRS2442
    Honeycomb Mar 11, 2015

    DRS2442 , Mar 11, 2015 :
    Hi everyone, an update:

    Oneplus basically said my phone needed to be replaced. That's how they resolved this issue that I made the thread for, suggesting that the reason this happens is because of hardware failure. I should be getting a new OPO, they're not going to try to fix the one that threw this issue at me.

    So, I guess if this issue happens, then you're probably eligible for an RMA.
     

    #40