4
JIO 4G(LTE) stopped working after CM 13 OTA update :/

  1. meprateek
    Honeycomb Jul 29, 2016

    meprateek , Jul 29, 2016 :
    1. You should be on Cyanogen OS 13
    2. Flash the modem
    3. Set the APN for Jio manually
    4. Use *#*#4636#*#* then select preferred network type as "LTE/GSM auto (PRL)" option
    5. Refresh the SMSC and then update it
    6. Turn off the radio and turn it back on
    7. Exit Phone Testing
    8. Restart your phone
    9. Select Jio manually, in case it is not detected automatically
     

    #61
    satish kumar pathak likes this.
  2. meprateek
    Honeycomb Jul 29, 2016

    meprateek , Jul 29, 2016 :
    1. You should be on Cyanogen OS 13
    2. Flash the modem
    3. Set the APN for Jio manually
    4. Use *#*#4636#*#* then select preferred network type as "LTE/GSM auto (PRL)" option
    5. Refresh the SMSC and then update it
    6. Turn off the radio and turn it back on
    7. Exit "Testing" options
    8. Restart your phone
    9. Select Jio manually, in case it is not detected automatically
    -----------------------

    Sorry for double posting...
     

    #62
  3. F_Abdul_Majid_VCsJ
    Cupcake Jul 29, 2016

    F_Abdul_Majid_VCsJ , Jul 29, 2016 :
     

    #63
  4. soumyadeepdutta84
    Eclair Jul 29, 2016

    soumyadeepdutta84 , Jul 29, 2016 :
    I am using one plus one with CM 13.1-254 Marshmallow..when i tried to save APN manually its not allowing me to save
     

    #64
  5. soumyadeepdutta84
    Eclair Jul 29, 2016

    soumyadeepdutta84 , Jul 29, 2016 :
    @meprateek I am using latest version of Cyanogen i.e. 13.1-ZNH2KAS254..Will your CM 11 modem i.e. XNPH44S work on this CM 13.1 and will i flash it simply through TWRP(just asking)..Do you find any error? Please help..will it work with this version of OS..and what version of Cyanogen you are using?
     

    #65
  6. op.pollicis
    Eclair Jul 29, 2016


    #66
  7. meprateek
    Honeycomb Jul 29, 2016

    meprateek , Jul 29, 2016 :
    @soumyadeepdutta84
    I am on COS 13.0-ZNH0EAS2JK
    I have posted the links in one of the posts before. Please get it from there.
    Use fastboot to flash, in case it does not work out. Utilize the modem from your current build and flash it. The modem files can be found in flashable zip file, with name like NON-HLOS.bin
    Hope this helps.
     

    #67
  8. F_Abdul_Majid_VCsJ
    Cupcake Jul 30, 2016

    F_Abdul_Majid_VCsJ , Jul 30, 2016 :
    non hlos.bin file of cos 13 is not in zip
    please help sir what to so step by step or give me ur whatapp num plz sir
     

    #68
  9. soumyadeepdutta84
    Eclair Jul 30, 2016

    soumyadeepdutta84 , Jul 30, 2016 :
    Thanks @meprateek ..First i ask OPO care to roll back my driver to COS 13.0-ZNH0EAS2JK and den will flash the modem through stock recovery..hope den it will work
     

    #69
  10. meprateek
    Honeycomb Jul 30, 2016

    meprateek , Jul 30, 2016 :
    Np. Flash the modem using fastboot only. Don't worry it won't mess up filesystem or apps/data or anything.
    I tried Oxygen OS 2.1.4 modem on COS 13.0-ZNH0EAS2JK and it did not work so simply flashed back the XNPH33R
     

    #70
  11. meprateek
    Honeycomb Jul 30, 2016

    meprateek , Jul 30, 2016 :
    Te
    Post the screenshot of your OS version. Surely, I will try to end your predicament.
     

    #71
  12. F_Abdul_Majid_VCsJ
    Cupcake Jul 30, 2016

    F_Abdul_Majid_VCsJ , Jul 30, 2016 :
    sir i am currently on this but i tried all c os 13 modem flash all nothing happens so now i revert back to cm13.1 please help sir or directly contact ne on whatsapp plzzz
     

    Attached Files:


    #72
  13. meprateek
    Honeycomb Jul 30, 2016

    meprateek , Jul 30, 2016 :
    @F_Abdul_Majid_VCsJ I guess your problem came up bcoz u flashed Cos modem on cyanogen mod os.
    Try with cyanogen mod version 11 modems, should work out fine.

    A general tip folks: cross flashing modems across different lines of os will not work.
    If u r on cyanogen os then flash cyanogen os modems from cyanogen os versions only.
     

    #73
  14. raj.amalw
    Cupcake Jul 30, 2016

    raj.amalw , Jul 30, 2016 :
    I flashed the CM 11 modem in COS 13.1 it is registering in network, but data does not work. Can you help me.
     

    #74
  15. harsh431
    Cupcake Jul 30, 2016

    harsh431 , Jul 30, 2016 :
    • ROM Name: CM 13.1 Working modems: Default firmware(latest stock rom),44S KITKAT, 241 LOLLIPOP
    Non-working modems: Oxygen OS 2.4.1 (other oxygen os modems will also not work)
    • ROM Name: Oxygen OS 2.4.1 Working modem: The default 2.4.1 modem would work without any problems.
     

    #75
  16. F_Abdul_Majid_VCsJ
    Cupcake Jul 30, 2016

    F_Abdul_Majid_VCsJ , Jul 30, 2016 :
    bro link please for everything please
     

    #76
  17. butaixyz8016
    Honeycomb Jul 30, 2016

    butaixyz8016 , Jul 30, 2016 :
    How to flash cm11s modem over cm13 procedure pls
     

    #77
  18. meprateek
    Honeycomb Jul 30, 2016

    meprateek , Jul 30, 2016 :
    Connect in fastboot mode
    Then from command prompt within the adb folder
    fastboot devices (will show your device then the next step)
    fastboot flash modem <cm11s modem filename>.bin
     

    #78
  19. meprateek
    Honeycomb Jul 30, 2016

    meprateek , Jul 30, 2016 :
    Cross flashing across different line of OSes will not help.
    I hope you have flashed COS11 I repeat COS11 modem on COS 13.

    Try to set up APN manually.
    Then go to Testing Settings *#*#4636#*#*
    Select the network type to LTE/GSM (auto) PRL
    Refresh and update SMSC
    Turn off radio then turn on radio
    Restart the phone
     

    #79
  20. butaixyz8016
    Honeycomb Jul 30, 2016

    butaixyz8016 , Jul 30, 2016 :
    what should i write in apn section??
     

    #80