0
Just received my Oneplus 7 pro ... but wiki connection is broken :-(

  1. wangweixun
    Donut May 22, 2019

    wangweixun , May 22, 2019 :
    Hi,

    I just received my OP7 Pro (in US, Model: GM1917). Everything is cool except ... wifi is basically broken. When it connects to my home wifi, it could work for about 30 seconds before completely stops working. I noticed the problem as early as during initial setup. Wifi status shows "Connected" with no issues in Settings. Things I have tried:
    • Tested with many apps. So this is definitely not app-specific problem.
    • Wifi works fine in all other devices at home.
    • Mobile data on OP7 Pro works just fine. So this is wifi only problem.
    • Reboot the phone.
    • Reset the network settings.
    • Disable and re-enable the wifi may get it working for 10 ~ 30 seconds, after which it just breaks.
    • (Update) Wait for ~5 minutes or so, the wifi will recover itself... but it will break again after using it for ~30 seconds to a few minutes.
    • (Update) factory reset doesn't solve the problem neither.
    I will test it with wifi in other places tomorrow.

    I really want to like this phone. But I cannot live without wifi :-(.

    Any suggestion? Thanks!
     
    Last edited: May 22, 2019

    #1
  2. wangweixun
    Donut May 22, 2019

    wangweixun , May 22, 2019 :
    Hmm ... using WiFi at work seems fine. So it might be my home's wifi setup not compatible with OP7? I have 3 Google WiFi routers covering my house with a Mesh setup.
     

    #2
  3. Golden_Whale
    Froyo May 22, 2019

    Golden_Whale , May 22, 2019 :
    I wouldn't rule out the OP's WiFi adapter as being faulty. I used to have similar issue with my ancient Nexus 5. It simply disliked certain channels with certain router types and dropped from them.


    What you can do is compare OP7 with another similar device, put them next to each other. Connect them at the same time, start some kind of download/video and observe.
     
    Last edited: May 22, 2019

    #3
    xnutzii likes this.
  4. RicardoDimm
    Eclair May 22, 2019


    #4
  5. allroadusa
    Eclair May 22, 2019

    allroadusa , May 22, 2019 :
    I do have 4 Google Wifi units and the OnePlus 7 Pro has no issue at all connecting to them... with great speed btw.
     

    #5
  6. wangweixun
    Donut May 22, 2019

    wangweixun , May 22, 2019 :
    Yes, I did the side by side comparison. OP7 is definitely dropping connections constantly. I never had any problem with WiFi at home before.
     

    #6
  7. jurschel
    Gingerbread May 23, 2019

    jurschel , May 23, 2019 :
    RMA it. They are sending out the occasional turd. I got one stuck in a bootloop. Mine's going back today.
     

    #7
  8. KeepTransisting
    The Lab - OnePlus 7 Pro Reviewer May 23, 2019

    KeepTransisting , May 23, 2019 :
    I have Google Wifi at home and my OP7 is having zero issues.

    Try unplugging your mesh pucks and only having your main puck online and see if that works.
     

    #8
  9. PeSPe2k6
    Cupcake Aug 25, 2019

    PeSPe2k6 , Aug 25, 2019 :
    Maybe try change settings in your modem/router. In my there was an option for changing frequency of my wifi signal - 2.4 Ghz and 5 Ghz. They were on. And my wifi was breaking on my OP7 PRO. Now i have only 5 Ghz chosed and it works fine, no breaking. But i don't know how this affect other devices in home. I haven't tested them out.
     

    #9
  10. Horsault
    Marshmallow Moderator Aug 25, 2019


    #10