0
Laggy animations in Play Store

  1. mikep7
    Donut Jan 23, 2020

    mikep7 , Jan 23, 2020 :
    Hello,

    I have very laggy animation in Google Play Store when I press menu button on left and choose "My games and applications".

    I attached debug from "Profile Rendering HWUI" developer options, there are clearly visible peaks over screen edge.

    Here is also example movie how it looks like:

    I've tested this on different networks WiFi and GSM same effect. Even with disabled networking it's the same problem.

    This effect does not exist on Samsung and Motorola ( much slower hardware) devices which I've tested.

    Maybe it's not a big deal but quite annoying.

    Any idea how to fix that?

    Greetings,
    Mike
     

    Attached Files:

    Last edited: Jan 23, 2020

    #1
  2. xnutzii
    Lollipop Jan 23, 2020

    xnutzii , via OnePlus 6T , Jan 23, 2020 :
    Well you're lucky that your laggy animation is still that, an animation.

    My 6T is worse sometimes, but this is a common problem with the Google Play Store, I've seen this since the newer design back in the day, where the play store got a bit rounded up, I think that was 2015, and since then, every phone I've used, got this lag when opening "my apps", only when the apps are loaded. No fix to this sadly, not clearing the app data, nothing.

    Not even a custom rom.
     

    #2
  3. mikep7
    Donut Jan 23, 2020

    mikep7 , Jan 23, 2020 :
    This is crazy even slow and old Motorola does it well, all tested Samsung devices also had no problem with that.
     

    #3
  4. xnutzii
    Lollipop Jan 23, 2020

    xnutzii , via OnePlus 6T , Jan 23, 2020 :
    Well, my samsung devices that I have, lag almost 2 seconds when I tap that. (WHEN LOADED!!)

    If you open the app the first time after it's been freed from ram, it'll reload, hence not lagging, still, not one problem that has anything to do with OnePlus.
     

    #4
  5. xnutzii
    Lollipop Jan 23, 2020

    xnutzii , via OnePlus 6T , Jan 23, 2020 :
    Just a little in-depth information about the phone, it's not having any kind of lag whatsoever, it's the app that does.

    Same deal in 30 fps locked apps such as gaming apps, asphalt 9 (on sub 90hz panels) asphalt 8, idle miner tycoon and what not.

    1579777419098.jpg
     

    #5
  6. mikep7
    Donut Jan 23, 2020


    #6
  7. xnutzii
    Lollipop Jan 23, 2020


    #7
  8. mikep7
    Donut Jan 23, 2020

    mikep7 , Jan 23, 2020 :
    It does not show GPU stats at all and CPU floating window is not available too. I guess this is root related.
     

    #8
  9. xnutzii
    Lollipop Jan 23, 2020

    xnutzii , Jan 23, 2020 :
    Yeah, it's root related.

    (You can root a OnePlus device by the way without voiding the warranty, just saying;))
     

    #9
  10. Roger.T
    Gingerbread Jan 24, 2020

    Roger.T , Jan 24, 2020 :
    So. I also have a Galaxy S10 + and the same is with me in the PlayStore ..
    It always depends on which version of the PlayStore you have.
    And Google is constantly unlocking or testing new things via over the air...
    Now the app needs some time to load all the shit 😉
    Definitely an app problem and not from the device...
     

    #10
    Sheppards and mikep7 like this.
  11. Sheppards
    Honeycomb Jan 24, 2020

    Sheppards , Jan 24, 2020 :
    Though it's saying something about google and android as a platform in itself that simple stuff like this is not working as they should, even on top shelf hardware
     

    #11
  12. mikep7
    Donut Jan 24, 2020

    mikep7 , Jan 24, 2020 :
    My Google Play Store version is 18.4.86-all ( 7T ), on second device 18.4.15-all ( Huawei P30 Pro ) it also does not hide that menu smoothly.
     

    #12