0
Latest update Wifi connection issue

  1. Chai
    Cupcake Sep 4, 2014

    Chai , Sep 4, 2014 :
    While my oneplus locks up with my work wifi like they were old friends. At home, it constantly goes into "saved,secured with wpa/wpa2" (these are the default security settings) and will not connect.

    If I disable security, it connects right up and is happy! Needless to say, I am not going to turn off security on my home gateway.

    Anybody have an idea on this?
     

    #81
    poehtkyaw likes this.
  2. umirza85
    Froyo Sep 5, 2014

    umirza85 , Sep 5, 2014 :
    My wifi just says connecting, connected, then it disconnects instantly. I cant connect to any wifi.
     

    #82
  3. lilaprasad
    Froyo Sep 5, 2014


    #83
  4. alvingm
    Eclair Sep 5, 2014

    alvingm , Sep 5, 2014 :
    I have problems connecting to my 5Ghz WiFi N but no issues connecting to my WiFi G 2.4 one.
     

    #84
    benluca likes this.
  5. Chai
    Cupcake Sep 5, 2014

    Chai , Sep 5, 2014 :
    For those of you who are having your wifi search, and search, and then dump out, I have found a fix.

    Found one!

    Gateway: AT&T 2wire modem, wifi enabled.

    From your computer, access your modem/gateway. It will have an address like 192.168.1.1. or some such. It is listed on the side of the thing.

    http that number on your connected computer and say hello. You may have to fiddle with passwords if you have not fiddled here before.

    Poke around and find the wireless settings, LAN settings or something that looks promising.

    On your OnePlus, go to 'wi-fi', put in the modem password, and then select "advanced".

    In these settings, you will find that the IP address that is populated by your beloved oneplus is wrong (fix that), and DNS1 is 8.8.8.8. (change that to 255.255.255.0)

    Network prefix length IS 24, and, unscientifically, I put 255.255.255.0 for DNS2.

    Hit it and take a swig of your lovely adult beverage.

    It took me three tries to get all of the numbers right, but, once they were, the thing connected brilliantly, and reconnected without a hitch following a reboot.
     

    #85
  6. kmbolworks
    Cupcake Sep 5, 2014


    #86
  7. pepsy89
    Honeycomb Sep 6, 2014

    pepsy89 , Sep 6, 2014 :
    Same problem here , is there a fix iet ? or we must wait for an update ?
     

    #87
  8. iTrollz
    KitKat Sep 6, 2014

    Last edited: Jul 21, 2016

    #88
  9. timekills
    Froyo Sep 7, 2014

    timekills , Sep 7, 2014 :
    What?!?!
    First, there is no DNS server IP of 255.255.255.0. Second, the DNS server of 8.8.8.8 is Google's, which presumably you got from your wireless access point, just as you got your phone's IP since you have set too DHCP. I appreciate your trying to help, but this is fairly basic networking we're talking here.
     

    #89
  10. leotoro
    Donut Sep 12, 2014

    leotoro , Sep 12, 2014 :
    I have problem with connection to two different Wi-FI AP roters when is set they SSID to hidden (SSID is not broadcast). On 5GHz and 2,4GHz using Draytek vigor 2850vn and 2,4GHz on TP-Link TL-WR543G.
    My phone OS - CyanogenMod 11.0-XNPH30O on Oneplus One 64GB

    Is there a fix for this ?
     

    #90
  11. izrealgood
    Gingerbread Sep 13, 2014

    izrealgood , Sep 13, 2014 :
    Chai


    I cannot connect to my home router. I followed your comments. And go ip static and put wifi manually. As you said it shows wrong settings. I copied the settings from my nexus into oneplus. However it did not work. It is authenticating but then nothing.

    1). Should DNS 1 always be 255.255.255.0? My nexus shows different - more like 192 etc. also 255.255.255.0 shows up as sub net mask.

    2). will this be solved by Ono with a software update?

    Appreciate your comments.
     

    #91
  12. izrealgood
    Gingerbread Sep 13, 2014

    izrealgood , Sep 13, 2014 :
    Chai


    I cannot connect to my home router. I followed your comments. And go ip static and put wifi manually. As you said it shows wrong settings. I copied the settings from my nexus into oneplus. However it did not work. It is authenticating but then nothing.

    1). Should DNS 1 always be 255.255.255.0? My nexus shows different - more like 192 etc. also 255.255.255.0 shows up as sub net mask.

    2). will this be solved by Ono with a software update?

    Appreciate your comments.
     

    #92
  13. Daniel Bray
    Ice Cream Sandwich Sep 13, 2014

    Daniel Bray , Sep 13, 2014 :
    Do you have the snapdragon batteryguru app installed? This caused many wifi problems for me
     

    #93
  14. EaGllE
    Gingerbread Sep 18, 2014


    #94
  15. firewire2035
    KitKat Sep 18, 2014

    firewire2035 , Sep 18, 2014 :
    yup, this. still need to play around to get reproducible consistency. but the problem is definitely there.
     

    #95
  16. EaGllE
    Gingerbread Sep 23, 2014

    EaGllE , Sep 23, 2014 :
    I found a solution. Use some default theme and it will work perfect.
    It was problem in may case.
     

    #96
    Nick1402 and firewire2035 like this.
  17. czar4you
    Jelly Bean Sep 23, 2014

    czar4you , Sep 23, 2014 :
    I have similar problem. Connecting automaticly to wifi does not work after nightlies. I have to turn off and then turn on the phone
     

    #97
  18. EaGllE
    Gingerbread Sep 23, 2014

  19. carbelmar
    Honeycomb Sep 26, 2014

    carbelmar , Sep 26, 2014 :
    Same problem, since a few days ago.
    Airplane mode does the trick, voted in Jira anyway
     

    #99
  20. krusade
    Jelly Bean Sep 26, 2014

    krusade , Sep 26, 2014 :
    just restart wifi and it should work