10

Lineage OS 14.1 [Nougat 7.1] for Oneplus 2 (cm14.1 continuation)

  1. spencer1620 Ice Cream Sandwich Jan 16, 2017


    #21
  2. empty659 Froyo Jan 19, 2017

    empty659, Jan 19, 2017 :
    Hello
    Im not able to install any app from Google Play. Any workaround?
    Thanks
     

    #22
  3. Daktak Cupcake Jan 20, 2017

    Daktak, Jan 20, 2017 :
    This build includes microG and expects you to use alternative options like Yalp from F-Droid. MicroG is an alternative implementation of Google Cloud Messaging to allow apps built with that service to continue to function. If you remove /app/FakeStore and /priv-app/GmsCore maybe you can flash GAPPS (untested).

    If you want to install GAPPS then I recommend Grarak or Seraph08's build. You should be able to dirty flash them over this.
     
    Last edited: Jan 20, 2017

    #23
    Seraph08 likes this.
  4. semaj81 Donut Jan 20, 2017

    semaj81, Jan 20, 2017 :
    I feel stupid asking this... so you don't flash Gapps with this? Oh boy.. No wonder I've been noticing odd behavior.
     

    #24
  5. Guusjah Cupcake Jan 23, 2017

    Guusjah, Jan 23, 2017 :
    I switched 8 months ago to CM. ANT+ Never worked (well the ant checker works but not the HR sensor).

    Thanks Hochalex, I'll give it a shot and see if it works. I'll report back!
     

    #25
  6. Guusjah Cupcake Jan 23, 2017

    Guusjah, Jan 23, 2017 :
    @semaj81, i'm running on DAKTAK and I had NanoGAPPS installed on my CM14.1. Only the etar app crashes sometimes after boot, other than that the build is silky smooth and performing excellent.
     

    #26
    semaj81 likes this.
  7. vudz_kostek Cupcake Jan 29, 2017

    vudz_kostek, Jan 29, 2017 :
    After latest update (2017.01.24) I've lost root access (in dev options I can only see two options: disable and adb only). Also I can't download nor update any application from play store. I tried many ways of resolving the second issue but no luck :( anyone has same problems? I did dirty flash from version 2017.01.08 with "Wipe dalvik/cache"
     

    #27
  8. duncle Froyo Jan 30, 2017

    duncle, Jan 30, 2017 :
    Hello! My phone is stuck in a reboot loop. Well, actually, it's stuck on the startup animation (the screen never flashes black).

    I've never done anything custom with my phone. This will be a learning process. I really liked CM on my OPO. Would y'all recommend Lineage for me now? My OS priorities right now are 1. stability, 2. customizable experience/app permissions, 3. to not have to do something like this again--it's not a hobby i want to develop, no offense ;)

    If not Lineage, what would you recommend? Thanks in advance.
     

    #28
    NunoLindo likes this.
  9. Daktak Cupcake Jan 31, 2017

    Daktak, Jan 31, 2017 :
    Lineage will remove root, you can add via this flashable zip
    http://www.lineageosrom.com/2017/01/download-supersuzp-and-su-removalzip.html

    Also see https://shadow53.com/no-gapps/ for information regarding microG.

    If FakeStore fails microG check please remove /system/app/FakeStore using TWRP file manager (or root file browser) and install FakeStore.apk from https://microg.org/download.html

     
    Last edited: Jan 31, 2017

    #29
  10. Daktak Cupcake Jan 31, 2017

    Daktak, Jan 31, 2017 :
    I had Etar as the calendar as the in-built one crashed for me. Now that Etar also crashes I've reverted back to AOSP calendar. I then disable it and install Etar.
     

    #30
  11. Daktak Cupcake Jan 31, 2017


    #31
  12. ticevi Cupcake Feb 1, 2017

    ticevi, Feb 1, 2017 :
    I have installed the current nightly without superuser. And have problems with the gapps (stock) . The most apps work fine but the clock und Gboard crash when launched
     
    Last edited: Feb 1, 2017

    #32
  13. jchang19 Donut Feb 2, 2017


    #33
  14. yagoub fathi Donut Feb 4, 2017


    #34
  15. Majidnourollahi Eclair Feb 4, 2017


    #35
  16. takui Cupcake Feb 6, 2017

    takui, Feb 6, 2017 :
    Hello, any chance to make the screenmirror working? Im using this rom cos its more stable than halogenos, but in halogen the screeb mirror worked...hope to see it in a closer release!
     

    #36
  17. rcrack2k Cupcake Feb 21, 2017

    rcrack2k, Feb 21, 2017 :
    I have the same issue. Clock and Gboard crash on startup. Also i am not able to change my background PixelLauncher is crashing if i try to change the background.

    This issue also exists on CM 14.1 build in November.

    How can this be fixed?

    LOS: 20170214 / GAPPS: Stock 20170219
     

    #37
  18. Tsaravan Donut Feb 21, 2017


    #38
  19. ShortyEx Ice Cream Sandwich Feb 21, 2017

    ShortyEx, Feb 21, 2017 :
    No it isn't, you do need an unlocked bootloader and a custom recovery (TWRP) amongst other things. I recommend you to follow the steps in this sticky thread: https://forums.oneplus.net/threads/...wrp-root-nandroid-efs-backup-and-more.345478/

    Also the EFS backup is very important, do not skip that step.

    Rooting is only something you do with your installed ROM to gain more control over it. For example changing your build.prop file to change the DPI etc.
     

    #39
    Tsaravan likes this.
  20. NunoLindo Donut Feb 24, 2017

    NunoLindo, Feb 24, 2017 :
    Hi guys,

    When I try install the new update (lineage-14.1-20170222-nightly-oneplus2), is giving a problem, on the loading screen (when is installing the update), it's always resarting the phone, and not install the update. And I had to install the previous update again
    Any of you is having this problem?
     

    #40