8
Network/Connectivity Losing mobile data and needs reboot to get it back for a while

  1. antoinerev
    Froyo Jan 12, 2017

    antoinerev , Jan 12, 2017 :
    Hi,
    My OnePlus X and my wife's are suddenly losing data signal several times a day. Putting airplane on/off doesn't work we have to reboot the device to get the data signal back. WiFi works fine and voice call is not impacted.
    We are on the same carrier (FreeMobile in France) but I have a third sim on this carrier for my home LAN (on 4G) and it still works OK. The phone sims have been bought 10 months appart so the probability that they both fail at the same time seems low.
    Last detail : we have good 4G signal where we live.

    We are on the latest OOS : 3.1.4 and I didn't notice any update recently, so I have no clue why this is happening... I saw some threads related to this on other forums but they were on old OS/Cyanogen and I couldn't do what they suggested to do (choose European bands).

    Any help/thoughts will be appreciated!
     

    #1
  2. Kéno40
    Jelly Bean Jan 12, 2017


    #2
    antoinerev likes this.
  3. a33g
    Cupcake Jan 13, 2017

    a33g , Jan 13, 2017 :
    I have the same exact issue on my One Plus 3. its running Oxygen OS 3.2.8. For me it tends to happen almost always when i deliberately turn wifi off, so i can use the mobile data instead. However if im out of range of wifi & it changes by its self to data it seems to be fine.

    Cheers
     

    #3
  4. antoinerev
    Froyo Jan 13, 2017

    antoinerev , Jan 13, 2017 :
    Thanks for your input @Kéno40, No it doesn't bring data back.

    @a33g : strange. But more strangely for me, the behavior is hard to replicate. A few days ago if I put WiFi on and off data wouldn't come back (any data, not only 4G). I tested again this morning and now data comes back normally (but maybe with more delay than usual) but still drops at random times...

    I will reinstall OOS 3.1.4 although this is already a clean install for both phones as they had problems with autorisations after the initial OA update...
     

    #4
  5. Kéno40
    Jelly Bean Jan 13, 2017

    Kéno40 , Jan 13, 2017 :
    What I would do :
    In the settings (not in the "réseaux" part, bur in the save & restore part I think), there is an option to erase all the infos about data, wifi...
    I would cut the restoaration of the data not to bring back the bug, then erase all the reds data (you will have to record again your wifi, sorry...), then reflash full rom zip and wipe caches.
    See If it comes back after that.
     

    #5
    antoinerev likes this.
  6. Mykson
    Ice Cream Sandwich Jan 14, 2017

    Mykson , Jan 14, 2017 :
    I had the same issue.
    For me it worked to enable "mobile data always on" in Developer Settings.
     

    #6
    adrian_vg and antoinerev like this.
  7. antoinerev
    Froyo Jan 16, 2017

    antoinerev , Jan 16, 2017 :
    Thanks @Kéno40 , it corroborates what I read on other threads and I did it yesterday (every steps). Unfortunately it didn't work and even the WiFi disconnected while charging last night! I had to turn WiFi off and on to reconnect.
    So I'm going to open a ticket to One+ support.
    I'm also going to ask for a new SIM card from Free just in case.
     
    Last edited: Jan 16, 2017

    #7
  8. antoinerev
    Froyo Jan 16, 2017

    Last edited: Jan 19, 2017

    #8
    Mykson likes this.
  9. Kéno40
    Jelly Bean Jan 16, 2017

    Kéno40 , Jan 16, 2017 :
    Not sure it's the phone then...
    I noticed yesterday on my girlfriend's Xiaomi that at some moment, she has no red. Then it comes back 5 minutes after. She's on an orange antenna.
     

    #9
    antoinerev likes this.
  10. antoinerev
    Froyo Jan 16, 2017

    antoinerev , Jan 16, 2017 :
    Just chatted with the support (in French and super nice). And the guy made me delete and manually reenter the APNs. Testing this today and in case of failure I'll recontact him and he will reinstall remotely he said... I'll keep you updated.
     

    #10
    whateva88 and phb_fr like this.
  11. stephane_A
    Eclair Jan 18, 2017

    stephane_A , Jan 18, 2017 :
    Hello,
    I have the same behaviour one my phone, it worked until January the 6th (approximately) and since I have to reboot the phone or extract the SIM card to have data access again.
    Did Free made some changes to their parameters that affect only 1+X users? My wife and colleagues do not suffer from this loss of data access, they have different phones and are on a Free network.
    Can you post here the APN you have?
     

    #11
    antoinerev likes this.
  12. Raviteja Kalagoni
    Cupcake Jan 18, 2017

    Raviteja Kalagoni , Jan 18, 2017 :
    In OnePlus X Go to Settings -> SIM Cards -> Deactivate the and reactive
     

    #12
  13. stephane_A
    Eclair Jan 18, 2017

    stephane_A , Jan 18, 2017 :
    It does not work if you have only one SIM, message says :"it is not possible to deactivate all the SIM cards".
     

    #13
  14. stephane_A
    Eclair Jan 18, 2017

    stephane_A , Jan 18, 2017 :
    I noticed this bug when I changed a parameter in my APN. I added the MMSC parameter without adding the word mmsc to the APN Type entry.
    I lost GSM data access, saw my mistake with MMSC and when I reverted to the default parameters I think it added the parameter "hipri" to the APN type. This might be the culprit as my phone behaves correctly now. When I use the Wifi network and goes back to the GSM network I have data access.
    Please try this and tell me if it works also on your devices.

    Update: it looks like this does help a little bit but I stil face some data access loss after a wifi connection.
     
    Last edited: Jan 18, 2017

    #14
  15. antoinerev
    Froyo Jan 19, 2017

    antoinerev , Jan 19, 2017 :
    @stephane_A following Support instructions I deleted both APNs and reentered them manually with data from Free website. It works very unreliably: sometimes it gets data back after WiFi but most of the times not.
    I will contact support again has planned, for a remote reinstall but also free to make sure they didn't change something on their side.

    [EDIT] I just updated APNs with these parameters from Free (https://mobile.free.fr/assistance/65.html) which include the "hipri". I will report here.


    [EDIT 2] It seems a lot better already, the LTE symbol stays on the data logo in the controls tray even when on WiFi has it used to be and switch from WiFi to data is instant again.
     
    Last edited: Jan 19, 2017

    #15
    whateva88 and vlungenstrass like this.
  16. antoinerev
    Froyo Jan 20, 2017

    antoinerev , Jan 20, 2017 :
    After initial hope, it fails less often but still does and needs a reboot to recover mobile data.
     

    #16
    vlungenstrass likes this.
  17. Mykson
    Ice Cream Sandwich Jan 20, 2017

    Mykson , Jan 20, 2017 :
    Maybe you have to reset your phone? Or use another ROM?
    But maybe that's a Nougat issue.
    Good luck
     

    #17
  18. Tanvirn23
    Cupcake Jan 22, 2017

    Tanvirn23 , Jan 22, 2017 :
    Same thing happened to me on my old carrier. I changed the carrier service provider and now it works fine.
     

    #18
  19. Neibaf63
    Cupcake Jan 23, 2017

    Neibaf63 , Jan 23, 2017 :
    I have the same issues here with my One Plus X since about 2 weeks and I'm also with Free so maybe the problem is coming from them, no ? compatibily issues ?
     

    #19
  20. stephane_A
    Eclair Jan 24, 2017


    #20