0
OxygenOS MAC-HELP- Oxygen os revert back to cm 11 on Mac

  1. moslimh
    Cupcake Feb 13, 2018

    moslimh , Feb 13, 2018 :
    ok so I got oxygen os and regret it, I have been searching how to go back to cyanogen mod and have not been able to find anything helpful at all. I have oxygen os on one plus one and bootloader is unlocked, but I don't know how to install Custom recovery like TWRP or how to flash it. Everything I can find is all on windows, I am looking for tutorials or how to's for those with a Mac, thanks.
     

    #1
  2. Krusadr
    Cupcake Feb 25, 2018

    Krusadr , Feb 25, 2018 :
    Hey @moslimh I figured out how to do this stuff on my MacBook Air as I too wanted to flash Cyanogen OS 13.1 back onto my OnePlus One.

    However, I tried flashing the latest Cyanogen OS build 13.1 but was unable to set it up with Google as I got the error Unable to connect to Google servers, Try again later.

    I searched a bit and decided to flash the latest nightly build of Lineage OS.

    The procedure can be found by searching online.

    1. First you need to download the Android SDK tools to your Mac from here: https://developer.android.com/studio/index.html#downloads

    Scroll down to "Get just the command line tools" and download the Mac version of the SDK tools named sdk-tools-darwin-xxxxxxx.zip

    2. Unzip the file and place the contents somewhere in your Users folder.

    Open terminal on your Mac and type cd ~ and press enter, then type pwd and press enter.

    The cd command with ~ will take you to your "home" folder and the pwd command outputs the present working directory (or folder).

    Copy the output of pwd command and open another finder window and press Command+Shift+G (Or while in Finder, click on the Go menu in the top bar and click on Go to folder).

    Paste the pwd command's output into the Go to the folder dialog and click on Go.

    You should now be in your home directory in Finder.

    Place the extracted SDK tools folder here.

    Make sure that the folder structure is like
    Users > {your username} > {android sdk folder} > build-tools, emulator, extras, platform-tools, etc

    3. Add the platform-tools path to your PATH environment variable so that it can be accessed from anywhere:

    In your terminal, type cd /Users/{your username}/{android sdk folder}/platform-tools and press enter.

    Now type pwd and press enter to output the path to platform-tools folder and copy it.

    Copy the following and replace /Users/{your username}/{android sdk folder}/platform-tools with the path you copied above and press enter:
    echo 'export PATH="/Users/{your username}/{android sdk folder}/platform-tools:$PATH"' >> ~/.bash_profile

    After you've executed the above command successfully, close the terminal and re-open it and type "adb /?" which should output a lot of text which if you scroll up should show the version of Android Debug Bridge.

    If you see the version of adb from above command, congrats! Your Mac is now ready to flash!

    4. Now you can follow all flashing instructions found anywhere which are for windows, like fastboot / adb commands.

    Just let me know if you are unable to do it and will try to help you out!
     

    #2
  3. Silent_One
    Cupcake Feb 26, 2018

    Silent_One , Feb 26, 2018 :
    Krusadr, Thanks for the guide. I have the same problem. Would you explain an issue I'm running into? I don't have a folder called 'platform-tools.'

    I downloaded the command line tools here: https://developer.android.com/studio/index.html#command-tools

    it downloaded and auto extracted to a folder called 'tools'. I moved tools to /users/~myuser~ and now I'm stuck. I don't have a file or folder called 'platform-tools.'

    Is that a generic placeholder for something or am I actually supposed to have that file?



     

    #3
  4. Krusadr
    Cupcake Feb 26, 2018

    Krusadr , Feb 26, 2018 :
    Hey @Silent_One,

    I'm sorry, You would need to do an extra step:

    Go to the tools folder in your terminal and type this and press enter:
    ./sdkmanager "platform-tools"

    This should get you the folder called platform-tools downloaded.
     

    #4
  5. Silent_One
    Cupcake Feb 27, 2018

    Silent_One , Feb 27, 2018 :
    Thanks Krusadr,

    I got that to work. I ran into another problem working through your guide though. When I type "adb /?" I get 'command not found'

    I'm doing this on OSX 10.13.3

    did I get the adb installation wrong, or is OSX somehow incompatible and I just wasn't aware?
     

    #5
  6. Krusadr
    Cupcake Feb 27, 2018

    Krusadr , Feb 27, 2018 :
    @Silent_One, If you are getting the error command not found, try closing terminal and opening since any cahnges by export command are only available when terminal is restarted. If you still see command not found, then type:
    echo $PATH
    and in the output of your echo command you should see the platform-tools folder. If not, then you haven't set your PATH environment variable using the export command properly.
     

    #6
  7. Silent_One
    Cupcake Feb 28, 2018

    Silent_One , Feb 28, 2018 :
    Thanks for the help Krusadr, I got it to work! Much appreciated!
     

    #7