[mac Os X] Mac Toolkit For Unlocking, Flashing, Rooting

Thread Status:
Not open for further replies.
  1. Mechanical
    Gingerbread Jul 7, 2014

    Mechanical , Jul 7, 2014 :
    Hello everyone!

    Since there was such a demand for a OS X Toolkit, I've made one. It's quite simple and is made in Bash. It should work on all OS X versions.

    It has been downloaded over 700 times on MediaFire alone and has been tested by several members including myself. Thanks to all the testers, you guys are awesome!

    * OS X
    * A OnePlus One
    * Cable to connect to your Mac (needs to be able to transfer data, if one cable doesn't work try another!)

    That's it.

    What it can do:
    * Instructions to enable USB Debugging.
    * Unlock or lock the bootloader of your OnePlus One
    * Flash a custom recovery or the stock recovery (TWRP, CWM, PhilZ, Stock)
    * Can root the OnePlus One (SuperSU)
    * Reflash the entire device back to stock
    * Install ADB and Fastboot to your Mac for manual use
    * Do some basic ADB/Fastboot commands like rebooting, checking bootloader status and sideloading.
    * Remove the tamper bit.

    It's all one application that you need to run. It's quite simple and I've tried to make it as user friendly as possible. Hopefully it'll work for you. If it doesn't, please post in the thread and I'll probably take a look, same goes for bugs or such things.

    Please remember that the application must not be renamed, otherwise it won't work properly.

    Thanks to the creators of the recoveries and Chainfire for SuperSU. Those are the real devs. Thanks to the testers who have a OnePlus One and who wants to use this!

    The source is available inside the application in Contents/Resources/Scripts, it doesn't have any comments or anything, but should be so straight forward that reading it shouldn't be a problem.




    Ver 1.2.8

    - Updated stock image to XNPH38R.
    - Updated the stock recovery to XNPH38R's recovery.
    - Added an experimental way to restore the old blue lockscreen.

    Ver. 1.2.6
    - Updated the TWRP image
    - Updated SuperSU binary to 2.02.
    - Removed unnecessary(?) reboot command at the end of the bootloader unlock menu.
    - Updated the "reflash back to stock" image to XNPH33R.

    Ver. 1.2.4
    - Updated the TWRP image to

    Ver. 1.2.3
    - Made it clear that booting custom recoveries without unlocking the bootloader is impossible in OTA 30O or later.
    - Made the DMG automatically open after mounting.
    - Changed the wget binary to another one. The previous wget was likely built with my personal OpenSSL setup from Homebrew and was thus not compatible with everyone.
    - Small fixes

    Ver. 1.2.1
    - Big bug fix to rooting without installing a bootloader (rebooted you previously into recovery when it was supposed to reboot you into fastboot). Thanks to Nandmp for finding that one.
    - Removed the "You need an unlocked bootloader to root" information in the rooting menu.
    - Removed a few sudos that weren't necessary.
    - Minor fixes here and there.
    - Added a honorary thanks to laiacher for sending me an invite!

    Ver 1.2
    - Added a way to lock the bootloader.
    - Added a special way to unlock a relocked bootloader without wiping the phone it can also remove the tamper bit!
    - Made it possible to root the phone without installing a custom recovery.
    - Made it easier to reflash back to stock. It now downloads and the factory image automatically in a designated folder.
    - Added locking in the basic adb/fastboot commands.
    - Added reflashing the stock image by using a manually downloaded factory image in the basic commands.
    - Loads of fixes here and there.

    Ver. 1.15
    - Fixed critical bug in reflashing back to stock for 64GB devices (thanks to X10D3 of XDA for finding this one)
    - Added "boot any custom recovery without installing it" to the basic fastboot commands.

    Ver. 1.1
    - It can now be run from anywhere!
    - Added new custom logo and DMG style
    - Problem where some people couldn't open the application due to multiple terminals should be fixed now.
    - Fixed compression issue. It's now around 45MB again.

    Ver. 1.05:
    - Added a way to check the current lock status of the bootloader in the basic commands center.
    - Small changes to the instructions when unlocking the bootloader.
    - Reshuffled Installing ADB/Fastboot and some basic commands.
    - Made some small changes to the basic commands menu to make it a little neater and easier to use with some extra instructions for certain commands.

    Ver. 1.02:
    - Removed warranty disclaimer since OnePlus does actually not invalidate your warranty by unlocking.
    - Included further important steps to flash a custom recovery.
    - Added the ability to install ADB and Fastboot into the system for manual use in the terminal.
    - Added some basic commands you can do without installing ADB/Fastboot to the system like rebooting.
    - Added version to About.
    - Updated screenshot below.

    Ver. 1.00:
    -Initial release.

    Q: It won't start!
    A: Make sure the OneToolkit application is located in the normal Applications folder where you usually have apps and that it is not renamed. Then download and run this: https://www.mediafire.com/?7emr4jumb58b4gd

    Q: I'm being asked to put in a password?
    A: That's your Mac's password. It's the same you log in with and the same you use to install apps onto your Mac. It will not show you writing anything when the password is being input. Type it slowly and you'll be fine.

    Q: I'm getting other errors!
    A: Please ask and/or search in the thread and I'll answer it and/or fix it.

    Here's a screenshot:
    Last edited: Oct 18, 2014

    mayoralito, Motuke17, qmmr and 208 others like this.
  2. Matt7262
    Ice Cream Sandwich Jul 7, 2014

    salimit, StereoPhantom, krxz. and 2 others like this.
  3. magischerherbst
    Ice Cream Sandwich Jul 7, 2014

    magischerherbst , Jul 7, 2014 :
    Super! Thanks a lot for sharing!
    This is a MUST for me. ;)
    I'll definitely try this out when I get my One. But only God knows when...

  4. jase33
    Jelly Bean Jul 7, 2014

    Deactivated User likes this.
  5. AdmiralNimitz
    Froyo Jul 7, 2014

  6. Deactivated User
    Jul 7, 2014

    Mechanical and magischerherbst like this.
  7. jase33
    Jelly Bean Jul 7, 2014

    jase33 , Jul 7, 2014 :
    Booo..Hissss!!! :D

  8. magischerherbst
    Ice Cream Sandwich Jul 7, 2014

    magischerherbst , Jul 7, 2014 :
    Then keep us updated, please.

  9. Deactivated User
    Jul 7, 2014

  10. AbuKole
    Gingerbread Jul 7, 2014

    AbuKole , Jul 7, 2014 :
    Sorry to ask what is probably a dumb question, but how do I run this after I've downloaded the .zip file to Applications? I've used a Mac Toolkit for my nexus devices in the past, and I've used Terminal to run (bash) the .sh. But I'm not sure how to start this. Thanks for your help.

  11. domi39
    KitKat Jul 7, 2014

    domi39 , Jul 7, 2014 :
    thanks for sharing so everyone can see

    StereoPhantom likes this.
  12. anish3232
    Gingerbread Jul 7, 2014

    Deactivated User likes this.
  13. Maxl
    Ice Cream Sandwich Jul 7, 2014

  14. Mechanical
    Gingerbread Jul 7, 2014

    Mechanical , Jul 7, 2014 :

    1. Unzip it anywhere, doesn't matter.
    2. Open up the dmg file.
    3. Go into Finder (the blue face where you find your files) and look at the left side, you'll find a OnePlus One Toolkit mounted there, open this up.
    4. Drag and drop the application (called OneToolkit) into the Applications folder there.

    Here's a small guide:

    Check the "DMG files" part here, it's exactly like this: http://www.howtogeek.com/177619/how-to-install-applications-on-a-mac-everything-you-need-to-know/
    Last edited: Jul 7, 2014

    ronoldo, jaysmoke, Maynard100 and 3 others like this.
  15. AbuKole
    Gingerbread Jul 7, 2014

    AbuKole , Jul 7, 2014 :
    Thanks for the tip. It worked like a charm for opening the ToolKit. However, I can't seem to get past the bootloader unlock. It wiped my phone, which I assume means it worked, but I can't seem to flash a custom recovery.

    Mechanical likes this.
  16. Mechanical
    Gingerbread Jul 7, 2014

    Mechanical , Jul 7, 2014 :
    If it's wiped, it's 99% sure unlocked. You can maybe see it's status on the fastboot screen. I assume it's looks like this? If it does, you can see it on the bottom there with "Locked state - Unlocked", if it doesn't look like that, then I'm still pretty sure it's unlocked anyway.

    Is there some part of the custom recovery that isn't working? Which of them are you trying to flash? Where does it stop? Any errors?

    Thank you very much for testing it! Feedback means a lot!

    willard1, ronoldo, laiacher and 2 others like this.
  17. BiffTirkle
    Gingerbread Jul 8, 2014

    BiffTirkle , Jul 8, 2014 :
    when i try to unlock the bootloader it requires me to type "y" accept the disclaimer. i type y and hit enter and it tells me to read it again and i type y. and it just keeps going on the same. nothing happens.

    and this is what i get for skimming the disclaimer.....
    Last edited: Jul 8, 2014

    ronoldo likes this.
  18. AbuKole
    Gingerbread Jul 8, 2014

    AbuKole , Jul 8, 2014 :
    Can't tell if trolling, 5/10.

    Seriously, read the whole disclaimer. Then type understood.

    6/10. I kind of took the bait.

    ronoldo likes this.
  19. PLPeeters
    KitKat Jul 8, 2014

    PLPeeters , Jul 8, 2014 :
    By the way, the warning is false. Quoting @David S. from here:


    ronoldo and Mechanical like this.
  20. Sparkitux
    Honeycomb Jul 8, 2014

    Sparkitux , Jul 8, 2014 :
    Sorry if you guys hate on me but this has be said.

    First: @Mechanical nice job man well done and thank you for the time put into this.

    But: If one can not use the simple adb and fastbboot tools to flash their device , one probably should not have access to root on their device.

    Sorry all