0

Magisk

  1. RandomDude66613 Gingerbread May 25, 2018

    RandomDude66613, May 25, 2018 :
    After I've done clean install of OxygenOS 5.0.3 I flashed magisk 16 zip, it did install but I had problems with safety net check, I removed magisk, tried to install older versions, no success, now I can't even install back the v16 it just won't show up and even if I do install the manager, it says that the magisk is not installed. I had Magisk v16 on OxygenOS 5.0.2 and there was no issues with safety net. Can anyone tell me what I should do, because it's 5:42 morning and I just gave up...
     

    #1
  2. Sun90 Starting Point Expert May 25, 2018

    Sun90, May 25, 2018 :
    You should wait till the majisk module get updated to be compatible with the latest oos version.
     

    #2
  3. Petjitsu KitKat May 25, 2018


    #3
  4. laupuy Honeycomb May 25, 2018

    laupuy, May 25, 2018 :
    Hi,
    Try latest magisk beta 16.4 (change to beta channel in magisk settings or flash it from twrp).
    Or better, you can dirty flash oos 5.0.3 to remove properly old magisk then flash magisk (stable or beta), reboot.

    Edit.
    Whoa, ninja'd twice :D
     

    #4
  5. Petjitsu KitKat May 25, 2018


    #5
  6. RandomDude66613 Gingerbread May 25, 2018

    RandomDude66613, May 25, 2018 :
    I did it like 3 times already, flash uninstall zip, reboot, flash magisk, no success
     

    #6
  7. RandomDude66613 Gingerbread May 25, 2018

    RandomDude66613, May 25, 2018 :
    I can't install any versions, they just won't show up, and magisk uninstaller gives me error in twrp when I try to flash it
     

    #7
  8. Petjitsu KitKat May 25, 2018

    Petjitsu, May 25, 2018 :
    Screenshot_20180525-131152.jpg
    after installing Magisk, go to the settings and turn off / on these switches
    then check the network ;)
     

    #8
  9. laupuy Honeycomb May 25, 2018


    #9
  10. RandomDude66613 Gingerbread May 25, 2018


    #10
  11. RandomDude66613 Gingerbread May 25, 2018

    RandomDude66613, May 25, 2018 :
    That was the first thing that I did after I flashed the magisk for the first time, but it didn't pass the safety net check anyway...
     

    #11
  12. RandomDude66613 Gingerbread May 25, 2018


    #12
  13. Petjitsu KitKat May 25, 2018

    Petjitsu, May 25, 2018 :
    what TWRP you are using?
     

    #13
  14. RandomDude66613 Gingerbread May 25, 2018


    #14
  15. Petjitsu KitKat May 25, 2018


    #15
  16. laupuy Honeycomb May 25, 2018

    Attached Files:


    #16
  17. RandomDude66613 Gingerbread May 25, 2018

    RandomDude66613, May 25, 2018 :
    I'll probably do the clean install of OxygenOS again, please tell or give me a link to a guide how I can install Magisk and pass the safety net check on OxygenOS 5.0.3, thx
     

    #17
  18. Petjitsu KitKat May 25, 2018

    Petjitsu, May 25, 2018 :
    use the "blu_spark" TWRP
    Wipe - wipes data, cache, and dalvik
    clean installation of OxygenOS over TWRP
    use the beta version of Magisk
    without restarting to install Magisk
    restart the system
    Check if Magisk is installed and set up
    if not back to TWRP and install Magisk again
    restart
    must be functional ;)
    good luck :D
    magisk
    https://github.com/topjohnwu/Magisk/releases/download/v16.4/Magisk-v16.4.zip
    TWRP
    https://forum.xda-developers.com/devdb/project/dl/?id=27655
     
    Last edited: May 25, 2018

    #18
  19. RASTAVIPER Jelly Bean May 25, 2018

    RASTAVIPER, May 25, 2018 :
    Why r u so worried about safety net??
    I had my phone not passing safety net for months now and never had any issues.
    But I know that xposed also can affect this. Do u have it installed?

    Anyway, 5.0.3 works fine with Magisk as 5.0.1 was working before.
     

    #19
  20. RandomDude66613 Gingerbread May 25, 2018

    RandomDude66613, May 25, 2018 :
    I just want to have the apps like Netflix, Snapchat, and my bank app work properly.
     

    #20