5
McLaren MMS not working with WiFi

  1. E1575690365225
    Cupcake Dec 23, 2019

    E1575690365225 , Dec 23, 2019 :
    So I got the 7T pro McLaren, and I'm very annoyed. MMS will not send or receive over WiFi. worked before and now it doesn't. Please fix ASAP. At my house, WiFi is the only signal I have. (live in the country). Very upsetting.
     

    #1
  2. rangerwolfy
    Cupcake Dec 23, 2019

    rangerwolfy , Dec 23, 2019 :
    I havent seen this but I'm willing to try and help verify it for you. Do you have cell signal at all? IE should I try airplane mode with wifi on and try to send an MMS? What app are you using for sending MMS?
     

    #2
  3. E1575690365225
    Cupcake Dec 23, 2019

    E1575690365225 , Dec 23, 2019 :


    rangerwolfy

    I havent seen this but I'm willing to try and help verify it for you. Do you have cell signal at all? IE should I try airplane mode with wifi on and try to send an MMS? What app are you using for sending MMS?​


    I haven't tried to put it in airplane mode yet. I have tried 3 different messenging apps. original app that comes on the phone, Google messenging and Verizon messenging. I can send pics and MMS through FB messenger but that's it. I don't care for FB messenger as default messenging.
     

    #3
  4. E1575690365225
    Cupcake Dec 23, 2019

    E1575690365225 , Dec 23, 2019 :
    just put it in airplane mode and still won't send MMS.
     

    #4
    marshallmaloy likes this.
  5. TheMissionary
    Eclair Dec 24, 2019

    TheMissionary , Dec 24, 2019 :
    I've also been experiencing MMS issues on the 7T McLaren. Haven't gotten it cracked yet. Just happened today. I can send to my wife's phone, and they receive. Cannot receive replies. My non-facebook workaround was to install the Google Hangouts app. That send MMS both ways for me. We were also both on the same wi-fi network at the time of the issue.
     

    #5
  6. kwseattle
    Eclair Dec 25, 2019

    kwseattle , Dec 25, 2019 :
    I'm also having MMS issues over wifi, though it doesn't happen every time. It sometimes works fine. Sometimes it doesn't even work over LTE.

    The T-Mobile store rep changed the settings for wifi calling to prefer cellular network and it seemed to help while we were in the store, but I'm still having issues occasionally.
     

    #6
  7. Loni4
    Cupcake Dec 26, 2019

    Loni4 , Dec 26, 2019 :
    I just purchased the OnePlus 7T Pro McLaren 5g. Set it up yesterday and am having the same problem. I cannot send or receive pics/videos through the regular message app over wifi or the tmobile network. It only works with Facebook messenger. Waiting on call back from T-Mobile customer care. I will repost here if we find a solution.
     

    #7
    TheMissionary likes this.
  8. TheMissionary
    Eclair Dec 27, 2019

    TheMissionary , Dec 27, 2019 :
    If you stumble in to anything with them, do share. Thanks!
     

    #8
  9. Abhilash_PM
    Froyo Dec 27, 2019

    Abhilash_PM , Dec 27, 2019 :
    Hi. I believe that the default 'OnePlus Messages' app doesn't support RCS messages (Multimedia contents) on all carriers yet. Its still under experimental rollouts. If RCS messaging is something you cannot live without, try installing Google's Android Messages app. Recently there has been news that Google's Android messages app is supporting almost all carriers in the US, EU and India.
     

    #9
  10. duboi
    Cupcake Jan 3, 2020

    duboi , Jan 3, 2020 :
    Exact same problem here. While on wifi, I can't send or receive MMS, but on cellular I have no issues. OnePlus support asked me to call T-Mobile to have them add an APN. Currently on phone with T-mobile. This is fustrating...
     

    #10
  11. LT1UltraZ
    Cupcake Jan 4, 2020

    LT1UltraZ , Jan 4, 2020 :
    This problem seems to fix itself. Someday it works like it should and others no matter what I do it doesn't work.
    What solution with any did TMobile provide ?
     

    #11
  12. kwseattle
    Eclair Jan 4, 2020

    kwseattle , Jan 4, 2020 :
    Has anyone had any luck fixing this? Currently my phone is just set to "prefer cellular" with wifi calling, like I mentioned in my last response.
     

    #12
  13. spdsk8race1 , via OnePlus Community App , Jan 5, 2020 :
    when connected to your home wifi, go to the wifi selection page, click the gears next to the connected wifi and under privacy, change it from use randomized Mac to use device mac address.
    if you did the reset network setting under system, make sure you change your preferred network type back to 5G, LTE, 3G, 2G as it default to LTE being the highest.
    delete the T-Mobile incorrect APN message also, it's under OMACP in message settings.
     

    #13
  14. kwseattle
    Eclair Jan 5, 2020

    kwseattle , Jan 5, 2020 :


    spdsk8race1

    when connected to your home wifi, go to the wifi selection page, click the gears next to the connected wifi and under privacy, change it from use randomized Mac to use device mac address.
    if you did the reset network setting under system, make sure you change your preferred network type back to 5G, LTE, 3G, 2G as it default to LTE being the highest.
    delete the T-Mobile incorrect APN message also, it's under OMACP in message settings.​


    I just changed MAC address to device and will try that.

    Can you explain that last part again? I don't have the incorrect APN message anymore, I haven't seen that for a couple of weeks.

    Edit: I'm using Textra so I didn't know where to look. In messages I found them under OMACP, I will delete them.
     
    Last edited: Jan 5, 2020

    #14
    spdsk8race1 likes this.
  15. kwseattle
    Eclair Jan 5, 2020


    #15
    spdsk8race1 likes this.
  16. spdsk8race1 , via OnePlus Community App , Jan 5, 2020 :
    I recommend to delete it because that what caused a issue with my phone, anytime I click that my network flickers. Do a network reset fixes it immediately. I guess I just suggest to delete it so it doesn't accidentally get clicked or triggered somehow.
     

    #16
    kwseattle likes this.
  17. kwseattle
    Eclair Jan 5, 2020

    kwseattle , Jan 5, 2020 :
    So far I've had mixed results just in the last hour or so. Most messages have sent, some not.
     

    #17
  18. spdsk8race1 , via OnePlus Community App , Jan 5, 2020 :


    kwseattle

    So far I've had mixed results just in the last hour or so. Most messages have sent, some not.​


    are you using the built in OnePlus message app, Google message app, Textra?

    is the mixed results over WiFi or mobile network
     

    #18
  19. kwseattle
    Eclair Jan 5, 2020

    kwseattle , Jan 5, 2020 :
    Using Textra, and over wifi. Usually no issues on mobile network.

    I use Textra because I have kept all of my text messages from a few certain conversations for the last 4 years, it's incredibly well optimized so there's no lag at all with the large conversations. I would like to try Google messages but I'm not sure it would keep the old messages.
     

    #19
  20. spdsk8race1 , via OnePlus Community App , Jan 5, 2020 :
    can you disable advanced messaging on the default app, and test again? Textra seems to be aware of some issues recently from carrier advanced messaging and have listed some fixes on their page.
    1578193714699.jpg

    1578193714741.jpg
     

    #20