6
[Answered] Menu button only works occasionally (application dependent!)

Thread Status:
Not open for further replies.
  1. KeyperOS
    Gingerbread Dec 31, 2016

    KeyperOS , Dec 31, 2016 :
    The issue is present on the following firmware: OnePlus3TOxygen_28_OTA_018_all_1612292141_55f4a06cb5cf4dc0
    - Bind the open/close menu action to a capacitive button (by default it is bound to long-pressing the recents button)
    - Try to open the menu of an application that supports it. Tests were done with "Nova Launcher" and "Fancy Widgets".
    The Menu button will not perform its' intended function consistently.
     

    #1
  2. runboy93
    Jelly Bean Dec 31, 2016

    runboy93 , Dec 31, 2016 :
    There is new firmware available, you can wait for OTA for your country or VPN Germany/Canada
     

    #2
  3. KeyperOS
    Gingerbread Dec 31, 2016

    KeyperOS , Dec 31, 2016 :
    The issue is on the Nougat Beta-1 ROM released today.
    It was not present on MM 3.5.4.
     

    #3
  4. runboy93
    Jelly Bean Dec 31, 2016


    #4
  5. KeyperOS
    Gingerbread Dec 31, 2016

    KeyperOS , Dec 31, 2016 :
    The bug-trackers drop-down menu only had this one option, hence why I mentioned the actual ROM version on the description.
     

    #5
  6. KeyperOS
    Gingerbread Dec 31, 2016

    KeyperOS , Dec 31, 2016 :
    Just as a heads-up, the same issue is present on the OFFICIAL OOS 4.0 / Nougat 7.0 ROM released through OTA (which AFAICT is identical to the BETA-1)
     

    #6
  7. PatrB
    Cupcake Jan 1, 2017

    PatrB , Jan 1, 2017 :
    Same for me, Oneplus A3003_28_161231. Menu button doesn't work in older apps.
    Works fine on OxygenOS 3.5.4.
     

    #7
  8. Jogi5
    Ice Cream Sandwich Jan 1, 2017

    Jogi5 , Jan 1, 2017 :
    Same here

    I get the 3-dot-menu with software keys, but the menu of some apps doesn't open by double tab or long press the hardkeys anymore. This is on OSS4.0. It worked with 3.5.4 flawlessly
     

    #8
  9. viper2097
    Gingerbread Jan 2, 2017


    #9
  10. andy.stallwood
    Cupcake Jan 3, 2017

    andy.stallwood , Jan 3, 2017 :
    +1. Which apps do you guys have that do work? I can't get any apps on mine to work using the capactive keys to open the menu. I've tried double and long press on all 3 keys and no joy. Works perfectly on 3.5.4 (have downgraded back to 3.5.4 as I have an app with no menu button on it that I need to use).
     

    #10
  11. walk_the_moon
    Eclair Jan 3, 2017

    walk_the_moon , Jan 3, 2017 :
    +1
    I spotted this bug within the first minute after upgrading. First I thought it's completely broken but soon realized it is app dependent, but even then it's inconsistent.
    Example: When going to gmail, using the menu button in the main window does nothing. However, when composing a new mail withing the app, long-pressing the "recent" button does open a pop-up window with additional options. Again, this works only for new emails, not with the inbox screen of gmail. Other apps are equally hit or miss. Worst is that I no longer can pop up the options windows of Nova launcher, which would allow me to go into phone settings with one click. My current workaround is to click on the settings button in the top right of the notification panel.

    I hope they fix this ASAP, it's an extremely annoying and party-crashing bug

    Btw hello :) New here, just came to report this bug, cheers
     

    #11
  12. catalinus
    Eclair Jan 3, 2017

    catalinus , Jan 3, 2017 :
    Very annoying, that one was a major feature for me in 3.5.3/3.5.4 but is now broken in 4.0.0 :(
     

    #12
  13. xenix
    Cupcake Jan 4, 2017


    #13
  14. von_Marcus
    Cupcake Jan 5, 2017

    von_Marcus , Jan 5, 2017 :
    I have this same issue. Work on Novla Launcher, but it does not matter. On OxygenOS 3.5.4 was fine, after upgrade to 4.0 doesn't work. The menu not shown on the applications as list below:
    Is only one solution for me: enable software button, change what you need and back to hardware button.
     

    #14
  15. Jogi5
    Ice Cream Sandwich Jan 7, 2017

    Jogi5 , Jan 7, 2017 :
    Sadly this error/bug was not fixed with 4.0.1..

    Please fix this, Please.
     

    #15
  16. grox
    Eclair Jan 7, 2017

    grox , Jan 7, 2017 :
    Yes, still present! To be honest I am a bit confused because with OP3 all the bugs were solved real fast, and now I bought better version but it looks like devs are not concerned about serious bugs like volume doesn't go to 0 or this one, damn, why?
     

    #16
  17. catalinus
    Eclair Jan 9, 2017

    catalinus , Jan 9, 2017 :
    I can not understand how this serious bug was not fixed or at least acknowledged, it is quite clear that the function was working properly before 4.x and is extremely easy to repeat so the problems must be with how such defects are managed at OnePlus :mad:
     

    #17
  18. Jogi5
    Ice Cream Sandwich Jan 13, 2017


    #18
  19. Jogi5
    Ice Cream Sandwich Jan 18, 2017

    Jogi5 , Jan 18, 2017 :
    Okay, flashed 4.0.2 today and menu buttons are still broken in some apps..

    That's sad...
     

    #19
  20. walk_the_moon
    Eclair Jan 28, 2017

    walk_the_moon , Jan 28, 2017 :
    Did we get any sort of offical statement on this? Among all the bugs sold to us as "features" this one clearly is a bug in by every definition.
    Oneplus, you there?
     

    #20