0
Other

Mesaage not sent, phone number formatted incorrectly

  1. Siddardha_Kumar Cupcake Sep 17, 2017

    Siddardha_Kumar, Sep 17, 2017 :
    Im continuously receiving a message while sending message "Message not sent, phone number formatted incorrectly".
    I couldn't able to send any message.
    Mobile: One Plus 3
    Operator : Airtel
    Location : Hyderabad, India.
    Problem identified : After update.
    Updated screen shot in this thread.
    Kindly solve this issue.
    Thanks in Advance,
    Siddardha Kumar.
     

    Attached Files:


    #1
  2. Android450 Marshmallow Sep 17, 2017


    #2
  3. Siddardha_Kumar Cupcake Sep 17, 2017

    Siddardha_Kumar, Sep 17, 2017 :
    Not only to single contact, but it is happening to every contact in my phone.
     

    #3
  4. Android450 Marshmallow Sep 17, 2017

    Android450, Sep 17, 2017 :
    try with the Android messages app. the stock one tends to have too many issues
     

    #4
  5. Siddardha_Kumar Cupcake Sep 17, 2017


    #5
  6. Android450 Marshmallow Sep 17, 2017

    Android450, Sep 17, 2017 :
    Can I see a screenshot of the icon? Because then that would mean it would be on Google to fix since it's they're app
     

    #6
  7. Siddardha_Kumar Cupcake Sep 17, 2017

    Siddardha_Kumar, Sep 17, 2017 :
    Screenshot_20170917-083359.png
     

    #7
  8. Android450 Marshmallow Sep 17, 2017


    #8
  9. Siddardha_Kumar Cupcake Sep 17, 2017


    #9
  10. Android450 Marshmallow Sep 17, 2017

    Android450, Sep 17, 2017 :
    Ok let's try this, download the 4.1.7 update from the website and flash it on your phone again. No need to format just flash it and clear cache afterwards.
     

    #10
  11. OptimusPrime7 Donut Oct 26, 2017

    OptimusPrime7, Oct 26, 2017 :
    Is the problem solved? Because I'm also having the same issue using the Airtel SIM in my onepus 3.
     

    #11
  12. U1513200924724 Cupcake Dec 13, 2017

    U1513200924724, Dec 13, 2017 :
    I'm a newbe here,

    Well I dunno why kelerman's post hasn't been removed. I think I may not be on a very good forum.

    However......I've spent hours trawling the net to overcome this problem. I tried the sim in another phone - same problem which makes one suspect the network. Phoned EE support - a really cheery and willing guy called Eric from Waterford. With what I had gained from my research and his encouragement I found the answer. The SMS messaging centre's number was set to my own phone number so instead of being sent on I was unsuccessfully trying to send messages back to myself. On my OnePlus 3 the SMS information is very well hidden and don't think you'll find it in any settings on the phone. What you have to do is to "phone" *#*#4636#*#* You will get a page labelled Testing with three sub headings the top one is Phone information. Click on this and you get a lot of information; scroll down until you get to SMSC:. In here you have to put inverted commas followed by the telephone number of your SIM supplier (Get it from them - unless you can find it on the Internet) followed again by inverted commas. Click the update button and, in my case, it added a comma and 145 to the SMS number still in inverted commas. I'm not sure if having my own phone number in Messages>three vertical dots at top right>Settings>Advanced>Phone Number caused this and if you manage to fix the problem by putting the correct SMS messaging centre number in there I'd be pleased to know.
    Glad to have solved the problem and hope this helps others.
     

    #12
    la_poP likes this.
  13. Nutribar Cupcake Dec 14, 2017

    Nutribar, Dec 14, 2017 :
    I had the same issue on my moto g4+. Thing was that I was logged in with my school email and it was not allowing me to send msgs because I did not have my school email synced with my phone number. All I had to do to send msgs again was go into settings>Google>sign in and security>pick the Gmail that you used when you set up the phone the first time. Hope this helps.
     

    #13
  14. la_poP Cupcake Dec 19, 2017

    la_poP, Dec 19, 2017 :
    This worked for me - thank you!

     

    #14