0
Messed up root during update, tried to flash twrp but now phone is stuck at bootloader warning

  1. M1541567745600
    Cupcake Dec 26, 2019

    M1541567745600 , Dec 26, 2019 :
    Hi all, I updated my One Plus to the newest version but forgot to reinstall Magisk after updating and went ahead and rebooted and lost root access to my phone.
    While trying to restore root, I was not able to start into TWRP (version 3.2.3-x_blu_spark_v9.86), it would stop at the splash screen while my command prompt showed no errors. I looked around and found the steps

    > fastboot getvar current-slot
    current-slot: b
    finished. total time: 0.002s
    > .\fastboot.exe flash boot_b .\twrp-3.2.3-x_blu_spark_v9.86_op6.img
    Sending 'boot_b' (28788 KB) OKAY [ 0.679s]
    Writing 'boot_b' OKAY [ 0.162s]
    Finished. Total time: 0.852s
    > .\fastboot.exe reboot

    I did not realize that was for a different phone model and now my phone will not even start correctly, it is stuck on the bootloader warning screen "<!> The boot loader is unlocked and software integrity cannot be...etc" for the last 10 minutes and going. What did I do to my phone and is it possible to just get it back to start up normally? I am very worried
    Thanks
     

    #1
  2. M1541567745600
    Cupcake Dec 26, 2019


    #2
  3. M1541567745600
    Cupcake Dec 28, 2019

    M1541567745600 , Dec 28, 2019 :
    Update:
    I was able to fast boot flash into twrp (twrp-3.3.1-30-fajita-Q-mauronofrio to be specific). I can see what I believe are my files in the internal storage, but encrypted (file names are all scrambled), however twrp never prompted me for a password, also going to the twrp terminal and entering twrp decrypt <passcode> did not work. Anybody know how to get twrp to decrypt? Any help would be appreciated

    Thank you
     

    #3
  4. M1541567745600
    Cupcake Dec 28, 2019

    M1541567745600 , Dec 28, 2019 :
    Final update: fixed my device completely, turns out I was using the wrong version of the os image, I had 41, needed 42
     

    #4
  5. sfinny
    Donut Jan 4, 2020

    sfinny , Jan 4, 2020 :
    How did you install the latest os image? I am also stuck at the "bootloader is unlocked" screen. I was just trying to install twrp and magisk as per usual after updating using the 10.3 ota.

    I can get into twrp using the fajita-maurnofrio.img file and tried to install the twrp zip (mauronofrio.zip) but still getting stuck at the "bootloader is unlocked" page.

    All of my files look fine when I get into the temp twrp.img.

    Any help?
     

    #5