Mic issue. One plus one microphone not working properly

  1. dommi_donsilver Gingerbread Oct 12, 2015

    dommi_donsilver, Oct 12, 2015 :
    Thanks a lot man, this worked for me.
    But hat if I unroot my phone? How to fix this again? Any intention from Oneplus to fix this??

    Thanks again :)

  2. kip23 Eclair Oct 27, 2015

    kip23, Oct 27, 2015 :
    Touchscreen issues followed by garbled phonecalls due to bad noise-cancelling issues. This OnePlus One phone is really awful.

    ockty3 likes this.
  3. rschueg Cupcake Nov 12, 2015

    rschueg, Nov 12, 2015 :
    I had the same issue, in my case it was solved by disabling the 'OK GOOGLE in every App' feature.

    No rooting or changing other settings neccesary.

    alexDB9 likes this.
  4. androidrootfire Donut Nov 27, 2015

    androidrootfire, Nov 27, 2015 :
    Thank you
    Worked fine

  5. tdpower Donut Dec 2, 2015

  6. alexDB9 Froyo Dec 5, 2015

    alexDB9, Dec 5, 2015 :
    Thanks man,, this worked for me,, you just prevented an embarrassing confrontation with my operator's employees;)

  7. siddug Donut Dec 30, 2015

    siddug, Dec 30, 2015 :
    Thanks! I am using carbonrom and it worked nicely.

  8. Davidred7697 Eclair Jan 17, 2016

    Davidred7697, Jan 17, 2016 :
    If you're also having microphone issues like I did, please make sure to try out this suggestion. Try turning off "ok Google detection from any screen" first. That completely resolved the problem for me. Plus, it helped my battery life a bit.

    No need to modify build.prop or .xml files and risk damaging your device.

  9. mattpgeorge Cupcake Jan 25, 2016

    mattpgeorge, Jan 25, 2016 :
    I was also having the same issue with in call voice quality. This fix worked for me. Thanks.

  10. marthe Cupcake Jan 28, 2016

    marthe, Jan 28, 2016 :
    I may be in the minority, but my issue was hardware related. Suddenly, my mic volume during calls was abnormally low, on and off speakerphone. Rooting and trying most of the software fixes as well as covering the other mics, I still had the issue.

    Since the mic wasn't working in other apps like sound recorder, I figured the mic may have failed. I replaced the microphone flex, and the issue was resolved. Never had that issue before, but I guess you get what you pay for. If the other fixes don't work, this may the culprit.

    I replaced the original battery while I was in there, cost was $30USD shipped for the parts, and it's not too hard.

    This walkthrough steps through it well.


  11. dannylahav Cupcake Mar 6, 2016

    dannylahav, Mar 6, 2016 :
    Hi, I have this problem. I did not found these configuration files on my phone. How do I get into /system directory? Tx, Danny


  12. sequelae Froyo Apr 11, 2016