3
Mic problem during call + OK Google detection

  1. thegios
    Gingerbread Sep 7, 2015

    thegios , Sep 7, 2015 :
    Could someone please verify that by enabling OK Google detection from any page will make call quality bad on the other side?
     

    #1
  2. mwayner
    Lollipop Sep 7, 2015

    mwayner , Sep 7, 2015 :
    Nah. I use it all the time with that setting and have had no complaints.
     

    #2
  3. thegios
    Gingerbread Sep 7, 2015

    thegios , Sep 7, 2015 :
    Well not sure its just a coincidence, but during the last few days I've ppl complaining that they cannot hear me well during a call (metallic voice and/or echo). So I started searching the forum and found many complaining about the same. Someone found out the problem is the 3rd mic on the back for noice cancellation and there's a solution for rooted devices to disable this mic on the back. Then in a couple of threads someone else suggested to disable OK Google detection from all pages, as this seems to interfere somehow...

    So now I have disabled the OK Google detection for testing, but thought that a specific thread to collect feedback would be useful.
     

    #3
    svprsk likes this.
  4. jhovstkepp
    Cupcake Sep 15, 2015

    jhovstkepp , Sep 15, 2015 :
    Hey. I can't confirm for sure if this is so but I had turned on "ok google" detection just this week and persons on the other end of calls have been complaining that they can't hear me intermittently.
    So I did the searching of the forums and saw that someone suggested turning off the "detection on any screen" option. I just did that and I've made one call since which was problem free so fingers crossed this is the issue
     

    #4
    joseqzd likes this.
  5. spinik
    Cupcake Sep 15, 2015

    spinik , Sep 15, 2015 :
    I had the same problem this weekend and solved it by turning off ok Google detection
     

    #5
    joseqzd and Blower like this.
  6. a.void
    Gingerbread Sep 15, 2015

    a.void , Sep 15, 2015 :
    Can confirm this is a bug and the fix mentioned corrects it. Disable Google search from any screen.
     

    #6
    joseqzd and Blower like this.
  7. juliekeJJ
    Froyo Sep 22, 2015

    juliekeJJ , Sep 22, 2015 :
    This helped me! I disabled ok Google now recognition from any screen and people can hear me just fine again! Thank you so much for this solution because I almost wanted to buy another phone!
     

    #7
    et121677 and joseqzd like this.
  8. CaneDrew
    Gingerbread Sep 22, 2015


    #8
    joseqzd likes this.
  9. frostyfurious
    Eclair Oct 2, 2015

    frostyfurious , Oct 2, 2015 :
    It happened the same to me as well, jus curious is it a Software issue or Hardware Issue... want to hit the Customer Service if its a Hardware Issue
     

    #9
    joseqzd likes this.
  10. danielmankarios
    Cupcake Oct 3, 2015


    #10
  11. frostyfurious
    Eclair Oct 10, 2015

    frostyfurious , Oct 10, 2015 :
    So, Guys i tried catching some info from the OnePlus Technical Support Team and was informed that it's a Software Issue and DEV team is working on the fix. However, i faced the issue when i was on CM11 later getting updated to CM12 it was consistent, then jumped to Exodus for a long time and i dint find the issue to occur, now I'm using Resurrection Remix and I'm seeing the issue back on my device, going to use CM12.1 cyanogen build and multiple other ROM's, so i can find the real culprit :p which is messing up with the Ok Google Functionality, will keep the thread posted with my findings if i have any luck.... @mwayner Can we have the Operating System Version name you are using so that i can give that a try aswell.
     

    #11
  12. mwayner
    Lollipop Oct 10, 2015

    mwayner , Oct 10, 2015 :
    COS12.1 Yoga-whatever the hell it's called.
     

    #12
  13. mbeni007
    Donut Oct 12, 2015

    mbeni007 , Oct 12, 2015 :
    Disabling OK Google has helped me. What's weird is that it just showed up out if the blue. I use OK Google all the time so this is not a great "fix" for the phone.
     

    #13
    joseqzd likes this.
  14. kabaka1
    Eclair Oct 12, 2015

    kabaka1 , Oct 12, 2015 :
    Yes it is true that google is interfering with your calls outside. Solution is to disable it and all will be ok, That CM 12.1 update has two issues, that google and that truecaller dialer where you can`t remove your favorites, I think I`m gooing back to CM 12 stock...
     

    #14
  15. childoftheworld
    Donut Oct 21, 2015

    childoftheworld , Oct 21, 2015 :

    Argggh! So what is the use ok OK Google Then when you have to open an APP to activate it?
     

    #15
  16. CaneDrew
    Gingerbread Oct 21, 2015

    CaneDrew , Oct 21, 2015 :
    You don't have to open the app. If you're using the Google Now launcher even if you disable OK Google from any screen, you can still say OK Google from the home screen.
     

    #16
  17. childoftheworld
    Donut Oct 21, 2015

    childoftheworld , Oct 21, 2015 :
    But if you choose to use the CM launcher? *sigh*
     

    #17
  18. frostyfurious
    Eclair Oct 21, 2015

    frostyfurious , Oct 21, 2015 :
    do you say this a software bug on most of the devices, else this is manufacturing defect ?
     

    #18
  19. ZoxTheFox
    Cupcake Nov 4, 2015

    ZoxTheFox , Nov 4, 2015 :
    I've noticed this problem before too - at first I assumed it was an issue with my carrier since I had just moved carriers upon recieving the phone. (EE is the only carrier in the UK that supports LTE on the OnePlus One for now)

    I had done some reasearch and found that yes, it is interference with one of the microphones and "OK Google from any screen". Disabling this will solve the issue for now, but it wont fix it.

    I've also noticed that whenever Google updates, it likes to re-enable this setting. I've found myself disabling the same setting a few times over when people complain of the audio quality in calls. (They explain it as a robotic/garbled noise, the caller is only just understandable) Others may describe it as adding an audio filter like a phaser or a flanger, a quick, intermittent audio ducking effect like you're speaking into a spinning fan.

    I've just received the incremental update COS 12.1- YOG4PAS3JL but haven't yet tested the call quality with "OK Google from any screen" enabled.


    Has anyone got an update from OnePlus or Cyanogen about a fix for this? Would be great to generate some noise on the issue and get some more feedback!

    Zox

    Edit: For those wondering how you might disable the "OK Google from any screen" feature in Google and the Google Now Launcher. Head over to google now and press the "burger menu" (three horizontal lines in the top left corner) and head into the settings.
    Settings > Voice > "OK Google" Detection > From Any Screen
     
    Last edited: Nov 4, 2015

    #19
    joseqzd likes this.
  20. wikz87
    Donut Nov 4, 2015

    wikz87 , Nov 4, 2015 :
    I use Cortana and mobile is behaving badly. I can't record my voice. Voice recorder says MIC already in use.
    Whatsapp, Viber, Skype, Messenger tried all of them but can't use MIC.
     

    #20