0
Third Party Software Minimum Security Requirements Error

  1. Anoop_14
    Froyo Apr 20, 2021

    Anoop_14 , Apr 20, 2021 :
    My device is OP7. It's been a long time since I've been facing the issue in SBI Credit Card App. The error reads: "This mobile device does not meet the minimum security requirements needed to use SBI Card App. Please use another mobile device to access your account via SBI Card App."
    This error comes whenever I tap the icon to open it. Once I formatted my device for the issue but it didn't go away. I contacted SBI Card for it. They have provided updates three times but the issue is still their. The problem is not from their side. This app is smoothly running on OP6.
    My device is neither rooted nor I have ever tried to root it. All the apps I'm using in this devices are downloaded from Google Play Store. Please help me to find out the root cause of this issue. I'm attaching the screenshot for perusal. Thanks.
     

    Attached Files:


    #1
  2. drl431
    Community Hero 2020 Apr 20, 2021

    drl431 , Apr 20, 2021 :
    Hi, did you activate the developer menu? If so, turn it off.
     

    #2
    J4t1np4r3kh and Tokolozi like this.
  3. Anoop_14
    Froyo Apr 20, 2021

    Anoop_14 , Apr 20, 2021 :
    Thanks for your reply. I appreciate your time & support.

    When you reset a device, the developers menu automatically gets turned off. But it didn't resolve the issue.
     

    #3
  4. Bobbie63
    Marshmallow Apr 20, 2021

    Bobbie63 , Apr 20, 2021 :
    What build nor are you on currently, what is the date of the latest security patch, what is the date of the google play system update?

    is the device certified for Play Protect certification?

    couldn’t the SBI Card people tell you what the minimum requirements are?
     

    #4
  5. Anoop_14
    Froyo Apr 21, 2021

    Anoop_14 , Apr 21, 2021 :
    After a long time of research from the web, I found the root cause of the issue. It was a folder named, "TWRP" in phones directory. When I deleted this folder, the app ran smoothly. Literally, I've never thought that a folder can also be a problem for some applications.

    Thanks for your support.
     

    #5
    Bobbie63 likes this.
  6. Bobbie63
    Marshmallow Apr 21, 2021

    Bobbie63 , Apr 21, 2021 :
    So a custom recovery was installed before? That could cause an issue indeed and you have probably, after the reset put the backup back on your phone including the twrp files.
     

    #6
  7. rayprayas03
    Ice Cream Sandwich Apr 21, 2021


    #7
  8. Anoop_14
    Froyo Apr 21, 2021

    Anoop_14 , Apr 21, 2021 :
    Yeah, I had installed a custom recovery image in Motorola G4 plus. When I purchased OP7, I transferred as it is all the internal memory content to it. Hence, the TWRP folder. But, the problem started in Oct 2020, and I purchased it back in June, 2019.
     

    #8
    Bobbie63 likes this.
  9. Anoop_14
    Froyo Apr 21, 2021

    Anoop_14 , Apr 21, 2021 :
    Never. If you are getting regular updates, then, I don't feel rooting is worth. Since, this is my primary phone, I don't do such experiments in it.
     

    #9
  10. Bobbie63
    Marshmallow Apr 21, 2021

    Bobbie63 , Apr 21, 2021 :
    I guess SBI upgraded their minimum security requirements.
     

    #10
    Anoop_14 likes this.

  11. #11

  12. #12