765
Mirrors for official Cyanogen roms & OTA updates

  1. Spannaa
    KitKat Aug 30, 2015

    Spannaa , Aug 30, 2015 :
    The only way to update from COS12 to COS12.1 without losing system settings is to use the OTA.

    If you use the full zip, system will be wiped.

    Your choice - don't be bored and do some work or start again from scratch.
     

  2. tasoik1
    Cupcake Aug 30, 2015

    tasoik1 , Aug 30, 2015 :
    That is what I was afraid to hear....

    We're growing up.....not 25-30 years old anymore.....

    Anyway, thanks for the reply.
     

  3. tasoik1
    Cupcake Aug 30, 2015

    tasoik1 , Aug 30, 2015 :
    If I upgrade with OTA using stock recovery, can I install TWRP with the app flashify without using PC?
     

  4. Mr. James
    Eclair Aug 30, 2015

    Mr. James , Aug 30, 2015 :
    Thank you for your reply.

    When is it necessary do "bootloader unlocked"?
    If I flash stock ROM, after of this, Is it necessary unlock another time the bootloader?

    My problem now is that when I use fastboot for flash the recovery TWRP I don't get any error (say OK) But when I restart the phone in recovery mode I only can see the stock recovery, not TWRP. I've disable CM Recovery Protection and I enable USB Debugging before of flash it.

    I use this comand:
    fastboot flash recovery twrp-2.8.7.0-bacon.img

    but always I get the stock recovery. Any problem with windows 8.1.1 x64 or driver?
    I'm using a windows 8 without update and samsung driver 1.5.51.0.

    I don't know what is the problem.
     
    Last edited: Aug 30, 2015

  5. Spannaa
    KitKat Aug 31, 2015

    Spannaa , Aug 31, 2015 :
    How?

    You need to be rooted to use Flashify and to root, you need TWRP installed...
     

  6. Spannaa
    KitKat Aug 31, 2015

    Spannaa , Aug 31, 2015 :
    The best time to unlock your bootloader is before you install anything. Once its unlocked, it should stay unlocked unless you relock it yourself.

    Disabling CM recovery protection and enabling USB debugging are necessary, but to get TWRP to 'stick' after fastboot flashing it, you need to reboot directly into recovery once too.

    Fastboot flash TWRP again, then disconnect the usb cable.

    Switch off the phone by holding the power button down.

    When it's off, use the power + volume down button combo to boot directly into recovery.

    Reboot system from TWRP.
     

    Mr. James likes this.
  7. Mr. James
    Eclair Aug 31, 2015

    Mr. James , Aug 31, 2015 :
    Amazing, works very fine! thank you! you are the best!!!! :D

    When it opens TWRP I get this message:

    "TWRP has detected an unmodified partition.

    TWRP can leave your partition unmodified to make it easier for you to take official updates. TWRP will be unable to prevent the stock ROM from replacing from replacing TWRP and will not offer to root your device. installing zips or performing adb operations may still modify the system partition.

    Never show this screen during boot again
    Keep Read only
    Swipe to Allow Modifications"


    What I need do now?
    Swipe to allow modifications?

    is it a problem of TWRP 2.8.7.0? is it necessary another version of TWRP?
     

  8. Spannaa
    KitKat Aug 31, 2015

    Spannaa , Aug 31, 2015 :
    As I'm still using Unofficial TWRP 2.8.6.0.4 I haven't seen that message but, If you read the "System read only option" section of this, you'll be able to decide what's the best option for you ;)
     

    Mr. James likes this.
  9. guywong
    Froyo Aug 31, 2015

    guywong , Aug 31, 2015 :
    BTW, TWRP 2.8.7 does not update the baseband from 230 to 241 on the OPO We need TWRP 2.8.6 to do it. You can get TWRP 2.8.6 at this Link.
    http://forum.xda-developers.com/showthread.php?t=2788632
     

  10. guywong
    Froyo Aug 31, 2015

    guywong , Aug 31, 2015 :
    Try this link instead to download TWRP 2.8.6:
    https://dl.twrp.me/bacon/
     

  11. Spannaa
    KitKat Aug 31, 2015


  12. guywong
    Froyo Aug 31, 2015

    guywong , Aug 31, 2015 :
    Sorry. I should have made it clear. My post was meant for Mr. James.
     

  13. Mr. James
    Eclair Aug 31, 2015

    Mr. James , Aug 31, 2015 :
    Thank you. This is solved now.
    But I have another problem xD

    I'm trying to flash "cm-12.1-20150831-NIGHTLY-bacon" from TWRP and I only get the message: "Patching system image unconditionally..." I'm waiting with this message 30minutes!

    I suppose that it doesn't works. How to fix it?

    Is it possible flash cm-12.1-20150831-NIGHTLY-bacon with fastboot? any solution for fix it with TWRP? Is it a problem of my phone? I'm buyed in china! is not the European version!

    Thank you!

    PS in TWRP console, I can read before of "Patching system image unconditionally..." this: "E: Unable to mount 'system' . Is this important?
     
    Last edited: Aug 31, 2015

  14. hlin9
    Honeycomb Sep 1, 2015

    hlin9 , Sep 1, 2015 :
    No, as long as you don't wipe everything, system won't be wiped. I flashed full zip and everything was intact.
     

  15. Spannaa
    KitKat Sep 1, 2015

    Spannaa , Sep 1, 2015 :
    So doesn't the line:
    Code:
    block_image_update("/dev/block/platform/msm_sdcc.1/by-name/system", package_extract_file("system.transfer.list"), "system.new.dat", "system.patch.dat");
    with a full system.new.dat (which contains system.img) and no data in system.patch.dat mean that \system is being replaced?
     

  16. hlin9
    Honeycomb Sep 1, 2015

    hlin9 , Sep 1, 2015 :
    As I said, I flashed full zip file and did not choose wipe data/media etc, only cache, hence no data lost.
     

  17. TempleKiu
    Froyo Sep 1, 2015

    TempleKiu , Sep 1, 2015 :
    Thanks:p
    I just downgrade back to cm11s
    It's much faster LOL

    But Google play services and Google play doesn't seem to be updating:confused:

    May I ask why and how to fix it:)
     

  18. seraph2099
    Eclair Sep 1, 2015


  19. lirdi
    Donut Sep 3, 2015

    lirdi , Sep 3, 2015 :
    I'M HAVING THE SAME ISSUE!! How can I fix it?? Anyone??!! Have you managed to deal with it?? Does it ever end? And what should I do if it doesn't??? Please help, someone. I'm terrified here...
     

    Mr. James likes this.
  20. Mr. James
    Eclair Sep 4, 2015

    Mr. James , Sep 4, 2015 :
    Finally I've solved alone xD

    For don't get the message "patching system image unconditionally..." when you flashing, you need:

    1) do wipes
    2) flash oxygen via twrp.
    3) do wipes
    4) flash cm-1+ official or cm-nightly and works fine.

    kind regards