1
Network/Connectivity MMI Codes (call forwarding) not working (T Mobile) with 6t

  1. Allen_Bo
    Cupcake Jun 5, 2019

    Allen_Bo , Jun 5, 2019 :
    Recently noted that call forwarding just stopped working recently, noticed on 28 May.

    I have run the gambit with T Mobile (purchased the phone directly from OP) and they claim it's a phone problem now.

    Problem is I took my SIM and tried to forward calls on a brand new OP 6t in the store (obviously a T Mobile handset) and had the same results- Connection problem or invalid MMI code. All MMI codes fail.

    I have swapped the SIM to other phones (Samsung S8 and iPhone XR) and it works fine pointing to the 6t platform.

    Has anyone seen this and have any corrective actions? Again, the MMI codes failed on a new, never registered phone in the T Mobile store, suggesting a 6t problem.


    Allen
     

    #1
    I1527238357040 likes this.
  2. I1527238357040
    Cupcake Jun 5, 2019

    I1527238357040 , Jun 5, 2019 :
    Have you tried to deactivate VoLTE? In the past you had to disable the complete VoLTE feature by T-Mobile because call forward was not working with VoLTE.
     

    #2
  3. Allen_Bo
    Cupcake Jun 5, 2019

    Allen_Bo , Jun 5, 2019 :
    I hadn't tried it but fully disabled VoLTE.

    No change, still doesn't work...


    Allen
     

    #3
  4. I1527238357040
    Cupcake Jun 5, 2019

    I1527238357040 , Jun 5, 2019 :
    on my OP6T (9.0.13) with T-Mobile/DE, MMI codes still working.

    so more info is needed. which Provider/Country. Firmware Version. MMI codes you have tried. Error message you received.
     

    #4
  5. Allen_Bo
    Cupcake Jun 5, 2019

    Allen_Bo , Jun 5, 2019 :
    Also using OP6T at 9.0.13.

    USA on T-Mobile.

    Error is actually the same for all MMI codes.

    Hand jammed code
    1559760247767.jpg
    Using the call setting from the dialer:

    1559760564833.jpg
     

    #5
  6. I1527238357040
    Cupcake Jun 6, 2019


    #6
  7. Allen_Bo
    Cupcake Jun 6, 2019

    Allen_Bo , Jun 6, 2019 :
    Yes, manually forced both to T-Mobile (instead of auto select) and to 2G then 3G. Same error.
     

    #7
  8. I1527238357040
    Cupcake Jun 7, 2019

    I1527238357040 , Jun 7, 2019 :
    last test should be to wait one or two days for 9.0.14. if the problem still exists, open a bug ticket.
    Forum Feedback - submit Bug.
     

    #8
  9. Allen_Bo
    Cupcake Jun 7, 2019


    #9
  10. Allen_Bo
    Cupcake Jun 7, 2019

    Allen_Bo , Jun 7, 2019 :
    More troubleshooting I have tried:
    - force to T-Mobile as the carrier (repeatedly)
    - clear cache and reboots
    - boot in safe mode
    - force to 2G and 3G
    - different location (was in DC, same issue in Omaha)
    - executing codes from app, settings in the dialer app and manually entering
    - force code (using a comma)
    - carrier force re-provision the line
    - replaced SIM card
    - Installed OOS 9.0.14

    I am heading to a store maybe tomorrow and test again with a new handset and will see if they will let me test on a 6t, 7 and another brand.

    This is really irritating [e]1f621[/e]
     

    #10
  11. KeepTransisting
    The Lab - OnePlus 7 Pro Reviewer Jun 7, 2019


    #11
  12. Allen_Bo
    Cupcake Jun 7, 2019

    Allen_Bo , Jun 7, 2019 :
    Already shut down WiFi through all of the troubleshooting to eliminate it as a possible conflict with WiFi calling.
    Still broke...
     

    #12
  13. Allen_Bo
    Cupcake Jun 7, 2019

    Allen_Bo , Jun 7, 2019 :
    Not sure what changed, but tried today and the functionality has been restored!

    I have to attribute it to the 9.0.14 update, especially since I tested it (with my current SIM) on more new phones in a store. I tried codes on both a new OP 6t and a new 7 and it failed. I then tried on a new Samsung S10 and worked no problem. This suggested the problem was with OP devices on T-Mobile.

    Just for giggles, I put my SIM back in my handset and low and behold, it worked.

    Baffled but encouraged. Again I have to believe .14 fixed it somehow.
     

    #13
  14. Allen_Bo
    Cupcake Jun 10, 2019

    Allen_Bo , Jun 10, 2019 :
    Seems I spoke too soon...

    Same issue has returned, no other updates or changes.

    Allen
     

    #14
  15. I1527238357040
    Cupcake Jun 12, 2019

    I1527238357040 , Jun 12, 2019 :
    could the issue be related on your location?
    maybe a sort of roaming?
    national roaming to AT&T or a kind of home zone?
    it could be possible, if you are in a foreign network, the MMI codes will be rejected.
     

    #15
  16. Allen_Bo
    Cupcake Jun 12, 2019

    Allen_Bo , Jun 12, 2019 :
    Was in my home area, both at work (where I used the codes every day) and at home when they just stopped working.

    I thought it may have been a local or even regional network problem, until I recently went to Omaha NE and had the same problems. Even made a point to test at a T-Mobile store and forced to the T-Mobile networks including trying forcing to 2G, 3G and then auto but no change.
     

    #16