2
Network/Connectivity

Mobile Data auto switch after Wifi.

  1. francisdnburrows Cupcake Jun 28, 2017

    francisdnburrows, Jun 28, 2017 :
    I have noticed that when I leave Wifi zone I am unable to connect to mobile data automatically. I would have to toggle mobile data off and then on before I connect.

    Anyone else experiencing the same issue. Having to turn data off and then on to access mobile data after being disconnected from Wifi.
     

    #1
  2. warrenmatty Cupcake Jul 1, 2017

    warrenmatty, Jul 1, 2017 :
    Yes, similar issues here, not sure if it's relevant, but i'm on AT&T. Also, I am on the latest Oxygen firmware OxygenOS 4.5.3. I didn't notice the problem during the short time I was on the release firmware(OxygenOS 4.5.1).
     

    #2
  3. warrenmatty Cupcake Jul 7, 2017

    warrenmatty, Jul 7, 2017 :
    The new update to 4.5.5 resolved all data drop issues and LTE is working great! I was contacted by the OnePlus bug team and they got this fixed immediately after the community posts and me sending in some log files. Really impressed by OnePlus's customer service improvements.
     

    #3
    mschildren likes this.
  4. Rajanshu Cupcake Jul 7, 2017


    #4
  5. thehintsch Cupcake Jul 18, 2017

    thehintsch, Jul 18, 2017 :
    I still got this problem with OxygenOS 4.5.5. I have to turn on airplane mode, wait until I am fully disconnected and then reconnect. But sometimes I need to do a reboot.
    I do have to say that my provider information is a bit weird. I am in Germany. It shows E-Plus, but my old phone showed always O2. I know that their networks are combined now, but still I am curious that it shows the other one now. Also, some provider information is just displayed as "unknown". I do hope for a bugfix in future updates, but I will check if any of the solutions in the forums work... Just want to bring this thread up, as the problem seems still not to be solved 100%
     

    #5
  6. nabil01717 Froyo Aug 11, 2017

    nabil01717, Aug 11, 2017 :
    I have bought my OnePlus 5 yesterday. I updated mine to the latest firmware. Still I'm facing the same issue. Mobile data doesn't auto connect. Any solution?
     

    #6
  7. mattjope Donut Nov 19, 2017

    mattjope, Nov 19, 2017 :
    I have this same problem with a brand new OP5. If I stay connected to wifi for an extended period of time, when I come off that wifi network, the phone fails to connect to the 4g network. The tedious workaround is to turn airplane mode on for a few seconds, then off again; the phone connects fine to the 4g network after that.

    Is there any solution to this?
     

    #7
  8. G_Sergey_Baklashov_unYo Froyo Nov 24, 2017


    #8
    E_Toms likes this.
  9. G_Wilson_Tam_oWEb Donut Nov 26, 2017


    #9
  10. Sandeep.lamba Cupcake Jan 13, 2018

    Sandeep.lamba, Jan 13, 2018 :
    Same problem with my 5t starwars edition.At night when i off everything like all apps and clear notification and turn off mobile data and wifi,my phone shows some notifications in the morning.if anybody found the solution than tell me.
    Thanks
     

    #10
  11. E_Toms Cupcake Jan 17, 2018

    E_Toms, Jan 17, 2018 :
    Have the same issue on 5T. As temp solution - WiFi-Settings-WiFi in sleep mode-Never. Then after unblocking phone after night you will on mobile data and if wifi is available then auto switched to wifi
     

    #11
  12. pchen088 Cupcake Aug 14, 2019 at 7:30 PM


    #12
  13. pchen088 Cupcake Aug 14, 2019 at 7:35 PM

    pchen088, Aug 14, 2019 at 7:35 PM :
    This can be a very serious issue when you are on the road and need to use GPS. For example, you leave your hotel, get in the car, put the address on Google map, and then start to drive hoping Google map would tell you where to go right away. You are about to get on the highway and the Google map is still not saying anything. You have to make a decision on which ramp to take to get on highway. Google map is still silent. You are screwed!
     

    #13