2
Mobile internet not working

  1. abdullah_khan777
    Cupcake Feb 13, 2018

    abdullah_khan777 , Feb 13, 2018 :
    when ever I get out of my WiFi range and get disconnected from my WiFi , I try to turn on my mobile internet but it won't work unless I switch on Airplane mode and then disable it.
    A lot of people are facing the same problem.
    just got an update for Orea. the problem exist before and after the update.
    Please help me out
     

    #1
    skygiven and sh2eyas like this.
  2. FaleshC
    KitKat Feb 13, 2018

    FaleshC , Feb 13, 2018 :
    Did you try to reset Network Settings?
    Settings>Backup & Restore>Reset Network Settings
    Also Clear the Cache Via Recovery.
     

    #2
  3. abdullah_khan777
    Cupcake Feb 13, 2018

    abdullah_khan777 , Feb 13, 2018 :
    I did reset network settings but the problem still exists, how do I clear the Cache?
     

    #3
  4. FaleshC
    KitKat Feb 13, 2018

    FaleshC , Feb 13, 2018 :
    Turn off the phone.
    press vol down + power button
    Select English
    Wipe Cache & Data
    Wipe Cache(Do not Wipe Data).
    Reboot
     

    #4
  5. G_Michał_L_VJCp
    Gingerbread Feb 13, 2018

    G_Michał_L_VJCp , Feb 13, 2018 :
    Is it any different if you just leave WiFI + mobile always on? You don't have to turn off mobile data when you're on Wifi because your phone disable mobile when wifi is available. I use it that way and I've never had any problem neither on Nugat nor Oreo. Not to mention you won't gain any longer battery life that way.
     

    #5
  6. abdullah_khan777
    Cupcake Feb 15, 2018

    abdullah_khan777 , Feb 15, 2018 :
    I did follow your instructions but the problem still persists
     

    #6
  7. FaleshC
    KitKat Feb 15, 2018

    FaleshC , Feb 15, 2018 :
    Why do u switch off mobile data when on wifi? phone automatically manages the data.
    you can try Aggressive Wifi to Mobile Data option in Developer Settings.
    Also reinstall the os might be permanent solution.
    BTW does that sim card works fine other handset?
     

    #7
  8. U1518716747855
    Cupcake Feb 15, 2018

    U1518716747855 , Feb 15, 2018 :
    I am also facing the same problem but when I restart cell it works fine but again after few hours again happening unless I restart it again. you suggestion will be highly appreciated.
     

    #8
  9. abdullah_khan777
    Cupcake Feb 15, 2018

    abdullah_khan777 , Feb 15, 2018 :
    Thought it saves battery.
    but still there is a problem that need to be addressed
     

    #9
  10. abdullah_khan777
    Cupcake Feb 15, 2018

    abdullah_khan777 , Feb 15, 2018 :
    Instead of restarting you can turn ON Airplane mode and then Disable it. or you can just keep the mobile data and WiFi on at all times
     

    #10
  11. FaleshC
    KitKat Feb 15, 2018

    FaleshC , Feb 15, 2018 :
    When connected to WIFI mobile data is automatically closed, you don't save any battery doing so. Very negligible difference it will make.

    Something seems to be messed up in your case. Maybe its issue with your sim provider?
    or something went wrong during update. BTW did you factory reset your phone after Oreo update.
    Its a major release and always better to erase data after the update.
     

    #11
  12. abdullah_khan777
    Cupcake Feb 16, 2018

    abdullah_khan777 , Feb 16, 2018 :
    Even after leaving Mobile internet On, it won't switch ON automatically after losing the WiFi signals, still have to go through Enabling then disabling Airplane mode. I haven't Factory reset the phone yet. I'll give it a try
     

    #12
  13. G_Moudgalya_kumar_“Mou
    Cupcake Feb 17, 2018

    G_Moudgalya_kumar_“Mou , Feb 17, 2018 :
    I had this issue right after the Oreo update. after checking a lot of forums I found the clearing the cache from recovery mode to be the best. I have myself tried this and it works.

    1. enable developer options.
    2. go to developer options and switch on advanced boot
    3. click power button long and you will see an additional option of recovery mode
    4.go to recovery mode and wipe cache.

    restart phone and then it should start working fine
     

    #13
  14. abdullah_khan777
    Cupcake Feb 18, 2018

    abdullah_khan777 , Feb 18, 2018 :
    I tried this but the problem still persists.
     

    #14
  15. sh2eyas
    Cupcake Jul 7, 2018

    sh2eyas , Jul 7, 2018 :
    facing same problem. I wiped cache didn't work. any other solution other than resetting. because I have lot of data on mobile don't wanna loose that.
     
    Last edited: Jul 7, 2018

    #15
    abdullah_khan777 likes this.
  16. skygiven
    Donut Oct 24, 2018

    skygiven , Oct 24, 2018 :
    I found a workaround: in developer options turned on 'Mobile data always active'.
     

    #16