0
Other MTP not working after windows 10 update

  1. galyc0s
    Cupcake Jun 3, 2018

    galyc0s , Jun 3, 2018 :
    I recently updated Windows 10 (19 May) and now MTP is not working.
    A drive letter with the Oneplus 3 drivers files does appear but I cannot see the phone anymore on the list of devices.
    There is no device with a warning in the device manager, the phone is not listed there either.
    I tried to uninstall the drivers, reboot, reinstall them and nothing.

    There is an event in the system viewer that I think it is quite related:

    Fault bucket , type 0
    Event Name: PnPDriverImportError
    Response: Not available
    Cab Id: 0

    Problem signature:
    P1: x64
    P2: E000024B
    P3: oneplus_android_winusb.inf
    P4: 59aff6524be5c0983f2711deb8d25d511d4f4924
    P5:
    P6:
    P7:
    P8:
    P9:
    P10:

    Attached files:

    These files may be available here:
    C:\ProgramData\Microsoft\Windows\WER\ReportQueue\NonCritical_x64_ad10d81319ceab6893322ac091e9897458bba8c3_00000000_0042baf6

    Analysis symbol:
    Rechecking for solution: 0
    Report Id: ad55657e-a041-4328-9282-97af1b7d46bd
    Report Status: 4
    Hashed bucket:
    Cab Guid: 0

    There are not folders in that path mention (WER/Reportqueue)

    Any help?
     

    #1
  2. galyc0s
    Cupcake Jun 3, 2018

    galyc0s , Jun 3, 2018 :
    I am on Oxygen OS 4.5.1 as I have some apps that do not work on 5.0 and also I had some issues last time I upgraded the phone so I rolled back to 4.5.1.
    It was working fine until that windows update. It was one of those big updates.
     

    #2
  3. galyc0s
    Cupcake Jun 3, 2018


    #3
  4. Fredman
    Gingerbread Jun 3, 2018

    Fredman , Jun 3, 2018 :
    My OP6 and my wife's OP2 won't connect at all, apart from drivers folder.
    Solution I found was to enable USB debug mode. Then it shows up once MTP mode is selected.

    Given that a change in the phones settings will make it work, I find it hard to accept that this is solely down to microsoft.
     

    #4
  5. galyc0s
    Cupcake Jun 3, 2018

    galyc0s , Jun 3, 2018 :
    Thanks for your reply but that did not work for me.
    For some reason now I do see the MTP under the device manager but with a warning.
    If I try to update the driver with automatic updates I get that error (see image attached).
     

    Attached Files:


    #5
  6. galyc0s
    Cupcake Jun 4, 2018


    #6
  7. Burgattti
    Cupcake Jun 28, 2018

    Burgattti , Jun 28, 2018 :
    Hi there, I have tried every method out there
    the phone in debug, the phone in FTP, PTP
    On windows 10 installing media feature pack (which didnt do anything)
    finding the wpdmtp.inf file and installing that
    Starting windows in test mode to allow driver signature to be ignored
    Trying to select the driver manually but my windows does not show android as a device

    what can i do!
     

    #7