1
MTP not working

  1. varunn1994
    Cupcake Dec 20, 2016

    varunn1994 , Dec 20, 2016 :
    installed drivers with USB debugging , but OnePlus 3t is not connecting to Windows 10...
    even tried with installing ADB drivers.....
    how to connect to PC for transfering files ??
     

    #1
    elgrace likes this.
  2. Bartnl
    Lollipop Dec 20, 2016

    Bartnl , Dec 20, 2016 :
    did you actually put the phone in MTP mode? (connect phone, swipe from top screen down and select MTP)
     

    #2
    pa5t1s likes this.
  3. varunn1994
    Cupcake Dec 20, 2016

    varunn1994 , Dec 20, 2016 :
    I read all most all threads on the forum and tried the methods.... not even one method worked :(
     

    #3
  4. Bartnl
    Lollipop Dec 20, 2016

    Bartnl , Dec 20, 2016 :
    Then you have a problem in your Windows. It is not the phone as it is connecting perfectly.
    Last thing you could try to install some generic drivers... or samsung drivers which might seem to work as well
     

    #4
    pa5t1s likes this.
  5. varunn1994
    Cupcake Dec 20, 2016


    #5
    pa5t1s likes this.
  6. Bartnl
    Lollipop Dec 20, 2016

    Bartnl , Dec 20, 2016 :
    There has been given a solution in that other thread you replied too.

    And you are sure you installed the OP3 drivers from the CD driver that pops up as soon as you plug in the phone?
     

    #6
    pa5t1s likes this.
  7. varunn1994
    Cupcake Dec 20, 2016

  8. fricy81
    Froyo Dec 20, 2016

    fricy81 , Dec 20, 2016 :
    I had a similar problem on Windows 10, for some reason MTP mode wouldn't work out of the box with the drivers on the virtual CD.
    I managed to get MTP mode working by launching "Device manager", open device propreties, (the device should be marked by a yellow exlamation mark), selecting update driver on the drivers tab, then choose manual, on the next page choose from a list, look for mobile devices (if I remember right) and select "MTP USB device".
     

    #8
  9. kimjay
    Donut Dec 22, 2016


    #9
  10. wouterraey
    Cupcake Dec 22, 2016

    wouterraey , Dec 22, 2016 :
    Hey Bartnl, jij bent Nederlands toch ? Ik zit ook met dit probleem. Als ik de oneplus usb driver set up instaleer gebeurd er helemaal niets. Als hij op MTP staat, connect hij wel maar ik kan er geen anderen bestanden naar toe slepen. Weet jij hoe dit komt ? Ik heb pas de OP3t.
     

    #10
  11. Bartnl
    Lollipop Dec 22, 2016

    Bartnl , Dec 22, 2016 :
    Het schijnt een Windows 10 probleem te zijn dat ontstaan is na anniversary update. Ik heb er met mijn OP3T gelukkig geen last van.
    Je zou kunnen proberen om de Quallcom USB drivers te installeren en heb ook gelezen dat bij sommige de Samsung drivers ook werken.
     

    #11
  12. wouterraey
    Cupcake Dec 22, 2016

    wouterraey , Dec 22, 2016 :
    oh jammer, ik zal het ook eens op een andere laptop/pc proberen. En bedankt voor de tips!
     

    #12
    Bartnl likes this.
  13. anupamkundu
    Cupcake Dec 26, 2016

    anupamkundu , Dec 26, 2016 :
    First of All Connect your device with Your pc then from mobile notification bar select use usb for File Transfer Means MTP than click ok and open your computer there you found oneplus Cd drive install software driver from that than open device manager in your computer found your device with explantion mark right click on that and click on update driver software after that click on browse my computer for driver software after that click on Let me pick from a list of device driver on my computer there your found a option called mobile device click next after that click on MTP USB DEVICE click on that click next and finsih your drive is ready open that in my computer
     

    #13
    ABHISHEKYAMINI and marie.godard1 like this.
  14. elgrace
    Cupcake Dec 27, 2016

    elgrace , Dec 27, 2016 :
    Hi guys, I'm a new user of OnePlus 3T and I can't make it work with my PC to transfer data. After connecting it with micro USB and micro USB to USB type C adapter it charges as it should be, but there's no notification about changing the USB mode to MTP, PTP, etc. In Device Manager in Windows I don't see any new devices. I've tried to plug it into USB 2.0 and USB 3.0, but nothing halped. I checked the Developers options and tried it with:
    USB Debugging turned off and on,
    Setting USB configuration to File Transfer or PTP (even tried what one of user suggested, which was setting PTP and then File Transfer).
    None of above mentioned helped me. I've noticed that when I try to change USB Configuration from PTP to File transfer it automatically sets Charging instead File Transfer.
    Have anyone experienced such problem?
     

    #14
  15. Sleepless_elite
    Cupcake Dec 29, 2016

    Sleepless_elite , Dec 29, 2016 :
    I think I may have found a solution to the problem. What I ended up doing was:
    1. Going into the device manager
    2. The OnePlus3T will be in the section "other devices" and it will be under "Unknown"
    3. Right-click unknown and select update driver
    4. Choose the option "Browse my computer for driver software"
    5. Then choose "Let me pick from a list...etc."
    6. From there, choose the option MTP portable device (Or something very similar)
    7. Choose MTP USB device
    8. You should be able to see your device after that.

    Let me know if this worked for you guys and hopefully you can now enjoy your phone.
     

    #15
    pa5t1s likes this.
  16. marie.godard1
    Cupcake Dec 30, 2016

    marie.godard1 , Dec 30, 2016 :
    THANK YOUUUUUUUUU !!! It finally works (after hours on forums to find an answer !!).
     

    #16
    anupamkundu likes this.
  17. vishal42
    Cupcake Mar 12, 2017

    vishal42 , Mar 12, 2017 :
    I have had similar problem. The reason is the oneplus device driver doesn't have verified signature so when you update to Windows 10 it prohibits the driver from running.

    All you need to do is "DEACTIVATE THE DRIVER SIGNATURE VERIFICATION"

    To do that you need to follow simple steps:

    keep shift button pressed from keyboard and click 'restart' in start menu. This will open Advance boot menu.

    1489292358303.jpg

    select advanced options.

    1489292575629.jpg

    click on startup settings.

    1489292635918.jpg
    click on restart. it will open startup settings screen.

    1489292724935.jpg
    press F7 from keyboard.

    1489292760130.jpg
    once this is done your PC will reboot and then you try to install the driver using "Device manager". There will be no further problems. Someone has already mentioned the process to install drivers in one of the comments.

    hope this helps.
     

    #17
  18. hunaricarus
    Donut Mar 17, 2017

    hunaricarus , Mar 17, 2017 :
    Try this. It might just work like it worked for me
    Go to device manager from your computer >> right click on the one with the exclamation sign >> select Update Driver Software >> again select Browse my Computer for Driver Software >> click on Let me pick from a list of Device Drivers Pon my computer >> select Mobile Devices >> Next >> Select MTP USB Device >> Next (DONE)
     

    #18
  19. hunaricarus
    Donut Mar 17, 2017

    hunaricarus , Mar 17, 2017 :
    Try this. It might just work like it worked for me
    Go to device manager from your computer > right click on the one with the exclamation sign > select Update Driver Software > again select Browse my Computer for Driver Software > click on Let me pick from a list of Device Drivers Pon my computer >> select Mobile Devices > Next > Select MTP USB Device > Next (DONE)
     

    #19
  20. Akhil_Parujan
    Gingerbread Mar 17, 2017

    Akhil_Parujan , Mar 17, 2017 :
    After connecting the phone to the computer, try MIDI mode, it may force Windows to install some drivers. Then switch to MTP or PTP mode to see if your computer can read your phone's storage.
     

    #20