0
Other My OP6 doesn't receive notifications until i wake up it

  1. Ibanez81
    Cupcake Sep 17, 2018

    Ibanez81 , Sep 17, 2018 :
    Hi all, I have an OP6 with OxygenOS 5.1.11 (based on Oreo 8.1.0).
    The phone seems to receive notifications from Outlook app and GMail only in the first moments i switch screen off, then no notifications anymore until I wake screen on.
    Messaging apps like whatsapp and telegram work properly (i.e. they always shows notifications).
    I tried disabling battery saving for the two apps (advanced battery saving is switched off) and i put all notifications concerning these two apps at maximum priority, but it doesn't seem to work.
    It seems to me some other energy saving hidden option is working somewhere, but i cannot find anything related nor in developer options.
    Is thee anyone who can help me?

    Thanks in advance
     

    #1
  2. the_o2
    OnePlus 9 Series Expert Community Expert Sep 17, 2018

    the_o2 , Sep 17, 2018 :
    Better to report this bug here
    https://forums.oneplus.com/feedback
     

    #2
  3. Deactivated User
    Sep 17, 2018


    #3
  4. Ibanez81
    Cupcake Sep 17, 2018

    Ibanez81 , Sep 17, 2018 :
    No, unfortunately i don't :(
     

    #4
  5. saahill
    Gingerbread Sep 17, 2018

    saahill , Sep 17, 2018 :
    Go to Settings>Battery>Battery Optimization>Advanced Battery Optimization>Disable Sleep Standby Optimization
     

    #5
  6. Ibanez81
    Cupcake Sep 17, 2018


    #6
  7. Ibanez81
    Cupcake Sep 17, 2018

    Ibanez81 , Sep 17, 2018 :
    Sleep standby is disabled
     

    #7
  8. ratansuthar00
    Eclair Sep 17, 2018

    ratansuthar00 , Sep 17, 2018 :
    Hi, Im also Facing the same, I'm using the Outlook app, what i need to so is every single time open the app refresh it to see if i got any new email. But that's fine for me, as for me personally not that important. Other same whatsapp is working fine with notification.
    I found these settings, to save the battery consumption by default seems the App is set in optimise mode, click on the outlook app under battery options, and select Don't optimise. Also you can uncheck the Advanced optimisation option + sleep standby. Also Go to app to Outlook then, checked Background data. Also another thing i have noticed, If you go to settings then account, any app account you create there is a app there where you can control in accounts tab like Google, whatsapp, duo and so on. But there is no option of a outlook, may be this causing the syncing doubt it, because in other brand settings page and in account tab, you can see outlook icon there, as soon as i have added my outlook ID
     
    Last edited: Sep 17, 2018

    #8
  9. yiddo13
    Cupcake Sep 18, 2018

    yiddo13 , Sep 18, 2018 :
    Many people are having the same issue, can see it on here and reddit. You usually get the sarcastic "turn off battery optimisation" without the OP being read.

    I've reported it as a bug to OP but got nowhere. They asked me to send them logs but it didn't help. They said the logs didn't show anything. I've had two separate OP6 devices now and both have had the same issue.
     

    #9
  10. Ibanez81
    Cupcake Sep 18, 2018

    Ibanez81 , Sep 18, 2018 :
    Yeah, they ask me too for logs, but it's difficult to have a screenshot of the error because...err...that's not an error, it's simply not receiving notifications......or, better to say, after maybe a minute with screen locked/off. I noticed that this is not happening the first seconds i shut down the screen....i reckon this hidden energy saving mode start after seconds...
     

    #10
  11. Aathif_Mahir
    Ice Cream Sandwich Sep 18, 2018

    Aathif_Mahir , Sep 18, 2018 :
    You might've enabled sleep standby in battery optimization, Go and disable that in battery optimization settings.
     

    #11
  12. yiddo13
    Cupcake Sep 18, 2018

    yiddo13 , Sep 18, 2018 :
    Yes this was exactly what I tried to explain to them but it fell on deaf ears unfortunately.

    Mine stopped receiving notifications after 2mins of being locked, plus it only happened on mobile data, wifi seemed unaffected.

    Edit: Things I've tried:

    • Both optimisations (advanced and sleep) off
    • Notifications on for all apps
    • Unrestricted data usage
    • Restrict background data off
    • Upgraded to Android P beta
    • Wipe cache and clear data
    • Factory reset
    • Disabled doze mode through ADB (option not in developer mode)
     
    Last edited: Sep 18, 2018

    #12
  13. Ibanez81
    Cupcake Sep 18, 2018

    Ibanez81 , Sep 18, 2018 :
    I didn't try on wifi 8not yet, i hope i try this evening), but this doesn't happen when telephone is charging, so I definitely think it's a matter of battery saving not well managed.
     

    #13
  14. yiddo13
    Cupcake Sep 18, 2018

    yiddo13 , Sep 18, 2018 :
    I've seen other people say the same about other handsets so maybe something to do with how the handset works with Oreo. It's definitely a battery saving issue there's no doubt but OP in particular seem ignorant to the fact its an issue. The thing I do find weird is why it doesn't affect everyone?
     

    #14
  15. saahill
    Gingerbread Sep 19, 2018

    saahill , Sep 19, 2018 :
    Try opening the app more often, using it frequently.
    Then the AI or any other battery Optimization would flag it as frequently used and not shut it down.
     

    #15
  16. Ibanez81
    Cupcake Sep 20, 2018

    Ibanez81 , Sep 20, 2018 :
    Now I'm trying Bluemail and it works perfectly...so there supposed to be some differences between outlook app and other mail apps....
     

    #16