2
My OPO Absolutely, Positively Will NOT connect to PC

  1. tarana2000
    Froyo Nov 6, 2015

    tarana2000 , Nov 6, 2015 :
    I had the same problem

    I went to Developer Options->Debugging> Revoke USB debugging authorisations

    then connected cable to PC and voila, drivers installed.!
    Dont know why it worked, but worked for me.!
     

    charanchakravarthi likes this.
  2. charanchakravarthi
    Honeycomb Nov 9, 2015

    charanchakravarthi , Nov 9, 2015 :
    I had the same problem now, but for some reason it worked after I chose "USB Debugging" from the developer options. Also I tried Developer Options->Debugging> Revoke USB debugging authorizations, following which the issue is gone permanently.
     

  3. roserool
    Cupcake Dec 8, 2015

    roserool , Dec 8, 2015 :
    mine solved with changing the usb cable...the old cable working just fine until i cant connect to pc and only able to charging...
     

  4. azeez4901
    Ice Cream Sandwich Dec 8, 2015

    azeez4901 , Dec 8, 2015 :
    uhhhhh..zapya transfers 300mb under 3 mins.
     

  5. azeez4901
    Ice Cream Sandwich Dec 8, 2015

    azeez4901 , Dec 8, 2015 :

    well..its good you found a solution for it--even though money back.. i wanted to ask you.. Do you try to connect with data (2g/3g) on or WIFI on? did you factory reset your device? or rather upgrade from the initial 4.4.4? it could have been a wide range of issues... too bad no more testing though. i have to agree with you one plus one service is worst. I was being thrashed in the forum for saying 'maybe-they-know-No-English' but i was at that point to call my dad illiterate so to say.

    Phone is a legend.. among best smart phones i used and still loving it. Have a burger
     

  6. pranav161996
    Cupcake Feb 28, 2016

    pranav161996 , Feb 28, 2016 :
    Got it fixed - had to navigate to 'Settings --> Storage', tap on 'three dots' on the top right, enable 'USB Computer Connection' and select 'MTP' or 'Camera' as the transfer mode.
     

  7. EarlParkour
    Cupcake May 15, 2016

    EarlParkour , May 15, 2016 :
    This may seem incredibly stupid, but make sure you are using an appropriate charging cable.
    It should be one for charging AND syncing. I could have sworn that my old cable used to connect to the computer just fine, but since about a month ago, it hadn't been working.

    Oddly enough, a charging cable I just bought today as a replacement for my old one that says "Sync/Charge" works, and now I see the drop down notification to switch charging/MTP mode.

    Hope this helps.
     

  8. jan lee
    Cupcake Jun 22, 2016

    jan lee , Jun 22, 2016 :
    Are we talking about the OnePlusOne? I'm having the same problem and looking for an answer but my settings does not have this option.
     

  9. jan lee
    Cupcake Jun 22, 2016

    jan lee , Jun 22, 2016 :
    Are we talking about the OnePlusOne? I'm having the same problem and looking for an answer but my "storage & USB" does not have this option.
     

  10. lparihar9
    Honeycomb Jun 22, 2016

    lparihar9 , Jun 22, 2016 :
    Having issues with windows 10 specifically on my laptop. Connects well with other PCs.
    Why cant oneplus provide a proper driver for OPO which has legitimate digital signature :(
     

  11. martincity
    Cupcake Jul 1, 2016

    martincity , Jul 1, 2016 :
    I had the same problem. On phone went to Settings>Developer Options>Select USB Configuration and change selection from Charging to MTP. Worked for me.
     

  12. anterys
    Cupcake Dec 22, 2016

    anterys , Dec 22, 2016 :
    I had the same problem. Here's what I did to fix it. I'm on Lollipop by the way and the following is all in Settings --> Debugging Options.
    1. Enable Android Debugging
    2. Revoke USB debugging authorizations
    3. Select USB Configuration --> Change to MTP (Media Transfer Protocol)
    4. Disable Android Debugging
    You may have to pull down the notifications, select USB for file transfer. For me, step #4 is what did it for some reason.
     

  13. samratvishaljain
    Eclair Dec 22, 2016