4
[MY STORY] Losing EFS data to 2xhard brick and back to life

  1. matija646
    Jelly Bean Nov 12, 2015

    matija646 , Nov 12, 2015 :
    this is gonna be a long post for someone, if you want to read, read, if not, you have TL;DR on the end, but maybe someone will find this interesting and helpfull
    maybe to someone this isn't a big deal, but to me it was..
    if you have any questions, fell free to ask, and i will be more then happy to share my experience

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    Oneplus One is my first true flagship, in which i fall in love even before i bought it, and once i got my hands on it, i knew it's a bond between me and the phone
    having it for 1 year now, and loving every moment i spent with it, flashed who knows what on it, and experimented with a lot of stuff

    but yesterday, during normal backup making in twrp my phone froze, i realized it got stuck because backup was taking too long (5+ mins, while it's done in like 1 min)
    progress bar was not moving, nothing was happening and i had to hard kill it and boot it again
    but once i got to my os i had a surprise, wifi does not work, sim card not readable (like it's not in the phone), fc of system right away, no mac adress, nothing, and on top of that phone reboots after 1min of being on because it's struggling to find network, turn on wifi, and fc of system :/
    it rebooted like 10-15 times, then i tried to factory reset it, same again, didn't even cross the initial setup, phone behaved the same (wifi, sim, fc, reboot)
    then i tried some other rom (had sultan atm), temasek, still the same
    upon research i found out my efs data is lost / corrupted and because of that problems started, and i was in fear if will get the phone back in normal state because i saw on xda that some people didn't had luck with it...
    since i had access to twrp i know that i still have a chance...
    tried to restore some older twrp backups, but i couldn't do that because my data partition was corrupted, and every restore failed on it...
    since i didn't have efs data, or to say modemst1 and modemst2 backup with my IMEI and other stuff related to wifi and so on, i couldn't try that in first place... :(

    then the debugging begin...
    i connected my phone to the pc, saved my photos and files, because i knew that sooner or later i will need to wipe my phone to start clean
    i had few roms on phone (older sultan, older temasek) and tried to flash that to see if my EFS data will be restored, but nothing helped, phone behaved the same
    since flashing lolipop rom didn't help, i found info that you need to flash color os / cm11 / oxygen to get the EFS data back, aka stock rom, but it's not a guarantied it will work...
    then i fully wiped my phone, transferred rom zips, firmwares for kk and lp, to the phone and tried flashing..
    oxygen os v1.0.2. didn't help
    cos12.1 didn't help
    cm11 44s on fully wiped phone, didn't help..
    color os ver 2 and ver 1 on fully wiped phone, didn't help...
    tried to get the phone to factory new with this tutorial, first i went on and placed 44s factory image cm11 on it, no help, efs still lost
    then i made stupid mistake, went on and flashed with that tutorial cos12.1 and ended up with hard bricked phone...
    at this moment i didn't know what is happening, since i panicked a little bit, because phone only vibrated with longpress of power button
    right away i started to look for options how to unbrick the phone, and found this tutorial
    i read through it, calmed down, prepared everything, downloaded files and connected my phone to the pc
    i was really happy when i saw that phone boots into color os, and thought my problems are done, but upon booting, bitter taste in my mouth, still the same, no wifi although it's turned on, no sim card although it's in phone, fc-a and reboots
    then tried again flashing oxygen os, of course no help...
    then i found cm11 30o factory image and went on to flash it wia fastboot from first tutorial, and again, stupid me, ended with another hard bricked phone, but this time phone didn't even vibrated when i hold the power button, and at this moment i really thought the phone is long gone dead, but i was lucky...
    then again i made same procedure with unbricking it and placing 30o cm11 on it with fastboot flashing of img files
    phone booted and fc stoped, wifi was working, but my sim card is undetected, no baseband
    now i felt a little bit of releaf because the phone was in "working" state
    next things what i have done from this tutorial, were erasing modemst1 and modemst2 with fastboot from phone, erasing persist partition and flashing persist.img, but that also didn't help me get my efs data, all works but main feature of phone, calls and cellular reception, no..
    tried erasing and flashing those partitions on cm12, oxygen 1.0.2., cm11 44s and 30o, color os v2 and v1, all the roms which are suposed to get my EFS data back, but no luck...
    then i flashed again color os while i was downloading oxygen os v1.0.0, since that is the only rom i didn't tried to flash
    at this point i was thinking that i will need to send my phone for repair, since all of the recommended options to get the EFS data didn't work, and i thought that something is seriously f*cked up in my phone...
    color os booted, same situation (no sim card, but wifi is ok, no fc), transfered oxyv1 zip to phone and flashed it...
    i really didn't expecting much to happen, but boy oh boy i was a happy man, phone booted to oxyv1 normaly, setted up my phone like i normally would, and then i saw, MY SIM WORKS, I HAVE BASEBAND, IMEI, ALL IS OK ! ! ! ! :D
    i was filled with joy, my beloved One was fully functional, and i was even more happy to see that, then from unpacking the phone for the first time :)
    i was flashing and combining whole day, but in the end it payed off

    then i proceeded and made backup of my EFS data (modemst1 and modemst2 in img files for easy flashing) and saved it on my laptop, and my google drive, for future (i hope not) problems

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    long story short, don't give up
    explore, try, flash, debug, combine, anything you can to see if you can fix it
    i never had hard bricked phone until now, i never lost EFS data until now, and was never so close to making a ticket and tried to send my phone to repair to 1+
    i maybe don't have knowledge to make some rom, kernel or some simple zip for flashing, but i am now richer for the experience of fixing phone in s*it condition and hard bricked, back to fully functional
    wonderful world of community, and mainly XDA forums, lead me to repairing my phone on my own, which made me one proud mofo (maybe someone wouldn't be, but for me, it's a big thing) :)

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    TL;DR
    phone lost EFS data, got hard bricked, got it back working, managed to get EFS data back, phone ok, me happy
     
    Last edited: Nov 12, 2015

    #1
    Vlaja, iqqy69, Franjo and 1 other person like this.
  2. TekRantGaming
    Ice Cream Sandwich Nov 12, 2015

    TekRantGaming , Nov 12, 2015 :
    your right with never giving up same happened to me i just kept flashing and doing things in fastboot and twrp until it worked .....so dam stressful but it all pays off i share same love for this phone as you do
     

    #2
  3. matija646
    Jelly Bean Nov 12, 2015

    matija646 , Nov 12, 2015 :
    it's quite stresfull when you see that flashing all sorts of things, in various ways, whole day, does not help
    but eventually, something will help, and that will be something beautifull
     

    #3
  4. CAuday
    Gingerbread Nov 12, 2015

    CAuday , Nov 12, 2015 :
    Are you my doppelganger... Dude that same thing happened to me 2 days ago..every word of it matches my story...
     

    #4
  5. matija646
    Jelly Bean Nov 12, 2015


    #5