0
Network/Connectivity Need a little help regarding my OPO and cellular connectivity....

  1. lori_cohen
    Froyo Feb 12, 2019

    lori_cohen , Feb 12, 2019 :
    To start: I'm not a great tech person and I don't get a lot of the jargon. I just follow how-tos on sites like this. I did a search and didn't really come up with a whole lot.
    I've had my OPO since the very beginning. I think it still works great. I've gone through all the CM operating systems, and made the jump to lineage and all the way up to 15.1. My cellular connectivity just seemed to get worse during all the updates. By the time I got to LineagoOS 15, I was missing calls and texts. I did all the checks I could, everything seemed as efficient as possible. My battery life was great but I had crashing apps at times. I went backward in Lineage but it really didn't improve that much. I was sick of bad cellular so I decided to try Oxygen 2.1.4 and the connectivity is much better. I have no crashing apps, but battery life stinks and I can't get that dumb Google search Bar off the home screen.
    My questions/ideas are:
    1. Could the problem have been the baseband? I'm currently on MPSS.DI.4.0.1.c7-00013-M8974AAAAANAZM-1 I don't know what it was before.
    2. Is it possible to go back to Lineage and fix the baseband if that was the problem?
    3. I found this via search ------- "It's best to install OxygenOS 2.1.4 first so that the baseband gets updated. Then install a custom ROM. Custom ROMs do not update the baseband." ---does anyone know if this is true? and possible? and wouldn't brick my phone?
    4. Could I just be wearing out my radio?
    5. Anything else I'm missing?
     

    #1
  2. lori_cohen
    Froyo Feb 12, 2019


    #2
  3. Hydra Bob
    Starting Point Expert Feb 12, 2019

    Hydra Bob , Feb 12, 2019 :
    Could very well be the baseband like you said. That's the part of the software that controls the radios and it's very difficult if not impossible to update without the help of the hardware manufacturer which pretty much ties the hands of custom ROM developers. After awhile compatibility issues could start to crop up between newer Android versions and the older firmware that may have an impact on the function of the device. Pretty much all you can do is make sure you have the most recent available version of the firmware installed before you install a custom ROM.
     

    #3
  4. lori_cohen
    Froyo Feb 13, 2019


    #4
  5. The1Lion
    Lollipop Feb 13, 2019

    The1Lion , Feb 13, 2019 :
    I was using an OPO on Lineage 14 - I do know that when I initially flashed 14 I had issues. I got around these issues by reverting to 13 and updating that to the LAST available update for 13 at the time and then flashed 14 and that seemed to work. Not really sure why as it seems odd that you would have to do it that way but that's what worked (who know's, perhaps during all that flashing and factory resets something actually got cleared up allowing 14 to work?)
     

    #5
  6. lori_cohen
    Froyo Feb 13, 2019


    #6
  7. lori_cohen
    Froyo Feb 22, 2019

    lori_cohen , Feb 22, 2019 :
    I flashed LineageOs (14). I still have the most recent baseband, so I thought all was good. But no. I frequently lose cellular connectivity. Yes, battery life is better but cellular is worse. I made sure cellular is not optimized, too, so it's always on. I'm not sure of a solution.
     

    #7
  8. lori_cohen
    Froyo Mar 6, 2019

    lori_cohen , Mar 6, 2019 :
    I went backwards, now on CM13. Now I have a different baseband, but I thought connectivity was still good. Over the last few days, however, I have been missing phone calls. I'm frustrated. I don't know what to do. The first couple of years, my phone was the most reliable one in the house. I have a Samsung sitting here that I might try.
     

    #8
  9. koninos
    Cupcake Mar 8, 2019

    koninos , Mar 8, 2019 :

    I also have similar problem but much worse .I wrote on another thread but didnt get an answer. its been a year now . when i connect to lte (preffered ) although i connect to internet i cannot receive calls nor make calls even when the signal changes to 3g , only works on 2 g. I am on lineage 15.1 and the problem seems to exist since cyanogen's last update . i ve tried all the roms from stock to oxygen even other custom roms but no luck . i have also installed all the basebands found on a xda thread but no luck. I checked the sim card reader contacts and they seem intact. So i came to the conclusion that its a hardware problem not a software . if someone here have some knowledge on the motherboards components and what to check visually or else can please advice me ?
     

    #9