8
Network issues after Android 10 update

  1. I1511137489637
    Cupcake Dec 2, 2019

  2. I1511137489637
    Cupcake Dec 2, 2019


    #42
  3. buddow
    Eclair Dec 2, 2019

    Last edited: Dec 2, 2019

    #43
  4. I1511137489637
    Cupcake Dec 2, 2019


    #44
  5. dream.er
    Gingerbread Dec 3, 2019


    #45
  6. jaymaru
    Cupcake Dec 4, 2019

    jaymaru , Dec 4, 2019 :
    I have had the same issue for a few weeks now on OnePlus 7T. When work profile is enabled and location is used (e.g. google maps) network signal on wifi/mobile drops out. Tried resetting network settings, hard reset, restore to factory settings but none worked. Reluctant to send the phone in for repair given it is clearly a software issue!

    Toggling off work mode provides a temporary solution but this is not a sustainable solution! OnePlus please sort this out.
     

    #46
    diwa51 and I1511137489637 like this.
  7. I1511137489637
    Cupcake Dec 4, 2019

    I1511137489637 , via OnePlus 7 Pro , Dec 4, 2019 :
    keep us updated if you find a solution.
     

    #47
  8. efeysoy
    Eclair Dec 20, 2019


    #48
  9. H1570637885530
    Cupcake Dec 25, 2019


    #49
  10. buddow
    Eclair Jan 1, 2020

    buddow , Jan 1, 2020 :
    Also, with latest stable Android 10.0.3GM21BA the issue remains
     

    #50
  11. efeysoy , via OnePlus 7 Mirror Gray , Jan 4, 2020 :
    Beta 8 issue still persists. I don't expect it to be fixed anymore, this is like a joke.
    whenever I say "hey google" my internet connection disappears and i control light at my place with google assistant. You can think how annoying this become.
     

    #51
  12. ReAusBe
    Cupcake Jan 6, 2020

    ReAusBe , via OnePlus 6 , Jan 6, 2020 :
    Any news on this topic? Official update a few weeks ago makes my phone drop its mobile connection every time I use location based apps.

    As I understood there's nothing I can do, also resetting my phone won't help?
     

    #52
  13. I1511137489637
    Cupcake Jan 8, 2020

    I1511137489637 , via OnePlus 7 Pro , Jan 8, 2020 :
    so I posted the thread in their Twitter DM and this is what they told me as a response.

    anyone willing to try this? do keep us updated. I have a lot of data so I can't wipe everything.
    1578474199572.jpg
     

    #53

  14. #54
    I1511137489637 likes this.
  15. buddow
    Eclair Jan 15, 2020

    buddow , Jan 15, 2020 :
    Issue persists, gets annoying now. I've submitted three logfile reports whic capture the issue of network and wifi. No solution so far. Really hope they will be able to solve this. Still think this is basic functionality and should perform 100%
     

    #55
  16. B1538578547131
    Cupcake Jan 20, 2020

    B1538578547131 , Jan 20, 2020 :
    Any update? this is super annoying. I thought it was my carrier but then realized I updated to Android 10 and that might be the reason.
    It shows that there is a normal 4G connection but in reality, it sometimes just lose connection and it takes a minute or few to get connectivity... this is frustrating.
     

    #56
  17. diwa51
    Cupcake Jan 21, 2020

    diwa51 , Jan 21, 2020 :
    This is exactly my situation with my 7T. Thanks for sharing this, it helps to feel less lonely 😅

    Support asked me to reset my phone (which I refused because it is such a pain and was way too easy from there side). Then they also asked me to reset the network, then wipe the phone's cache. These gave me a bit of fresh air but it came back after few days.

    I finally asked for a phone replacement to Amazon. With my fresh new 7T, things were going alright up until I setup a work profile where I came back to square 1.
    When I disable work profile then network works again.

    So there is a true reproduction path to fix this issue or at least a way to narrow down the root cause.
     

    #57
  18. hurlsioneplus
    Cupcake Jan 22, 2020

    hurlsioneplus , Jan 22, 2020 :
    Another user with the same issue here!
    OnePlus 7 on OS ver 10.0.3.GM57BA
    Work profile active

    Apps that use location will repeatedly take down and reconnect the mobile data connection and refuse to connect.
    Sometimes will work however mostly will not work until either location or the work profile is turned off.
    Seriously frustrating.

    Any chance of an update or response from OnePlus ?
     

    #58
  19. elmi82
    Cupcake Jan 23, 2020

    elmi82 , Jan 23, 2020 :
    I'm having the same issues, I've followed all the instructions from support that are also mentioned above. None of it fixed the issue. Complete reset through the recovery mode made it work for half a day, then it was back. I could consistently reproduce it when I opened Google Maps. It seemed like the Chip completely resets, if I started to do something that needs to get a location fix. Making the phone somewhat usable required me to disable location services. With this I didn't experience any further disconnections or resets. But if course that's not a long term option.

    I've still sent in the phone for repair. First thing they did was to flash the "latest" software on the phone and then couldn't reproduce the problem. So they shipped the phone back to me. When I got the phone I realized that by "latest" version they meant "Android 9". Now I have a working phone, but I of that course I can't upgrade. Very, very annoying! Especially after going through the whole hassle.
     

    #59
  20. H1580187922096
    Cupcake Jan 28, 2020

    H1580187922096 , Jan 28, 2020 :
    Hi there im also facing the same issue with network getting disconnected on my one plus...can anyone please help me with the final solution??
     

    #60