1
NFC issues - Can't read or write to NFC tags

  1. Geoffrey121
    Froyo Aug 9, 2014

    Geoffrey121 , Aug 9, 2014 :
    So I've had my OPO for a bout 2 weeks now.. a fantastic phone so far! But I've noticed two problems. One is the "ok google" command, but ive already received answers for that. The second is NFC..

    I just bought some NFC tags from a company called Whiztags off of Amazon. But I the OPO is unable to recognize, read, or write to the NFC tags! I know that it is not an issue with the Tags as I just used my fathers Galaxy S5 to write to the tags, and his phone also can read the written data.

    Is anyone else having troubles with their NFC? Is this just a software update or firmware or something?\


    ***Update***
    So apparently OnePlus and CM are working on a solution for the NFC issues. I ended up purchasing the RapidNFC tags from (http://rapidnfc.com/item/275/nfc_starter_packs_touch_nfc_starter_pack) and they have been working perfectly. You can either use android apps found on the playstore to program/write the tags, or you can use the built in writing method found under the profile section.
     
    Last edited: Jan 25, 2015

    #1
    Jackal Wong likes this.
  2. mattc
    Jelly Bean Aug 9, 2014

    mattc , Aug 9, 2014 :
    I use the Touch starter pack from RapidNFC and it works great.
    One time only, my OPO didn't want to read or write to them, but a phone reboot solved I for me. I haven't had that issue afterwards
     

    #2
  3. Geoffrey121
    Froyo Aug 9, 2014

    Geoffrey121 , Aug 9, 2014 :
    Would you be able to send me a link to it?
    Is it just an app on the play store? or do I also need different tags?

    Great to hear its working at least!
     

    #3
  4. Greenas
    Ice Cream Sandwich Aug 9, 2014

    Greenas , Aug 9, 2014 :
    did you tryed to remove back cover of the phone and then use NFC ?
     

    #4
  5. mattc
    Jelly Bean Aug 9, 2014


    #5
    antmin likes this.
  6. AndyPober
    Ice Cream Sandwich Aug 9, 2014

    AndyPober , Aug 9, 2014 :
    Old style NFC tags don't work. The new ones seem to. I have a bunch of the old Samsung tags (logo has one gray square, three blue) and they don't work. I've done NFC from phone to phone and it works fine.
     

    #6
  7. jjmathew27
    Cupcake Aug 9, 2014


    #7
  8. AndyPober
    Ice Cream Sandwich Aug 9, 2014

    AndyPober , Aug 9, 2014 :
    Just curious. Whom are you asking?
     

    #8
    psh17421 and PLPeeters like this.
  9. PLPeeters
    KitKat Aug 9, 2014


    #9
    Niels_Andersen, kostazu and mattc like this.
  10. Geoffrey121
    Froyo Aug 9, 2014


    #10
  11. PLPeeters
    KitKat Aug 9, 2014

    PLPeeters , Aug 9, 2014 :
    Damn it :( I suggest you vote on this issue and comment saying Topaz 512 tags are not working either.
     

    #11
  12. jct2692
    Cupcake Aug 17, 2014

    jct2692 , Aug 17, 2014 :
    I did the same exact thing. Bought the same Whiztags ones off Amazon and having troubles with writing, reading, and erasing them. Tried with my Galaxy S4 and had no issues with it at all.

    They are the Topaz 512 chip as well. Little Disappointed:(
     

    #12
  13. FoleyRose
    Ice Cream Sandwich Aug 18, 2014


    #13
  14. EmmaWATTson
    Ice Cream Sandwich Aug 18, 2014


    #14
  15. Geoffrey121
    Froyo Aug 19, 2014

    Geoffrey121 , Aug 19, 2014 :
    I think im going to order the NFC tags that someone recommended on my thread here. They were like the second or third person to comment..cant quite remeber aha
     

    #15
  16. Geoffrey121
    Froyo Aug 19, 2014

    Geoffrey121 , Aug 19, 2014 :
    AHH! It was Mattc!
     

    #16
  17. JLL
    Cupcake Sep 22, 2014

    JLL , Sep 22, 2014 :
    Hi guys,

    First, sorry for my english.

    Then, i have encoutered the same issue with the topaz 512 chips. There is no issue indicated on the amazon.fr (french store) but on the english store i have read this :
    Please note: Some bugs have been reported regarding the NFC functionality on the OnePlus One device. We're awaiting a firmware update from Cyanogen to fix this issue. This device may temporarily experience issues with WhizTags.

    I'm crossing my fingers for a quick fix (if it's really a software issue and not an hardware one).

    Just for information. :)
     

    #17
    hasith777 likes this.
  18. batwingnz
    Gingerbread Sep 25, 2014

    batwingnz , Sep 25, 2014 :
    Hopefully some resolution is found. I am now unable to scan any NFC tags or share via NFC with any other phones - even ones that were previously working.
     

    #18
  19. JLL
    Cupcake Sep 26, 2014

    JLL , Sep 26, 2014 :
    Not me.
    The OPO work with some tags, but not with all tags (for now).

    I tested one of mine (Topaz 512), last night, with a Galaxy S5 and that's work. Wait and see...
     

    #19
  20. petemacuk
    Eclair Oct 1, 2014


    #20