0
No 5g for Nord 2 !!!! Are you serious? via OnePlus Nord 2 Blue Haze

  1. Jishnudev , via OnePlus Nord 2 Blue Haze , Oct 18, 2021 :
    I am using Batelco 5g sim which is working fine in my iPhone 12 . But when I put that sim to my Nord 2 there is no option for selecting preferred network to 5g. WTF! Are you people kidding us? What should I do now? Please help.
     

    #1
  2. B_Wrath
    Junior Moderator Junior Moderator Oct 18, 2021

    B_Wrath , Oct 18, 2021 :
    Did you check if Batelco 5G was supported in Nord 2 before buying it? Usually, the network provider has to enable support.
     

    #2
    McJader and Caomhin like this.
  3. Jishnudev , via OnePlus Nord 2 Blue Haze , Oct 18, 2021 :
    Yes, brother. I checked with Batelco team and they said there are no issues from their side and recommended to check with OnePlus service. Also I have Samsung Galaxy A 71 5g. This phone also working fine in 5g network with the same sim.
     

    #3
  4. Caomhin
    OnePlus 9 Series Expert Community Expert Oct 19, 2021

    Caomhin , via OnePlus 9 Pro , Oct 19, 2021 :
    This is a workaround. If it works, you will have to Apply these settings again 🔸Each time you Restart the phone. 🔸

    This App available on the Playstore does the same as the manual procedure as stated below. But it may depend on your Network provider..
    ⚡You must have an existing 5G plan with your mobile network provider. ⚡
    5G Switch - Force 5G
    https://play.google.com/store/apps/details?id=com.sladjan.sava.petg

    Manual procedure (Does not work on ColorOS codebase) try the app linked above.
    You can possibly enable 5G:
    1) Open Dialer App.
    2) Type *#*#4636#*#*
    3) Tap on Phone information
    4) Select NR/LTE/TDSCDMA/GSM/WCDMA.
    5) You may now be able to use 5G.

    Ensure you have checked that your Mobile Network provider can provision your phone on their 5G Network.
     

    #4
  5. Jishnudev , via OnePlus Nord 2 Blue Haze , Oct 19, 2021 :
    I tried both. But not working, especially manual method . When I type last digit dialer closing automatically and nothing happens. Anyway I went to service center today and they settled it correctly. Now it is working fine. But still in preferred network selection list, 5g option is not showing. Service centre guy said they will fix it with an update.
     

    #5
    Caomhin likes this.
  6. Jishnudev , via OnePlus Nord 2 Blue Haze , Oct 20, 2021 :
    I will switch off my phone when I am sleeping. I did the same yesterday too. After switching it on 5g is gone.
     

    #6
  7. deeneendo
    Donut Oct 25, 2021

    deeneendo , Oct 25, 2021 :
    this is unacceptable, the phone is advertised as 5G! That is why I bought it, and it is NOT working!
     

    #7
    Hassonipulus likes this.
  8. Caomhin
    OnePlus 9 Series Expert Community Expert Oct 25, 2021

    Caomhin , via OnePlus 9 Pro , Oct 25, 2021 :
    The suggestion above is a workaround, and it may or may not work depending on how open you Network Provider has their 5G set up.

    However you do also have to get your Mobile network provider to provision and whitelist your phone onto their network.
     

    #8
  9. O1635930618649
    Cupcake Nov 7, 2021


    #9
  10. Caomhin
    OnePlus 9 Series Expert Community Expert Nov 7, 2021

    Caomhin , via OnePlus 9 Pro , Nov 7, 2021 :
    If you don't see any improvement after trying the suggestions given. Please send Bug reports and give Feedback on the issues back to the OnePlus OOS developers. So that they can investigate them.
    https://forums.oneplus.com/feedback/

    And you can also contact OnePlus support directly to see if they have more information on your issue. Scroll down the page for Email, Phone contact and online Chat details.
    https://www.oneplus.com/support
     

    #10
  11. L1629815455474
    Cupcake Nov 8, 2021


    #11
  12. H1632001072298
    Cupcake Nov 17, 2021

    H1632001072298 , Nov 17, 2021 :
    Could you pleae he
    Could you please help me find this developer setting?
     

    #12

  13. #13