3
No ANT+ support?

  1. wolfauto
    Cupcake Jun 30, 2017

    wolfauto , Jun 30, 2017 :
    Confirmed, ANT+ seemed to start working when turning on Airplane mode. However, even though in the ANT+ Tester app it is shown up as working I still cannot connect to any sensors. After the first time trying to connect to a sensor ANT stopped working again and the ANT+ Tester app started saying there was an issue again.
     
    Last edited: Jun 30, 2017

    #21
    flipperdk and 2nd like this.
  2. flipperdk
    Eclair Jun 30, 2017

    flipperdk , Jun 30, 2017 :
    Turn Airplane mode on, and then off directly makes "ANT tester" register the ARS firmware. "ANT+ Plugin Sampler" connects to my Wahoo HR strap, no problem, and contineously read the information. Rebooting the phone gave weird result; it worked the first time I started the sampler (after the reboot). 2nd time, about 30 seconds later and it didn't work. ANT Tester is back to showing Built-in firmware as "Require ARS".

    OP5 on 4.5.3
     

    #22
  3. G_Preben_Nygaard_hQpl
    Cupcake Jun 30, 2017


    #23
  4. flipperdk
    Eclair Jun 30, 2017

    flipperdk , Jun 30, 2017 :
    Had a chat with onePlus moments ago about this issue. Looks like we will need to turn airplane mode on and off for now, but they are aware that it doesn't work and are working to have it fixed. :)

     

    #24
  5. JnManso
    Eclair Jul 21, 2017

    JnManso , Jul 21, 2017 :
    Everytime that one plus launch a new mobile the ant+ does not work.... One plus one, two, three and now the five... All have the same problem at the beginning....
     

    #25
  6. ElizabethPearl
    Cupcake Jul 21, 2017


    #26
  7. wolfauto
    Cupcake Jul 25, 2017


    #27
  8. JnManso
    Eclair Aug 4, 2017


    #28
  9. JnManso
    Eclair Aug 4, 2017


    #29
  10. jasonraymond
    Cupcake Aug 7, 2017


    #30
  11. JnManso
    Eclair Sep 28, 2017


    #31
  12. felipemendes
    Jelly Bean Sep 28, 2017

    felipemendes , Sep 28, 2017 :
    I have a Garmin VivoActive. I just use the Garmin app to collect data from the watch and then export to the app I use (in case, Strava). I never even notice there was an issue with Ant+, or even that OP5 would have support to this.

    My suggestion for this not to be a bother is to use Tasker to create a task to turn airplane mode on and off again when you start the workout app.
     

    #32
  13. JnManso
    Eclair Oct 25, 2017


    #33
  14. GopalB.
    Nougat Oct 25, 2017


    #34
  15. iamagoodboy
    Eclair Oct 25, 2017


    #35
  16. JnManso
    Eclair Nov 5, 2017


    #36
  17. jbc98b
    Ice Cream Sandwich Nov 5, 2017


    #37
  18. JnManso
    Eclair Nov 7, 2017

    JnManso , Nov 7, 2017 :
    The vivosmart connects through the Bluetooth to the garmin connect app! Try to connect the heart strap directly to you phone using the ant+. After installing all the ant+ software it will only work if you put your phone in airplane mode!
     

    #38
  19. JnManso
    Eclair Nov 24, 2017

    JnManso , Nov 24, 2017 :
    Bug reported to oneplus. Already sent logs and a screencast reproducing the problem
     

    #39
    pnyg likes this.
  20. voodoopt
    Donut Dec 8, 2017

    voodoopt , Dec 8, 2017 :
    to run the ANT + I just need to turn off BT
    some problem or conflict because of ANT+ and Bluetooth
    but with me it works just by turning off Bluetooth
     

    #40