0

no call waiting on T-Mobile with global version

  1. barnabyj Gingerbread May 30, 2019

    barnabyj, May 30, 2019 :
    anyone else buy a 7 pro from OnePlus and use t-mobile? I get a network or sim card error when I see if call waiting is enabled. call forwarding does it too. I also haven't been able to get the built in visual voicemail to work..
     
    Last edited: May 30, 2019

    #1
  2. P1558379700792 Cupcake May 30, 2019


    #2
  3. barnabyj Gingerbread May 30, 2019

    barnabyj, May 30, 2019 :
    called T-Mobile, they're pushing a network update to me, but their diagnostic is saying the phone isn't compatible, and isn't connecting to all their their networks...
     

    #3
  4. JoseReyes69 Gingerbread May 30, 2019

    JoseReyes69, May 30, 2019 :
    Built in visual voicemail doesn't even work on their own devices. I have a Galaxy S10 purchased through T mobile and visual voicemail is no part of the dialer. Have to use the app

    By the way I get same error when checking call forwarding
     

    #4
  5. barnabyj Gingerbread May 30, 2019

    barnabyj, May 30, 2019 :
    hmm.. after the supposed network update they pushed, nothing changed.. they said I can call back and they can try to manually do it.. 2 days left on my return if it turns out the house version isn't fully supported.. sigh
     

    #5
  6. rlshky Eclair May 30, 2019

    rlshky, May 30, 2019 :
    Wish I could help... I bought mine direct from Oneplus and use T-Mobile. All those functions work for me. Visual voice mail worked since day 1 for me a week ago. Just tried the call forwarding and waiting menus. They each took about 30-45 seconds to load but they did work. Maybe go to a store and get a new SIM card? Maybe the access point info is wrong?
     

    #6
  7. barnabyj Gingerbread May 30, 2019

    barnabyj, May 30, 2019 :
    that's good to know.. maybe the sim I have is messed up in someway.. since yours is working, can you tell me if when you log into my T-Mobile, does it recognize your phone or does it show up unknown
     

    #7
  8. barnabyj Gingerbread May 30, 2019


    #8
  9. rlshky Eclair May 30, 2019

    rlshky, May 30, 2019 :
    Might take a bit for the first request because I’m just one person on a family plan and am not the primary person taking care of our account so I’ve never logged into our t-mobile account online.
    Using slot 1. Maybe it works for me cuz the Sim I’m using was in my Oneplus 5 and that info was associated to our account, so it’s a easy transition for the phone they have associated to my number? Again don’t know just tossing another possibility out there
     

    #9
  10. barnabyj Gingerbread May 30, 2019

    barnabyj, May 30, 2019 :
    hmm.. makes me wish I didn't program a new sim card before switching to the 7 pro.. last one I had on my 6t was from a couple of years ago. so, I never used the one that actually came with the 6t. when I ordered the 7 pro, I activated that new sim, and plugged it into my 6t. I never checked those settings there. then I moved it over..
     

    #10
  11. rlshky Eclair May 30, 2019

    rlshky, May 30, 2019 :
    But it loaded the access point info correctly into the data section of the settings for the SIM, and you’re getting relatively high speed internet from the cell network, and VoLTE works? Not sure why one would work and not the other options
     

    #11
  12. barnabyj Gingerbread May 30, 2019

    barnabyj, May 30, 2019 :
    yeah, everything seems to work, expect those 2 things so far . definitely on LTE, volte and vowifi works. calls go through..
     

    #12
  13. barnabyj Gingerbread May 30, 2019

    barnabyj, May 30, 2019 :
    just tried a new sim from TMO. same thing, either slot I tried.. OnePlus support is if course suggesting a factory reset..
     

    #13
  14. jayatla Eclair May 30, 2019


    #14
  15. rlshky Eclair May 30, 2019

    rlshky, May 30, 2019 :
    And not sure if it mattered, speaking of factory reset, I always start fresh with new devices. Didn’t transfer anything from my oneplus 5 over. No photos, messages etc. Only thing that synced was my contacts from my google account.
     

    #15
  16. barnabyj Gingerbread May 30, 2019

    barnabyj, May 30, 2019 :
    wonder if there is a problem with new sim cards or something considering the only one who doesn't seem to have this problem so far is the one with an old sim...
     

    #16
  17. rlshky Eclair May 30, 2019

    rlshky, May 30, 2019 :
    And just got our online password... it says unknown device next to my number
     

    #17
  18. barnabyj Gingerbread May 30, 2019

    barnabyj, May 30, 2019 :
    ok, thanks for checking. was wondering if since yours is working it would show up as a known device or not..

    I'm really on the fence now.. I have 2 days to return the phone. but since we know it seems to work at least with an older sim, it's possible. should be no reason the phone itself is the problem. I really don't feel like returning it for the T-Mobile version, if there is a chance this might work. I mean, even if it doesn't, no call waiting and call forwarding isn't the end of the world. just trips up my OCD to know there is something amiss.
     

    #18
  19. barnabyj Gingerbread May 31, 2019

    barnabyj, May 31, 2019 :
    factory reset did nothing other than commit me to spending the next couple of hours setting everything back up...
     

    #19
  20. barnabyj Gingerbread May 31, 2019

    barnabyj, May 31, 2019 :
    I wonder if this is a problem with the phone or T-Mobile at this point. like it doesn't read the newer T-Mobile sims correctly.. call waiting and forwarding are pretty much standard on all plans, so it shouldn't be anything they have to activate on the network..
     

    #20