2
[Answered] No data connection after Android 8.0 and Oxygen OS 5.0 update

Thread Status:
Not open for further replies.
  1. G_Matt_Boucher_Lmaq
    Cupcake Nov 25, 2017

    G_Matt_Boucher_Lmaq , Nov 25, 2017 :
    Updated to android 8.0 and oxygen OS 5.0 and since this has been installed, I am unable to get any data connection. I'm with a friend who has the same sim cards and networks, but has not updated and there are no issues with his phone.
     

    #1
  2. jaime.ferbec
    Cupcake Nov 26, 2017


    #2
    ariclark likes this.
  3. jaime.ferbec
    Cupcake Nov 26, 2017

    jaime.ferbec , Nov 26, 2017 :
    Oops, I meant Oneplus 3T.
     

    #3
  4. ariclark
    Cupcake Nov 26, 2017


    #4
  5. jaime.ferbec
    Cupcake Nov 26, 2017

    jaime.ferbec , Nov 26, 2017 :
    I have spotted the issue (at least in my case). The problem was that the APN (Access Point Name) had changed to an access point I did not have a correct username/password for. I'm guessing the OS update changed the APN I was using previously (I do not know why).
    Anyway, I solved the issue switching the APN back to the one I was using before the OS update. You can make the change in Settings => SIM and newtork => Select the SIM slot you're using => APN => select the correct APN.

    Hopefully this solves it for you too.
     

    #5
  6. Namit Bhardwaj
    Eclair Nov 27, 2017

    Namit Bhardwaj , Nov 27, 2017 :
    Thank You so much.
    It worked in. My case too.

    Cheers.
     

    #6
  7. F_Jesús_Redondo_Pascual_
    Cupcake Nov 27, 2017

    F_Jesús_Redondo_Pascual_ , Nov 27, 2017 :
    Same problem.
    It works!! Thank you!
     

    #7
  8. DayleSalmon
    Cupcake Nov 27, 2017


    #8
  9. LonestarSurvivor
    Cupcake Nov 27, 2017

    LonestarSurvivor , Nov 27, 2017 :
    I also had this problem, and resetting the APN name alone didn't look like it would help. Then I popped the SIM out to check it wasn't damaged, plugged it back in, and it all synced up to the network again!
     

    #9
  10. andy600_uk
    Cupcake Nov 27, 2017

    andy600_uk , Nov 27, 2017 :
    I have had this same problem twice - its not the APN settings. I have doubled check them and they are correct for my operator (3 UK). I found the only way to resolve this was to reboot the phone. Both times I did this and the 3 data connection was restored.
     

    #10
    Soild_UK likes this.
  11. Matovilka
    Cupcake Nov 27, 2017

    Matovilka , Nov 27, 2017 :
    This has not helped me - rebooting or switching aeroplane mode ON/OFF restores data connectivity for a few minutes.

    Google has knowledge of this bug and is supposed to fix it in November security update.
     

    #11
  12. G_kishan_singh_bQeI
    Cupcake Nov 27, 2017

    G_kishan_singh_bQeI , Nov 27, 2017 :
    Hi Guys,
    Yesterday i had flashed this Open beta rom,but after that Sim2 slot is not working (No signal only), tried flashing stock OS but getting Installation failed error.. Pleawe help me with this...
     

    #12
  13. bill_emarketer
    Eclair Nov 27, 2017

    bill_emarketer , Nov 27, 2017 :
    Excellent!! Worked for me!
     

    #13
  14. hapystar2688
    Cupcake Nov 28, 2017

    hapystar2688 , Nov 28, 2017 :
    Guys try to check the APN settings in the settings>SIM & Network>SIM 1' (or SIM 2, depending on where you have your card)>Access Point Names. Just cross check if the APN selected is incorrect. Coz I upgraded my OS in OP3 yesterday & soon after 10 minutes cellular data was lost. It showed cellular data active in notification bar but it had an "!" alongwith 4G. Today i thought of playing with the settings and there i found that after the upgrade APN selected in my handset was "Vodafone live" whereas it should have been "Vodafone connect". This case is about India though. But y'all can give it a try. Good if this helps.
     

    #14
  15. F_Shahzad_Raja_Mohammad_
    Cupcake Nov 29, 2017

    F_Shahzad_Raja_Mohammad_ , Nov 29, 2017 :
    wow, exactly what I was looking for - edited APN and go the nerwork working- simple thing but I was struggling with it for days.
     

    #15
  16. stevenni
    Cupcake Dec 22, 2017

    stevenni , Dec 22, 2017 :
    This community is why I love one plus! Thank you so much!
     

    #16
  17. andy600_uk
    Cupcake Jan 11, 2018

    andy600_uk , Jan 11, 2018 :
    I am regularly getting this problem - at least once a day - I repeat its not the APN settings. You can use the *#800# code and then 'Modem Crash'. This stops you having to reboot the phone to get the signal back.
     

    #17
  18. Mich O.
    Ice Cream Sandwich Jul 30, 2018

    Mich O. , Jul 30, 2018 :
    Hello @G_Matt_Boucher_Lmaq,

    This is from the OnePlus Bug Hunters.

    If this issue persists on the latest build, please raise a new bug report and we will look into it again. This thread will now be closed.

    Thank you and have a great one.
     

    #18