0
No fixes so far have worked - Dead Home Button and Random Reboots

  1. Nickexp
    Honeycomb Jan 9, 2016

    Nickexp , Jan 9, 2016 :
    I've had my OP2 for a good few months and it's worked flawlessly, no issues. But then my home button stopped working and I got random reboots. After about a hour of searching for a fix for the home button I found one that made it come back for about 5 minutes then stopped working again (I swapped to "awesomeplayer") , so it isn't hardware. The random reboots also are new and started at the same time the home button died. The reboots will completely stop happening for days on end then happen like 3 times within 10 minutes.

    Does anyone know of any fixes for this, (the home button issue is more important to me, by the way) because all of the fixes I've tried haven't worked.

    The issue began on the second newest update (which I got the day it came out and it worked fine for ages) and then I flashed the newest one to try to fix it and even tried factory reset.

    My phone is the Chinese version and is running Oxygen OS.

    I'm yet to try any fixes for the reboots as they don't bother me as much and I assume will go away when I resolve the home button issue, anyway. But I need my home button back so I can use the fingerprint scanner and have my phone secure again before school starts so my friends won't mess with my phone.

    EDIT:
    I did the "*#808#" command and got a fail on the fingerprint auto test. But when my home button originally died I managed to change something in the settings (after it was dead for about an hour) and it worked again for about 5 minutes, so it's software, isn't it? Otherwise it wouldn't have come back from a software change.

    I then did the non-auto test (quality) and it came up with some Chinese (I'd assume) writing in green.
     
    Last edited: Jan 9, 2016

    #1
  2. Dimmerworld
    Honeycomb Jan 9, 2016


    #2
  3. Dimmerworld
    Honeycomb Jan 9, 2016

    Dimmerworld , Jan 9, 2016 :
    And turn on on-screen home button
     

    #3
  4. Nickexp
    Honeycomb Jan 9, 2016

    Nickexp , Jan 9, 2016 :
    It stopped working then I updated, so I don't see what the next one would do. And I'm using on screen but it's awful. I can't quick boot the camera, plus my phone is completely unsecured - which isn't a good idea in a high school with all of my friends who seem to want to make having a phone by OnePlus difficult by f**king with it. Not to mention the plethora of typos I've made, failed attempts at backspacing that open emojis and send like 20 emojis and in general it being werid with everything being higher up.
     

    #4
  5. jp_1plus
    Honeycomb Jan 9, 2016

    jp_1plus , Jan 9, 2016 :
    "Wait for the next update and hope for the best"

    Pardon my bluntness, but that is terrible advice.
     

    #5
    Nickexp likes this.
  6. dinjesk
    KitKat Jan 9, 2016


    #6
  7. SoniaB
    Nougat Head Moderator Jan 9, 2016

    SoniaB , Jan 9, 2016 :
    Have you tried flashing the full OxygenOS ROM yourself?
    Chinese versions of the phone come with HydrogenOS, so if you bought from a 3rd party seller, then they would have installed OxygenOS. If you did this yourself, then perhaps try clearing system cache via recovery or try reinstalling OxygenOS again.
    A clean instal is most likely what OnePlus support will tell you to do as part of the initial troubleshooting.
     

    #7
    Adityaf and Tokolozi like this.
  8. Nickexp
    Honeycomb Jan 9, 2016

    Nickexp , Jan 9, 2016 :
    I did do that, and I've flashed 2 of the updates since getting it, so I know it's fine. That didn't resolve the issue. I even tried factory reset then flashing it.
    Yep.
     

    #8
    SoniaB likes this.
  9. iPusak Gaoq™
    Jelly Bean Jan 9, 2016

    iPusak Gaoq™ , Jan 9, 2016 :
    Flash Hydrogen OS and see if problem persist....if you got the same problem with Hydrogen OS then it could be hardware problem (grounding issues)....keep in mind Hydrogen OS is 5x stable then Oxygen OS...
     

    #9
    SoniaB likes this.
  10. SoniaB
    Nougat Head Moderator Jan 9, 2016

    SoniaB , Jan 9, 2016 :
    Then I am not sure what else you could do. It may be a hardware issue as @iPusak Gaoq™ has said. Flashing HydrogenOS would help confirm that.
    You bought from a 3rd party seller. What method did you buy the OP2? If you are unable to get anywhere with the seller and you used PayPal, you can contact them about starting a pay dispute.
    PayPal, depending on what they class your claim as, can allow you to have up to 180 days from purchase to open a dispute.
     

    #10
    Adityaf and iPusak Gaoq™ like this.
  11. Nickexp
    Honeycomb Jan 9, 2016

    Nickexp , Jan 9, 2016 :
    Where do I get the download for Hydrogen? Also, I do not think it's hardware as I changed something in the developer settings (I didn't have access to them before the issue, I went and gave myself developer when troubleshooting) and swapped to "AwesomePlayer" and it came back for a bit, but then stopped working again- so it seems like software to me, because I don't see how a software change could bring back dead hardware.
     

    #11
  12. SoniaB
    Nougat Head Moderator Jan 9, 2016

    SoniaB , Jan 9, 2016 :
    This is the one I know of on XDA.

    http://forum.xda-developers.com/oneplus-2/development/rom-h2os-hydrogen-os-ota-clean-stable-t3195636

    as posted in this thread on the forum:

    https://forums.oneplus.net/threads/hydrogen-os-official.368899/
     

    #12
  13. iPusak Gaoq™
    Jelly Bean Jan 10, 2016

    iPusak Gaoq™ , Jan 10, 2016 :
    It is a hardware failure if you got the same problem after flashing Hydrogen OS....if you think that is a software problem when you can always revert back the change you make in developer option as you have change something on developer option after updates because the home button start giving you problem...before updates there no problem...factory reset didn't help you too so flashing Hydrogen OS is the only way to find out what is the real problem....if home button is working on Hydrogen OS then flash Oxygen OS before the last updates and wait for a new updates which might have a home button fix...
     

    #13
  14. Nickexp
    Honeycomb Jan 11, 2016

    Nickexp , Jan 11, 2016 :
    I was on the update for AGES before anything happened, so it wouldn't be something a update would fix, I don't think. Also, the developer settings thing only worked for about 5 minutes.
    It says crap about needing TWERP and stuff, can I just flash it like I would a normal update and ignore that stuff?
     

    #14
  15. Pankaj duggal
    Cupcake Jan 27, 2016

    Pankaj duggal , Jan 27, 2016 :
    Just dial *#808# nd then press check home button or fingerprint scanner . this work for me nd my home button works fine
     

    #15
  16. Nickexp
    Honeycomb Jan 29, 2016

    Nickexp , Jan 29, 2016 :
    Did that and it said it's dead and didn't fix it
     

    #16
  17. Adityaf
    Ice Cream Sandwich Jan 29, 2016

    Adityaf , Jan 29, 2016 :
    Generally flashing full OxygenOS zip is helpful anytime
     

    #17
  18. MichelHPerez
    Eclair Jan 29, 2016

    MichelHPerez , Jan 29, 2016 :
    It's something that honestly magically starts working again mine stoped for no reason for 3 weeks then out of no where it just started working don't reload any other rom just re flash the original maybe wip the cache
     

    #18