0
No Wifi 5GHz, can be fixed?

Thread Status:
Not open for further replies.
  1. ramik Gingerbread Sep 21, 2016

    ramik, Sep 21, 2016 :
    (Sorry if this is repeated, couldn't find info)

    Got my OP3 last week, today I came back home to find it doesn't detect my 5GHz wifi network !!

    is it a software issue? hardware? I am all stock, running latest 3.2.6 rom, no root, no bootloader unlock. just a new device with everything stock.

    Please help
     

    #1
  2. Superbrowndude Ice Cream Sandwich Sep 21, 2016

    Superbrowndude, Sep 21, 2016 :
    I'm pretty sure it's a software issue, if you can re update to 3.2.6 again and ensure your other devices are able to connect to the 5ghz network. I'm running 3.2.6 with no issues on 5ghz. Except I'm rooted and flashed it manually with no other mods.
     

    #2
    4tr4s likes this.
  3. Remo spadaccini Honeycomb Sep 21, 2016

    Remo spadaccini, Sep 21, 2016 :
    Make sure you have auto band enabled in the advanced wifi settings by going to wifi->advanced(in the three horizontal dots)->WiFi frequency band-> then select auto. If it is in auto and still doesn't connect to 5ghz then there may be another problem. Also you can try only 5ghz by selecting 5ghz instead of auto
     

    #3
  4. ramik Gingerbread Sep 22, 2016

    ramik, Sep 22, 2016 :
    The problem was on the router side, it was set to offer 5GHz on channel "auto", which didn't seem to work with OP3, when I set it manually to 36 it worked.
     

    #4
  5. MarkLR Jelly Bean Sep 22, 2016

    MarkLR, Sep 22, 2016 :
    Indeed, the OnePlus3 supports 5ghz just fine. I noticed the 5ghz network is a lot more unstable than 2.4ghz when the signal is weak, when I accidentally set my router to only use 5ghz I had MAJOR problems with everything network related working in a very unstable way, especially youtube.
     

    #5
    Andrizzy R, srlawren and pa5t1s like this.
  6. ramik Gingerbread Sep 22, 2016

    ramik, Sep 22, 2016 :
    Update:

    Maybe the issue is that OnePlus 3 doesn't support the DFS channels (Dynamic Frequency Selection), when I set the router to use one of them, OP3 stops detecting 5ghz (which is the case with Auto setting). something below 100 is ok.
     
    Last edited: Sep 22, 2016

    #6
  7. emerowo Froyo Sep 22, 2016

    emerowo, Sep 22, 2016 :
    You have to check, wchich ones channels are legal, and wchich ones illegal in Your country , and then change channel number in router to legally channel.
     

    #7
  8. srlawren Honeycomb Sep 22, 2016

    srlawren, Sep 22, 2016 :
    I tend to find this in general with 2.4 vs. 5GHz Wi-Fi. I've had this same behaviour with my own Netgear 3700 router, my mother's Linksys (forget the model, WRT400N maybe?), and the integrated WiFi in the cable modem at my father's place, across a variety of client devices including the OP3, my previous phones (Moto X 1st gen, BlackBerry Z10, etc), and a few different laptops. I always try to connect to the 2.4 network when possible as it gives me a more stable and consistent connection.
     

    #8
  9. ramik Gingerbread Sep 22, 2016

    ramik, Sep 22, 2016 :
    @all
    I know that 2.4 is more stable, and can reach further, but my router offers 450 Mbps on 2.4Ghz and 867 Mbps on the 5Ghz, and I want to get the fastest possible.

    With the same OP3 and the same Router at the same place: with 2.4Ghz I get 72mbps, while on 5Ghz I get 200 Mbps.
     

    #9
  10. G_Andy_Bao_(nulldev)_uer Gingerbread Sep 22, 2016

    G_Andy_Bao_(nulldev)_uer, Sep 22, 2016 :
    5GHz and 2.4GHz are legal in all countries. Maybe you are talking about bands?
     

    #10
  11. ramik Gingerbread Sep 22, 2016

    ramik, Sep 22, 2016 :
    No, I guess emerowo is right, the channels have sometimes limitations per country, such as Wifi 2.4Ghz channels 13 and 14 are not permited in the USA, while allowed elsewhere, that's why the FCC wants to limit firmware changes.
     

    #11
  12. G_Andy_Bao_(nulldev)_uer Gingerbread Sep 22, 2016

    G_Andy_Bao_(nulldev)_uer, Sep 22, 2016 :
    Sorry, 5GHz and 2.4 GHz are bands.
    2.4GHz has 14 channels while 5GHZ has 189 channels. Either way, both 2.4GHz and 5GHz should work fine no matter where you are, most countries support at least one channel in both bands.
     

    #12
  13. F_Will_Zehetmayr_zAKZ Donut Sep 22, 2016

    F_Will_Zehetmayr_zAKZ, Sep 22, 2016 :
    I have problems with both frequencies. 2.4 is slow to the point where LTE feels like the quicker option. 5 is intermittent. Not sure how to resolve.
     

    #13
  14. emerowo Froyo Sep 23, 2016

    emerowo, Sep 23, 2016 :
    I'm talking about channels , not about 5GHz or 2.4GHz - if I choose channels between 100-161 in router, my OP3 can't see these channels. In my country these channels are reserved for other purposes. And - I think - these channels are blocked in OP3
     

    #14
  15. ramik Gingerbread Sep 23, 2016

    ramik, Sep 23, 2016 :
    I am in Italy, and devices support these channels: my router is set to Italy's channels and it automatically choose a DFS channel (above 100), the OP3 has also been bought from the Italian store, so I guess on a hardware level it might not support them*, or disabled in OOS roms for all, regarding country. and for the moment I don't want to root or change roms.

    *in the specs they say it support "Wi-Fi 802.11 a/b/g/n/ac", they don't specify which bands/channels and maximum speeds on each, because now there is also MU-MIMO.
     

    #15
  16. HITMAN2 Cupcake Sep 23, 2016

    HITMAN2, Sep 23, 2016 :
    I have the same problem , i have huawei-e5372 and its on 5 Ghz band but my OP3 cant recognize this band , when i switch the modem to 2.4 Ghz its working fine without any problem

    i also have Samsung galaxy s3 and its working fine on this modem using two bands 5 Ghz and 2.4 Ghz
     

    #16
  17. G_Ping_Ou_Ratd Froyo Sep 24, 2016

    G_Ping_Ou_Ratd, Sep 24, 2016 :
    5 is shorter rang and high speed. 6 more wireless connection use 5 GHz is better.
     

    #17
  18. srlawren Honeycomb Sep 24, 2016

    srlawren, Sep 24, 2016 :
    I'll take stable and a bit slower over faster and unstable any day of the week. Usually it's the internet that's the limiting factor these days more than the WiFi connection anyway. :)
     

    #18
  19. Grahamdc Eclair Sep 26, 2016

    Grahamdc, Sep 26, 2016 :
    Not sure if you've got a fix for this yet but I to couldnt see my 5ghz WiFi channel, I fixed this by using the WiFi analyzer app in the play store, I found other WiFi hotspots on 5ghz and then set my WiFi channel to the same settings instead of auto.
    The channel I'm using is ch40 5200mhz
     

    #19
  20. SimonRam Lollipop Sep 26, 2016


    #20