No WifiCalling or VoLTE ? Here is your solution!

  1. 777SAO
    Eclair May 24, 2019

    777SAO , May 24, 2019 :
    I've been searching all around, called my Carrier support, opened a Bug report on OnePlus for this issue posted around the forum, no one was able to help.

    I even have a thread (where i will link this one) asking people with whom it worked and didn't work... and now i found the solution. I just tested on my 7pro, and it worked!

    Follow this link and the article, and report back to see if it works!


    I'll be happy to know if i helped some people!

  2. Sargo
    Ice Cream Sandwich May 24, 2019

    Sargo , May 24, 2019 :
    the apk is not needed
    use dialer and dial *#800# to get to the same menu
    also keep in mind you are essentially forcing this function on
    Ive done this on my 3t and while volte was working perfectly I had to disable vowifi since every call that wanted to come through using this method was giving the engaged sound on the other end
    worth a try but make sure you test it properly

  3. 777SAO
    Eclair May 24, 2019

    777SAO , May 24, 2019 :
    Not all have, i didn't have it on 1.0, I installed 1.0-1 and it appeared. On the 1.0 i didn't have the VoLTE or WifiCalling in the LogKit.

  4. skinnytoo
    Eclair May 25, 2019

    V1558368669343 likes this.
  5. arabinow
    Froyo May 25, 2019

    arabinow , May 25, 2019 :
    did this method on my op 7 pro in Canada on Fido. Still not using volte or wifi calling.

    was crossing my fingers. oh well

  6. WA_Bob
    Jelly Bean May 25, 2019

    WA_Bob , May 25, 2019 :
    You have to call Verizon to set it up on their end. It doesn't take too long and it was pretty simple for me. Works great now.

    mcosenza14 likes this.
  7. skinnytoo
    Eclair May 25, 2019

    skinnytoo , May 25, 2019 :
    I have wifi calling feature on the line. Is there something else they need to do?

  8. noctua75
    Eclair May 25, 2019

    noctua75 , May 25, 2019 :
    great, thank you very much ! both work fine !!

    Carrier "Drei", Austria

    Attached Files:

    • 1.jpg
      File size:
      317.3 KB

  9. Syaoran
    Froyo May 25, 2019

    Syaoran , May 25, 2019 :
    Does your screenshot confirm that the roaming options are available for each SIM separately and not just a single option applying to both SIM's?

  10. Mikey_1273
    Gingerbread Aug 18, 2019

    Mikey_1273 , Aug 18, 2019 :
    don't have this issue with my op 7pro as I'm on TMobile and they are very open with unlocked phones plus they sell this. model.

    I did get a friend who had a iPhone 5 on At&t with a bulged out battery in to an OP 6t. picked it up on the back to school sale. so far he loves it but I have to check with him if volte is working. I hear at&t tries to keep non at&t branded phone from accessing volte and vowifi.

    I wonder if this works on the 6t also?

  11. V1558368669343
    Cupcake Aug 18, 2019

    V1558368669343 , Aug 18, 2019 :
    Screenshot_20190818-165605.jpg Screenshot_20190818-165559.jpg Worked for me on Verizon. Tap Sim# with the. Verizon SIM and you will see the Wi-Fi calling option.

  12. F_Lars_Dennert_NbST
    Gingerbread Aug 21, 2019

    F_Lars_Dennert_NbST , Aug 21, 2019 :
    when you say worked for you on Verizon are you referring to being able to flip the switch or actually make WiFi calls? in other words airplane mode with WiFi on you can make calls?

    Coolhandz likes this.
  13. pgrey
    Ice Cream Sandwich Sep 13, 2019

    pgrey , Sep 13, 2019 :
    I'm wondering the same if "anyone got it to make a call, in Airplane Mode" (with WiFi turned back on, explicitly, obvioulsy)?
    Anyone above ever test this? Thanks.

  14. Geoff Junior
    Cupcake Sep 14, 2019

  15. A1568536359916
    Cupcake Sep 15, 2019

    A1568536359916 , Sep 15, 2019 :
    Hi, thanks for the tip! Now I have working VOLTE on my Oneplus 7 Pro on T-Mobile Czech republic.
    Btw. had to install that app, it was actualization of my log kit where there was no function switch for VoLTE and VoWIFI.

  16. iptvcld
    Cupcake Oct 20, 2019

    iptvcld , Oct 20, 2019 :
    I tired to enable this via the toolkit as mentioned and even though both are toggled on, nothing happens. I am in Canada with Rogers. Anyone in Canada with Rogers got this working?

  17. arabinow
    Froyo Oct 20, 2019

    arabinow , via OnePlus 7 Pro , Oct 20, 2019 :
    Rogers and Fido won't support OnePlus phones and volte or wifi calling. They claim they will only support phones bought from them.

  18. iptvcld
    Cupcake Oct 20, 2019

    iptvcld , Oct 20, 2019 :
    Ah, that's too bad! How about Telus and Bell, same deal?

  19. arabinow
    Froyo Oct 20, 2019

    arabinow , via OnePlus 7 Pro , Oct 20, 2019 :
    I don't think any Canadian carriers supports it. Also could be that OnePlus the company isn't working with Canadian carriers to get it to work.

  20. iptvcld
    Cupcake Oct 20, 2019

    iptvcld , Oct 20, 2019 :
    Thanks for the reply, appricate it.. I have bad reception in my home and was a feature I always had on my other devices. Lucky I'm still within my 15 days to decide. It was oneplus 7 pro VS pixel 4 xl