0
Network/Connectivity

Not able to edit/add APN settings in OP3

?

Is this common problem

  1. Yes

    8 vote(s)
    100.0%
  2. No

    0 vote(s)
    0.0%
  1. thezionview Donut Mar 30, 2017

    thezionview, Mar 30, 2017 :
    Hi,
    I saw several posting regarding this in the forum, i tried multiple options but i still have the issue.
    My OP3 doesnt allow me add new access point. When i add and save the saved details just diappear.

    Below are the options i tried based on reading other similar posts regarding this problem.

    1. Clear cache and try it. Done but not working still
    2. Clear cache, restart and Try. No luck.
    3. Change to default theme and try No luck
    4. Change to OnePlus launcher and try No luck
    5. Turn off wifi and bluetooth and try No luck
    6. Turn on wifi and try No luck
    7. Switch to airplane mode and try Nope Not working


    So the only other option i havent tried is factory resetting of phone. I dont want to do that as i have several file/photo/contacts and OP doesn't have a simple recover option( my phone is not rooted).

    So what else should i try before this starts working, and If this is a known issue , is there a solution or ETA for the fix?
     

    #1
  2. thezionview Donut Mar 30, 2017

    thezionview, Mar 30, 2017 :
    Here is the screenshot,, as you can see i am able to get LTE connection for SIM1 with existing setting, but for SIM2 i need to add new APN setting which i am not able to do
     

    Attached Files:


    #2
  3. darius1988 KitKat Mar 30, 2017

    darius1988, Mar 30, 2017 :
    you can Factory reset your phone without losing pictures, music and personal data. Go to settings- backup and reset , then you got the opcion to reset only the apps and not personal data
     

    #3
  4. thezionview Donut Mar 30, 2017

    thezionview, Mar 30, 2017 :
    I completed the Factory reset as well still not able to edit/add APN settings.
     

    #4
  5. Bartnl Lollipop Mar 30, 2017

    Bartnl, Mar 30, 2017 :
    And what if you turn off the 4G for Sim1 temporarily? Is it then possible to add it for the second Sim?
    You are aware that you can only use 1 Sim with 4G at the time and not both simultaneous?
     

    #5
  6. thezionview Donut Mar 30, 2017

    thezionview, Mar 30, 2017 :
    I am not sure what you are talking about.At any point in time the cellular data can come from only one SIM.
    This is why we have Default SIM for cellular data option in the SIM& Networks menu.


    I am not sure what switching off of 4G you are talking about, can you explain more clearly.
    As i understand only one data connection from one SIM is possible at any given point in time.
     

    #6
  7. turist Eclair Mar 30, 2017

    turist, Mar 30, 2017 :
    I have the same problem, hoping to find a solution...

    I also took out the my SIM1 in which the data worked and used only SIM2 in the first slot and still same problem... No internet...

    Also I should point out that everything worked before the last update... I'm currently running A3003_28_170313
     

    #7
  8. darius1988 KitKat Mar 30, 2017

    darius1988, Mar 30, 2017 :
    then roll back to the previest version
     

    #8
  9. thezionview Donut Mar 31, 2017

    thezionview, Mar 31, 2017 :
    that easier said than done. what if i want the new features ,you can't have this or that option in high end phone
     

    #9
  10. darius1988 KitKat Mar 31, 2017

    darius1988, Mar 31, 2017 :
    Or instal again the new version...
     

    #10
  11. Aron.Lif Cupcake Apr 1, 2017


    #11
  12. turist Eclair Apr 5, 2017

    turist, Apr 5, 2017 :
    I have now done factory data reset but still exactly the same problem...
     

    #12
  13. turist Eclair Apr 21, 2017

    turist, Apr 21, 2017 :
    Guys. I managed to fix my issue. If anyone is facing the same problem then what I did is this:
    At the end of APN settings there is a setting "MVNO Type", I don't know what it was before but after changing it to "IMSI", new APN names and stuff came up and after that the settings that didn't work before started working.
     

    #13
  14. mgcase1 Cupcake Aug 6, 2018

    mgcase1, Aug 6, 2018 :
    turust -- you're a genius! even though the screen says that I couldn't edit the APN, after doing as you say, setting the MVNO Type to IMSI, I could magically save the info and access mobile data! I am saved1!
     

    #14