0
Not able to install any other build via local upgrade since Android 9 update

  1. tush@r97
    Cupcake Sep 27, 2018

    tush@r97 , Sep 27, 2018 :
    I'm not able to install any other build.like the open beta or the downgrade version via local upgrade, every time I try to install any other build a installation failure occurs this started to happen after Android 9 update.
     

    #1
  2. anupritaisno1
    KitKat Sep 27, 2018

    anupritaisno1 , Sep 27, 2018 :
    Provide more details about the error
     

    #2
  3. MD_18
    Honeycomb Sep 27, 2018

    MD_18 , Sep 27, 2018 :
    turn on the oem unlocking in developer options. then try again. it'll work for sure.
     

    #3
  4. anupritaisno1
    KitKat Sep 27, 2018

    anupritaisno1 , Sep 27, 2018 :
    no it won't. OEM unlocking simply changes one byte at the end of the factory reset protection partition. changing it won't do anything
     

    #4
    idkwhoiam322 and Kytharsis like this.
  5. Adityatawade17
    Honeycomb Sep 27, 2018


    #5
  6. MD_18
    Honeycomb Sep 27, 2018

    MD_18 , Sep 27, 2018 :
    i know that but he didn't specify the exact error so i thought this is the issue coz most of people in forum don't even know about oem unlocking and all. or maybe he's not using the roll back rom so he might be getting that error.
     

    #6
    Kytharsis likes this.
  7. tush@r97
    Cupcake Sep 28, 2018

    tush@r97 , Sep 28, 2018 :
    I enabled developer option and in that also enabled the OEM unlocking but still not able to install any other build.
    Every time I choose the package from root directory and click install it shows that installation cannot occur above the status bar of the system update screen.
     

    #7
  8. tush@r97
    Cupcake Sep 28, 2018

    tush@r97 , Sep 28, 2018 :


    MD_18

    i know that but he didn't specify the exact error so i thought this is the issue coz most of people in forum don't even know about oem unlocking and all. or maybe he's not using the roll back rom so he might be getting that error.​


    Sir I'm trying to install beta 3 and I'm on Oxygen OS 9.0 why would I need a downgrade ROM for that and I'm flashing stuff since last 5 years and I'm not new to this environment, plus I'm a Android developer and a ROM expert, installing updates and packages in OnePlus devices is still not anywhere near the level of flashing custom ROMs in devices like Samsung and Xiaomi. So I'm doing all the steps correct but there is a bug in the latest version.
     

    #8
  9. G_Charlie_Wright_Tndu
    Cupcake Sep 28, 2018

    G_Charlie_Wright_Tndu , Sep 28, 2018 :
    Andrew 9 sucks it will not even allow you to update your apps. it will download to 100% And set there then you have to reboot your phone to get it to install you have to do that to every app, my Garmin watch will not Bluetooth to the the phone anymore either. it's in the Android 9 update.
     

    #9
  10. MD_18
    Honeycomb Sep 28, 2018

    MD_18 , Sep 28, 2018 :
    see first of all you mentioned that downgrade thing so read again what you you wrote. secondly you didn't specify the error you're getting so we don't know what issues you're facing. and if you call yourself an android developer then you should have figured it out on your own. if you're creating a thread then specify the exact problem you're facing. you call yourself developer and don't even know what error you're getting. now I've a doubt regarding the developer thing. Also OnePlus 6 supports A/B partition like pixel so yeah flashing is hard unlike Samsung and Xiaomi who still haven't followed the trend of seamless upgrades.
     

    #10
  11. MD_18
    Honeycomb Sep 28, 2018

    MD_18 , Sep 28, 2018 :
    i think the file you downloaded is broken. download it again via OnePlus website only. also don't forget to download the correct file.
     

    #11
  12. tush@r97
    Cupcake Sep 28, 2018

    tush@r97 , Sep 28, 2018 :


    MD_18

    see first of all you mentioned that downgrade thing so read again what you you wrote. secondly you didn't specify the error you're getting so we don't know what issues you're facing. and if you call yourself an android developer then you should have figured it out on your own. if you're creating a thread then specify the exact problem you're facing. you call yourself developer and don't even know what error you're getting. now I've a doubt regarding the developer thing. Also OnePlus 6 supports A/B partition like pixel so yeah flashing is hard unlike Samsung and Xiaomi who still haven't followed the trend of seamless upgrades.​


    Yeah I figured out the problem myself and now I'm able to install another build. I re-downloaded the package from oneplus website and the package got installed successfully.
    Thanks for the concerns.
     

    #12
  13. MD_18
    Honeycomb Sep 28, 2018

    MD_18 , Sep 28, 2018 :
    what was the problem?
     

    #13
  14. tush@r97
    Cupcake Sep 28, 2018

    tush@r97 , Sep 28, 2018 :
    I think the package file was corrupted, I re-downloaded it and reinstalled it later it got Installed successfully.
     

    #14
  15. MD_18
    Honeycomb Sep 28, 2018

    MD_18 , Sep 28, 2018 :
    see i told ya. so stop whining and blaming OnePlus for such things.
     

    #15
  16. tush@r97
    Cupcake Sep 28, 2018

    tush@r97 , Sep 28, 2018 :
    yeah my bad and thanks
     

    #16
    Budruel likes this.
  17. _Khalid
    Gingerbread Sep 28, 2018

    _Khalid , Sep 28, 2018 :
    Apps are still not supported or built with Android Pie. Hence the issue. wait for the developers of the apps to built it with Android Pie API.
     

    #17
  18. anupritaisno1
    KitKat Sep 28, 2018

    anupritaisno1 , Sep 28, 2018 :
    oh yeah? ROM developer

    if you're a ROM developer you should have had enough knowledge of how to use adb logcat but it seems like you do not

    simply building ROMs doesn't make you a developer, cupcake
     

    #18