1
Not getting Gmail notification after Android 11 update via OnePlus 6

  1. B1552743901147
    Cupcake Sep 13, 2021


    #1
    VipulChandu likes this.
  2. Liehjan
    The Lab Reviewer - OnePlus Buds Pro Community Expert Sep 13, 2021

    Liehjan , Sep 13, 2021 :
    Battery optimization is off?
     

    #2
  3. B1552743901147
    Cupcake Sep 13, 2021


    #3
  4. Liehjan
    The Lab Reviewer - OnePlus Buds Pro Community Expert Sep 13, 2021

    Liehjan , Sep 13, 2021 :
    Set Gmail app to do not optimize.
     

    #4
  5. B1552743901147
    Cupcake Sep 13, 2021


    #5
  6. A1594910915738
    Honeycomb Sep 13, 2021


    #6
    K1552204904685 likes this.
  7. ItsRavi25
    Jelly Bean Sep 14, 2021

    ItsRavi25 , Sep 14, 2021 :
    Gmail notifications issue, follow the steps below:
    1. Disable RAM Boost.

    2. Goto > Settings > Battery >Battery optimisation > Right top corner 3 dots > Advance optimisation > Disable sleep stand by and optimise app power consumption.

    3. Go to App Info of Gmail App, Unde Batter section select
    "Don't Optimize" option.

    4. Again in App Info of Gmail, go to Permissions. At Bottom
    disable "Remove permissions if app isn't used" option.

    5. Restart your phone.


    Try this basic settings

    1) Update Gmail to latest version. Then goto app info clear the cache and storage of Gmail app.

    2) Check the Gmail Sync settings

    Open the Gmail app Tap the side menu button at the top-left corner.
    Tap Settings (at the bottom)
    Select your account.
    Scroll to the bottom. Under "Data usage", make sure you've enabled Sync Gmail.

    3) Check your device's account sync settings

    Open the Settings app
    Scroll down and select Accounts First, scroll to the bottom and make sure "Auto-sync turned on.
    After that, select your Gmail account from the list.
    Tap Account sync. Make sure you enable the Gmail.

    Also go through this thread
    https://forums.oneplus.com/threads/...ail-notification-fixing-for-everyone.1496545/
     

    #7
    antivirtel likes this.
  8. antivirtel
    Cupcake Nov 14, 2021

    antivirtel , Nov 14, 2021 :
    Hi,

    Thanks for all this, it looks like the below is the key, that fixed the Gmail notifications.

    OnePlus 6, Android 11, OxygenOS 11.1.1.1

    Thank you!
     

    #8
  9. WonMinus
    Froyo Nov 16, 2021

    WonMinus , Nov 16, 2021 :
    No. It does not fix it. It only seems working for a while and the problem will be back.
     

    #9
    K1552204904685 likes this.
  10. S1562559378015
    Cupcake Nov 16, 2021


    #10
  11. schar07
    Cupcake Nov 25, 2021

    schar07 , Nov 25, 2021 :
    You may wanna check Settings - Apps and Notifications - Notifications - Advanced "Hide silent notifications in status bar" flag: i had it set, not sure why
     

    #11
  12. antivirtel
    Cupcake Dec 4, 2021

    antivirtel , Dec 4, 2021 :
    Yeah, you're right, it seemed to be working for me on OxygenOS 11.1.1.1 after disabling Optimise App Power Consumption, but after upgrading to 11.1.2.2, it stopped working again even with that disabled (OnePlus 6). Please fix it, as this is useless like this... I'm thinking of flashing in a custom firmware, like LineageOS, but hate living with other bugs...
     

    #12