6
Not receiving incoming calls on 8t via OnePlus 7

  1. A1606838074141
    Cupcake Jan 25, 2021

    A1606838074141 , via OnePlus 7 , Jan 25, 2021 :
    Can anyone help, I am not receiving incoming calls on my one+8t. Took some time to realise this but have done some investigation and there is something very odd going on.

    If I am on Instagram I do not receive incoming calls, however if I force stop Instagram I appear to then be able to receive calls. Has anyone ever seen this before? Maybe its some funny setting?

    Worth mentioning this was a brand new phone that had to be sent back straight away cause the mobile network wouldn't connect. This was fixed but now not receiving calls when certain apps are on seems very odd.

    Android version 11
    Oxygen OS 11.0.6.9

    Edit: resolution for me as mentioned in below replies
    We are in Ireland and using the 3 network, the default settings on the phone for preferred network type is 2g/3g/4g/5g (default) which enables another 5g setting. I changed this to be 2g/3g/4g (default) which removed 5g. I am guessing the networks here are not up and running in terms of 5g and this is some how effecting network connection on the phone.

    Go to settings -> WiFi and internet -> SIM and network -> preferred network type -> set 2g/3g/4g (default)
     
    Last edited: Apr 19, 2021

    #1
  2. Dave Kavanagh
    Cupcake Jan 26, 2021

    Dave Kavanagh , Jan 26, 2021 :
    I also experience this issue - took my weeks of missing calls to notice. When someone rings me, on their end they can hear my phone ringing, but on the phone (8T Oxygen OS 11.0.69.KB05BA) absolutely nothing happens.

    I've tested this myself by calling from a friends phone, whilst watching my phone - nothing happens whatsoever on the handset despite me hearing the dial tone on the calling phone. This is a very worrying bug; as of now I cannot receive calls and am not even aware that I am missing calls. Need a patch for this ASAP!

    Unlike the above, I have not noticed this happening when any particular apps are in use - I have observed it even after a phone reboot when no apps at all have been opened yet.
     

    #2
  3. A1606838074141
    Cupcake Jan 26, 2021

    A1606838074141 , via OnePlus 7 , Jan 26, 2021 :
    Hey Dave I think I may have found a resolution but still testing so not 100% hopefully it works and can help you too.

    We are in Ireland and using the 3 network, the default settings on the phone for preferred network type is 2g/3g/4g/5g (default) which enables another 5g setting. I changed this to be 2g/3g/4g (default) which removed 5g. I am guessing the networks here are not up and running in terms of 5g and this is some how effecting network connection on the phone.

    Go to settings -> WiFi and internet -> SIM and network -> preferred network type -> set 2g/3g/4g (default)
     

    #3
  4. Dave Kavanagh
    Cupcake Jan 26, 2021

    Dave Kavanagh , Jan 26, 2021 :
    Will try that, also Ireland and also with 3! Thanks!
     

    #4
    I1611869542416 likes this.
  5. Scruff21
    Cupcake Feb 1, 2021

    Scruff21 , Feb 1, 2021 :
    This has been happening me too. The 2g/3g/4g option still has a long delay though. As in, when i'm calling it dials out for about 10-15 seconds before my phone starts ringing. its pretty much instant when switched to 2g/3g option but this isn't obviously ideal for internet connection.
     

    #5
    I1611869542416 likes this.
  6. eamonnde
    Donut Feb 17, 2021

    eamonnde , Feb 17, 2021 :
    Glad to know I'm not the only one having this issue, also on 3 Ireland - This started happening for me around middle of January, can't remember if there was an update at the time.

    The phone has been back to OnePlus and they've changed the Mainboard as a result but still seeing the issue - I've had it out with OnePlus over the issue as well.

    Going to try the above and see but I get issue regardless if on Wifi or 4G.
     

    #6
  7. Q1610196617594
    Cupcake Feb 24, 2021

    Q1610196617594 , Feb 24, 2021 :
    Hi All, same issue here and from ireland and with 3. Did the above work? I am meant to have a remote session with OP but have heard nothing.
     

    #7
    I1611869542416 likes this.
  8. cormac1982
    Donut Mar 15, 2021

    cormac1982 , Mar 15, 2021 :
    Hi lads. Same issue here with my one plus 8 Pro, also on 3 Ireland. Had the phone since start of January and only realised lately the full extent of the problem in the past couple weeks when a few people started telling me they couldn't reach me. Limiting to 2g/3g does work but obviously not a proper fix. Tried the whole enabling volte/WiFi calling thing but no luck. Last oneplus software update couple weeks ago didn't help either. Very frustrating.
    Had anyone tried reaching out to 3 to see if it's a common issue and perhaps fixable their end?
     

    #8
    I1611869542416 likes this.
  9. binay.pradhan
    Cupcake Mar 19, 2021

    binay.pradhan , Mar 19, 2021 :
    Hello Everyone,
    I am from Dublin, Ireland. I bought oneplus 8t towards the end of January this year. I am having this issue from the day one itself. I am on Lycamobile.

    So that means, it's nothing to do with network for sure. What should I do?

    I am really pissed.
     

    #9
    I1611869542416 likes this.
  10. cormac1982
    Donut Mar 22, 2021

    cormac1982 , Mar 22, 2021 :
    Actually as far am I'm aware, Lycamobile piggy back on Three's network so technically you are using Three. Restricting your mobile network to 3g does temporarily work.

    Kind regards,
    Cormac.
     

    #10
    I1611869542416 likes this.
  11. cormac1982
    Donut Mar 22, 2021

    cormac1982 , Mar 22, 2021 :
    I've contacted Three support (business) and they say there's no issue and I'm inclined to believe them. I've been doing a bit of Googling and believe I understand what's actually going wrong when we can't receive calls. 4g and 5g are strictly for data purposes only, you can't actually make traditional calls. As your phone prepares to receive a call (while connected to 4g/5g) it switches you back to 2g/3g/H/H+ first, it's called Circuit Switched Fallback/CSFB apparently... I presume the phone gets some sort of signal. This isn't happening for us while on Three and it's why we have no issue receiving calls while limiting our mobile network to 3g.

    I did a bit of experimenting while trying to work our why this was happening on my phone.... If you're connected to 4g/5g and make an outgoing call, watch your signal bar - It will switch to back 2g/3g/H/H+ just as you try to make a call. Similarly, in normal circumstances if you're receive a call while on 4g/5g your signal bar will again fallback to 2g/3g/H/H+ before you're phone actually rings. In our situation, if you call your own phone and your handset doesn't ring (because you're on 4g/5g), try to make an outgoing call... your outgoing call will fail but your incoming call will immediately start ringing on your handset because it switches you over to 2g/3g in order to make the outgoing call you tried to make.

    Got onto OP support who offered to take the handset in for repair but when I told them I bought it from Amazon they suggested I get them to sort it. I've read posts from other people with this issue (all pre 2021 strangely enough except for this thread) who sent their handsets for repair but the issue persisted. Wondering if I should send the above details re CSFB to Three in case it is their issue but considering how quick OP were to offer to take the phone in for repair I'm inclined to think it's a handset issue and their aware of it!
     

    #11
  12. eamonnde
    Donut Mar 22, 2021

    eamonnde , Mar 22, 2021 :
    No didn't work for me - still having the same issues and have replaced my sim card too in hope that would resolve it.

    Serious patience to work all that out but for a new phone that was released only a couple of months ago, this in my eyes is a design flaw, reality is phone isn't working as a phone. I probable get more calls on WhatsApp at this stage than on my actual phone.

    The fix from OP is to simple replace the motherboard and hope it resolves it - they wouldn't do anything else on

    Not that i want to change a phone 6 months after getting it but depending on the cost of OP9 - I may trade this in and hope that issue doesn't persist.
     

    #12
    I1611869542416 likes this.
  13. magsdbee
    Cupcake Mar 23, 2021

    magsdbee , Mar 23, 2021 :
    Having the same problem, with three Ireland, beyond annoyed with this. When I emailed a complaint they had no problem reminding me every 2 days to respond or they would mark the issue resolved, now they have now left me without response for almost 2 weeks. Also with three Ireland. At the moment apps are shutting down the second I open them which is probably unrelated but I have enough of this useless phone
     

    #13
    I1611869542416 likes this.
  14. amyregxn
    Cupcake Mar 23, 2021


    #14
    I1611869542416 likes this.
  15. eamonnde
    Donut Mar 24, 2021

  16. V1578423370250
    Cupcake Mar 24, 2021

    Last edited: Mar 24, 2021

    #16
    I1611869542416 likes this.
  17. cormac1982
    Donut Mar 25, 2021

    cormac1982 , Mar 25, 2021 :
    Eamonn,
    I've tried this. Makes no difference for me anyway.

    You're quite right too about it being a design flaw, shouldn't have to deal with this! I've gone down the Amazon refund route now, hopefully will be straigthforward.

    Kind regards,
    Cormac
     

    #17
    I1611869542416 likes this.
  18. S1603224238556
    Donut Mar 31, 2021

    S1603224238556 , Mar 31, 2021 :
    Hello,
    I having the same issue (missing calls OnePLus 8T / Three Ireland).
    No real solution has been proposed to me by OnePlus (only troubleshooting like wipe your cache, reset your phone, change sim, etc.)..
    Honestly I have the feeling they have no idea what is wrong with their OnePlus 8T phone and can't fix it.
    Has someone found a solution to this problem (with or without the help of OnePlus)?
    Has someone obtained a refund for this defect product (how can they put on the market a phone that misses incoming calls is beyond my understanding)?
    I have my own company and with the current situation (all employees working from home) this is a serious problem for business.
    Any help welcome.
    Regards,
    Christophe
     

    #18
    I1611869542416 likes this.
  19. Declan Finlay
    Cupcake Apr 3, 2021

    Declan Finlay , Apr 3, 2021 :
    I was having the same problem and I'm on Virgin which uses the Three network.

    I switched off 5G and it seems to have sorted it.
     

    #19
    I1611869542416 likes this.
  20. S1603224238556
    Donut Apr 6, 2021

    S1603224238556 , Apr 6, 2021 :
    Hi Declan,
    Thank you very much for your feeback.
    I tried that too but it switched back to 5G after I made the troubelshooting proposed by OP.
    I will switch off again, wait and see if this helps!
    Best regards,
    Christophe
     

    #20
    I1611869542416 likes this.