0
Occasional WiFi disconnects in COS 13

  1. go8soccer
    Ice Cream Sandwich Apr 15, 2016

    go8soccer , Apr 15, 2016 :
    Has anyone else experienced random Wifi Disconnects in COS13?
    It doesn't happen very frequently for me, but just enough to be annoyed by it.

    Has anybody else flashed the radio/modem from Oxygen 2.1.4 over COS13?

    Not sure if that would work, since we're talking about 2 different android versions (5.1.1 vs 6.0).
     

    #1
  2. inroma
    Honeycomb Apr 24, 2016

    inroma , Apr 24, 2016 :
    Hey, I have had the same issue since Cos12.0 (I think). I've juste solved this by going to my routeur settings and enable DHCP (I had set a static IP to my OPO). And now it makes 20 minutes that my phone is working fine on wifi !
    Let me know if that work for you ;)
     

    #2
    go8soccer likes this.
  3. rajatthakrangmail
    Cupcake Apr 24, 2016

    rajatthakrangmail , Apr 24, 2016 :
    I have the same problem.. Will give it a try

     

    #3
  4. Deactivated User
    Apr 25, 2016


    #4
    go8soccer likes this.
  5. go8soccer
    Ice Cream Sandwich Apr 26, 2016

    go8soccer , Apr 26, 2016 :
    That's a great workaround.. I can't say I'd call that a fix though, considering that doesn't help you out when you're not on your home network.

    I was able to flash the Oxygen 2.1.4 modem and firmware.. and that resolved the Wifi disconnect issue for me....HOWEVER!!! This causes the COS OTA's to fail, since the firmware isn't signed by Cyanogen.
    The only way to get COS OTA back (Since there's not currently a flashable COS 13) is to flash the latest COS 12.1 (cm-12.1-YOG7DAS2K1-bacon-signed.zip), which replaces the Oxygen firmware with Cyanogen's, then immediately flash the OTA file for COS 13 (cm-bacon-cee4e8702d-to-64003595ee-signed.zip)... then reboot, then flash the latest OTA (cm-bacon-e36dd78050-to-64003595ee-signed.zip).
    Major pain in the tush, but it worked like a charm for me.
     

    #5
  6. go8soccer
    Ice Cream Sandwich Apr 26, 2016

    go8soccer , Apr 26, 2016 :
    I think there's a setting like that in "Advanced" under Wifi.. "Avoid poor connections". I've tried disabling that, but the issue persisted for me... GREAT thought though @KarelOne
     

    #6
  7. Deactivated User
    Apr 26, 2016


    #7
    go8soccer likes this.
  8. go8soccer
    Ice Cream Sandwich Apr 26, 2016

    go8soccer , Apr 26, 2016 :
    Agreed! Hoping the latest OTA, combined with my flashing binge fixed it :)
     

    #8
  9. pablofg1978
    Nougat Head Moderator Apr 26, 2016


    #9
  10. lechevalierr
    Donut Apr 29, 2016

    lechevalierr , Apr 29, 2016 :
    Wi-Fi seems to disconnect itself every minute or so which is definitely a nuisance. Apart from flashing OOS and then reverting to COS, is there any other possible solution?
     

    #10
  11. kishorevenky
    Honeycomb Apr 29, 2016

    kishorevenky , Apr 29, 2016 :
    I've had this issue since COS 12.1 YOG4PAS1NO and it has persisted ever since. I flashed a cm12 wifi modem which fixed it earlier but now on COS 13 it no longer works for me. A fix would be appreciated.
     

    #11