248
ROM [OFFICIAL][LINEAGE OS/CM14.1][ONEPLUS2] [DISCUSSIONS][DOWNLOADS]

  1. hampfred
    Gingerbread Mar 31, 2016


  2. mido25
    Ice Cream Sandwich Mar 31, 2016

    mido25 , Mar 31, 2016 :
    It should work for some but @Grarak said some may face issues. So it's advised to clean flash OOS 2.2.1 and clean flash latest cm13
     

  3. yamako
    Froyo Mar 31, 2016

    yamako , Mar 31, 2016 :
    Hi,

    I try to dirty update from cm-13.0-20160324-UNOFFICIAL-oneplus2.zip to cm-13.0-20160330-UNOFFICIAL-oneplus2.zip, unsuccessful. Here is a pict, about error with TrustZone.
    I have TWRP 3.0.0.-0

    IMG_20160331_135639.jpg IMG_20160331_135620.jpg
     

  4. hampfred
    Gingerbread Mar 31, 2016

    hampfred , Mar 31, 2016 :
    Did you wipe dalvik/art and cache before you tried to update? Thats what I did and it worked perfectly for me.
     

  5. yamako
    Froyo Mar 31, 2016

    yamako , Mar 31, 2016 :
    Same problem.
     

  6. hampfred
    Gingerbread Mar 31, 2016

    hampfred , Mar 31, 2016 :
    Sorry mate, then I don't have a working solution for ya.
     

  7. mido25
    Ice Cream Sandwich Mar 31, 2016

    mido25 , Mar 31, 2016 :
    Clean flash OOS 2.2.1 and then clean flash cm13 new version
     

  8. Prakash Bulusu
    Gingerbread Mar 31, 2016


  9. spysky
    Gingerbread Mar 31, 2016

    spysky , Mar 31, 2016 :
    Yep, Looks like it's not only recovery related.Also on 3.0.0-2 and no luck.
    Let's wait a couple of days to see if anyone finds a more friendly fix/workarround
     

  10. yamako
    Froyo Mar 31, 2016

    yamako , Mar 31, 2016 :
    I try to update recovery to 3.0.0-2 and not working. Problem is, I think, I was on 2.2.0 and revert back to 2.1.2 (maybe it change TZ to R1-00169)
     

  11. mido25
    Ice Cream Sandwich Mar 31, 2016

    mido25 , Mar 31, 2016 :
    no need to revert. Flash 2.2.1 not 2.1.1
     

  12. burnout123
    Ice Cream Sandwich Mar 31, 2016

    burnout123 , Mar 31, 2016 :
    Same here, build works great!
     

  13. mido25
    Ice Cream Sandwich Mar 31, 2016

    mido25 , Mar 31, 2016 :
    For those who's experiencing errors while flashing in recovery, the fix added in OP. Please read a bit before you post here. If that doesn't work for you. Please stay in older build and wait for @Grarak to release his new build.

    Thanks for understanding...
     

    eocampos likes this.
  14. spysky
    Gingerbread Mar 31, 2016

    spysky , Mar 31, 2016 :
    Just to be sure, this method requires a clean install, correct?
    Therefore at the moment there is no solution for a dirty flash whenever one encounters the TZ error.
     

  15. mido25
    Ice Cream Sandwich Mar 31, 2016

    mido25 , Mar 31, 2016 :
    yes. If you face that error, only clean flash is your way.
     

    spysky likes this.
  16. abchauhan2009
    Eclair Mar 31, 2016

    abchauhan2009 , Mar 31, 2016 :
    I guess u should wipe all data (not internal storage) and then reflash grarak rom or 2.2.1(as latest rom have tz assertion) and u may just hold power button for 20 second (when the phone vibrate even after that wait for 5 second) then directly try to recovery. U may also see this if nothing else helps https://forums.oneplus.net/threads/...ck-guide-for-a-hard-bricked-oneplus-2.347607/
     

  17. arminth
    Honeycomb Mar 31, 2016

    arminth , Mar 31, 2016 :
    Just ran into a stupid issue. I updated to Garaks latest Version. Worked perfect. Great performance. I was quite happy.

    I realized before, that the recognition of my thumb fingerprint wasn't really good. And here the bad things started!
    I erazed all registered 5 fingerprints and registered new ones.
    Then I locked the screen. The fingerprint-symbol appeared. I tried to use the sensor and a message "Fingerprint Hardware not available" appears. Ok, not an issue - key in your PIN. Then it says "wrong PIN!!".
    Only thing that helps is to reboot and NOT touch the homebutton! Then you can key in the PIN.
    What I realized was that it is not possible to register a fingerprint without at least one Error during registering. You can scan your print until the last try without problems and then it says "please put finger blalala" but then completes the scan. I thought, this could be an issue and tried to register about 20 times to get at least one flawless registration - no way.
    So the moment you place the finger on the sensor with havin at least one registered print, I get the "Hardware not available" error and my PIN is not accepted anymore.

    I want to do a clean Flash to investigate into the issue a bit more but I am afraid, the TZ-Thing might hit me.
    I know that somewhere on this Forum there is a list of official, TWRP flashable ROM's but today I am too blind to find the post. So I'm looking for the OOS 2.2.1 ROM to download onto my phone before trying a clean install.
    My other Option to restore my nandroid-backup...

    Can someone help me with that?
    Sorry for bothering!

    THX!

    Cheers
    Armin
     

  18. spysky
    Gingerbread Mar 31, 2016

    spysky , Mar 31, 2016 :
    Regarding the OOS 2.2.1 ROM, you have it in #1 post of this thread:
    https://www.androidfilehost.com/?fid=24438995911976356
     

    arminth likes this.
  19. Foggy79
    Gingerbread Mar 31, 2016

    Foggy79 , Mar 31, 2016 :
    Just reflash the latest build in TWRP. I had this issue in the first build and had to flash the rom twice, then it worked.
     

  20. arminth
    Honeycomb Mar 31, 2016