1

"Ok Google" is not working

  1. mrpacs Honeycomb Jun 11, 2019

    mrpacs, Jun 11, 2019 :
    I tried uninstalling and reinstalling the Google app, clearing cache in app and on phone. Retrained the voice in Google app a dozen times. Nothing is working. Side note: my SIM card is still installed in my old 5T. "OK Google" is working fine with the 5T. The 7 Pro doesn't have a SIM card. Not sure if that is a factor. Assistant works fine. *UPDATE: "OK Google" will launch when prompted when display is locked but it won't answer or respond to whatever I ask it. "OK Google" will not launch or respond when phone is unlocked at all.
     
    Last edited: Jun 11, 2019

    #1
    perk_in likes this.
  2. Spectr_ Eclair Jun 12, 2019

    Spectr_, Jun 12, 2019 :
    What OS version are you on? I just updated to 9.5.7 and my assistant also stopped responding. I realized I needed to enable the setting again. Settings - Google - Search, Assistance & Voice - Voice Match - Access with voice match.

    Also, even though it says Ok Google, I use Hey Google and it works just as well
     

    #2
  3. mrpacs Honeycomb Jun 12, 2019

    mrpacs, Jun 12, 2019 :
    9.5.7
     

    #3
  4. dallasnights Donut Jun 12, 2019

    dallasnights, Jun 12, 2019 :
    Same issue OK Google or Hey Google will NOT work on the One Plus 7 pro for some reason on my end on the homescreen like it did before this firmware update.
    Did all that was suggested , Clear Cache , Clear Data, Disable Google, Reboot, then Enable google, retrain my voice
    But still on the home screen when I say OK Google nothing happens
    Anyone have a FIX for the Oneplus 7 pro? Thanks

    BTW Stock 9.5.7 GMA21AA Firmware
    Model GM1917
     
    Last edited: Jun 12, 2019

    #4
    perk_in likes this.
  5. bibhab1976 Gingerbread Jun 12, 2019


    #5
  6. perk_in Donut Jun 12, 2019

    perk_in, Jun 12, 2019 :
    Exactly. it's not working. only appears when screen is off. when screen is unlocked it doesn't respond no matter how many times you retrain your voice. Any work around ?
     

    #6
  7. Deagle311 Donut Jun 12, 2019

    Deagle311, Jun 12, 2019 :
    Try sideloading Google Home and Google App from APKmirror and check if that works.
     

    #7
  8. dallasnights Donut Jun 12, 2019

    dallasnights, Jun 12, 2019 :
    No luck when I try sideloading it says app can not be installed
    I am thinking the only way to fix is a factory reset but I hope not
    Thanks everyone hope someone can find a solution
     

    #8
    Deagle311 likes this.
  9. perk_in Donut Jun 12, 2019

    perk_in, Jun 12, 2019 :
    Another thing worth mentioning is that it works with one plus bullets or any other wireless headphones when connected but it just won't work without the headset !
     

    #9
  10. GuitarHero0179 Jelly Bean Jun 12, 2019

    GuitarHero0179, Jun 12, 2019 :
    Interesting this also persists on the 7pro. On my 5 it completely stopped working after they introduced assistant and with fixes I could only get it to work for a couple of minutes. Following this
     

    #10
  11. Spectr_ Eclair Jun 13, 2019

    Spectr_, Jun 13, 2019 :
    What I can say is that mine worked in 9.5.1 then I noticed it had stopped on 9.5.7 but after changing the settings I mentioned above it all went back to normal. I have not tried it with a headset yet. European version 12gb for me.
     

    #11
  12. mrpacs Honeycomb Jun 13, 2019


    #12
  13. perk_in Donut Jun 13, 2019

    perk_in, Jun 13, 2019 :
    should I opt for it too ? this is disgusting to have to go down that road to fix it
     

    #13
    mrpacs likes this.
  14. mrpacs Honeycomb Jun 13, 2019

    mrpacs, Jun 13, 2019 :
    I use ok Google on a daily basis. I needed to have the functionality working. It all depends on your needs. I would advise you to try factory reset.
     

    #14
  15. perk_in Donut Jun 13, 2019

    perk_in, Jun 13, 2019 :
    It worked. surprisingly I didn't factory reset. you just need to clear all data and then retrain your voice ! [e]1f603[/e]
     

    #15
    mrpacs likes this.
  16. mrpacs Honeycomb Jun 13, 2019

    mrpacs, Jun 13, 2019 :
    Awesome! That didn't work for me.
     

    #16
    perk_in likes this.
  17. perk_in Donut Jun 13, 2019

    perk_in, Jun 13, 2019 :
    let's stay connected for future bug discussions mate :)
     

    #17
    mrpacs likes this.
  18. Spelt Ice Cream Sandwich Jun 13, 2019

    Spelt, Jun 13, 2019 :
    That pretty much what I had to do when the assistant stopped responding to OK Google.
     

    #18
  19. Militant Asian Cupcake Jun 18, 2019


    #19
  20. KeepTransisting The Lab - OnePlus 7 Pro Reviewer Jun 18, 2019

    KeepTransisting, Jun 18, 2019 :
    Crazy question, but do you have the app Plus Beat installed?

    I had this exact tame thing happen. I uninstalled Plus Beat and it started working.
     

    #20