2
Ok Google Not working

  1. Logancd1
    Ice Cream Sandwich Feb 28, 2019

    Logancd1 , Feb 28, 2019 :
    So the fact you say that "retrain and delete voice" isn't enabled combined with the freeze on "Say OK Google" when trying to do a new voice model after an app reinstall makes me think there's an issue with the Google app.

    You may have already tried these, but...
    My next suggestions are, in order:
    Clear cache AND clear storage/data for the "Google" app in Settings > Apps. Make sure to close the "Google" app in multitasking before doing this as well just as a safety measure.
    If that doesn't work, try removing your Google account from your device completely (in Settings > Accounts I believe) and then re-add it. This will require you to sign in again, but it should also refresh these apps as far as your account data goes.
     

    #41
  2. SomilTyagi
    Donut Feb 28, 2019

    SomilTyagi , Feb 28, 2019 :
    I have already tried the first option and it didn't work, let me also check the second option of removing my accounts but i feel it will hardly make any difference, since clearing the app cache hasn't worked at all.

    thanks for the advice.

    will check and revert.

    i seriously hope someone Oneplus or Google fixes this bug.
     

    #42
  3. SomilTyagi
    Donut Feb 28, 2019

    SomilTyagi , Feb 28, 2019 :
    option 2 checked and not working.
     

    #43
  4. SomilTyagi
    Donut Mar 1, 2019


    #44
  5. iPap
    Froyo Mar 1, 2019

    iPap , Mar 1, 2019 :
    I have that same issue since I updated to Beta 25. The voice match option is disabled and can't get turned on. So probably it's a common issue and we'll have a response soon hopefully
     

    #45
  6. Tahir.
    Donut Mar 1, 2019

    Tahir. , Mar 1, 2019 :
    Ok, so i took the plunge and did a full factory reset (Backup data first), TWRP > erase data, cache & Dalvic. I also wiped System as well, since i was using Magisk. Rebooted.. Voice match is working again. :)
     

    #46
  7. SomilTyagi
    Donut Mar 1, 2019

    SomilTyagi , Mar 1, 2019 :
    i wish i could do the same

    cannot go through the painful process of losing my stuff.

    there needs to be a workaround.
     

    #47
  8. Tahir.
    Donut Mar 1, 2019


    #48
  9. yossxp
    Donut Mar 2, 2019

    yossxp , Mar 2, 2019 :
    Finally, OK Google is working again.. no updates were done for the Google app, so this might be a server side thing (which happened a few months ago as well)


    1551523042482.jpg

    1551523042523.jpg
     

    #49
  10. SomilTyagi
    Donut Mar 2, 2019


    #50
  11. Mr_Cyrox
    KitKat Mar 2, 2019

    Mr_Cyrox , Mar 2, 2019 :
    I'd recommend just waiting it out as some users just get it fixed overtime like one user above...
    I too think this is a server side issue...
    Well, at least it works for me on OB 27
     

    #51
  12. pavlos87
    Cupcake Mar 3, 2019

    pavlos87 , Mar 3, 2019 :
    I'm afraid not! works perfectly on my other phones
     

    #52
  13. SomilTyagi
    Donut Mar 4, 2019

    SomilTyagi , Mar 4, 2019 :
    i just checked my friend's OnePlus 5T, he is having no such issues.
    This bug/error just gets creepy.
     

    #53
  14. M1551686498794
    Cupcake Mar 4, 2019


    #54
  15. SomilTyagi
    Donut Mar 4, 2019

    SomilTyagi , Mar 4, 2019 :
    tried several times, didn't work.
     

    #55
  16. M1551686498794
    Cupcake Mar 4, 2019


    #56
  17. J_Duece_81
    Froyo Mar 4, 2019

    J_Duece_81 , Mar 4, 2019 :
    i was skimming through this post, I haven't updated to pie or the feb google update 9.27.3.21. Did anyone try just unistalling the update for Google. That worked for Play Store issues for me last year
    1551712094134.jpg
     
    Last edited: Mar 4, 2019

    #57
  18. SomilTyagi
    Donut Mar 7, 2019


    #58
  19. Mr_Cyrox
    KitKat Mar 7, 2019

    Mr_Cyrox , Mar 7, 2019 :
    I think it's best to report this to Google directly...
     

    #59
  20. Scherpenseel
    Jelly Bean Mar 7, 2019

    Scherpenseel , Mar 7, 2019 :
    If you're the only one with a OP5T having this issue. Why not indeed just back-up your data and factory reset your phone. Everything will be back as it was when you restore the back-up. Why keep asking for weeks while it may just be a corrupted file on your specific device. No update will fix that.
     

    #60