Ok Google Not Working

  1. anoopraok
    Eclair Mar 1, 2019

    anoopraok , Mar 1, 2019 :
    hello Guys,

    I am having issues enabling ok Google hotword on my OnePlus 5t with pie running on it.

    I am not able to enable the "access to voice match" for some reason.i try to enable it but it just go back to disabled mode any help is appreciated! (I have googled this issues and tried to do some fix but didn't help)


    jmbolivar likes this.
  2. Tahir.
    Donut Mar 2, 2019

  3. anoopraok
    Eclair Mar 3, 2019

    anoopraok , Mar 3, 2019 :
    I was looking for options which does not force me to do a factory reset....

  4. ANDREA F.
    Eclair Mar 3, 2019

    ANDREA F. , Mar 3, 2019 :
    Experienced the same on OP5 9.0.3 yesterday. Maybe it's just a language compatibility issue which affected many different devices types in the last few weeks. I've solved with this: Set the System language to English. Then in assistant settings you'll be able to re set Access with voice match and also unlock (if you like) previously greyed out without solution. Maybe you'll be answered to repeat Ok Google 4 times. A restart in recovery with a wipe cache could be helpful. Now, if you don't want to speak with assistant and get responses only in English you have to add your language in assistant settings ( could asked to repeat Ok Google 4 times), then Re set your language as System language. Restart. Tell us if you've solved.

    furboll likes this.
  5. nick_k
    Gingerbread Mar 3, 2019

    nick_k , Mar 3, 2019 :
    It is/was Google's problem, not 1+. Learn to search and read a little.

    Aj_singh07 likes this.
  6. furboll
    Cupcake Mar 11, 2019

    furboll , Mar 11, 2019 :
    I'll confirm this worked for me. My settings were set to "System Default" I changed them to English and OK Google is working again. Thanks for this suggestion because I was not looking forward to resetting my phone.

    ANDREA F. likes this.
  7. roel5684
    Cupcake May 29, 2019

    roel5684 , May 29, 2019 :
    If you don't face the problem yourself, please don't be the smartass judging. It isn't problem solving but problem denial. That doesn't help people any further. A lot of people are unable to enter voice match because it simply is greyed out. A lot of methods have been described from adding english besides or i.s.o. native language even deleting google app and reinstall even as a system app k3pt voice match being grade out. For your understandings this means that it is not an available software option. This is not for all phones the case, making it hard to believe it is a google's problem but probably (?) more the shell over Google , for example OOS. But this is obviously my ignorance caused by not reading and searching nor trying. Thx man

  8. sonnyhaze
    Eclair Jul 10, 2019

    sonnyhaze , Jul 10, 2019 :
    I think we all are having the same issue. Google Assistant not working properly. For me it wouldn't let me click on voice match, in the settings. I tried everything, or at least I thought. Until I found this solution, and that's by Enabling Google Assistant with Beta Apps. Follow these steps...
    1. We are going to start by signing to the beta versions. Go to Settings > Google.
    2. Now tap on the three-dot menu icon located in the top-right corner of the screen. Select Help & feedbackfrom the next menu.
    3. Once you’re on the Help page, tap the three-dot menu icon again and select View in Google Play Store.
    4. This will open up a new Google Play window with Google Play Services. Ignore the fact that it needs to update, we’ll deal with that later on.
    5. Scroll all the way down to the Beta program and tap on I’m in.
    6. After a while, you will be invited to complete the beta sign up. Do so by tapping on Join. After you hit Join, it will take at least 5 minutes until the sign up is complete. In my case, it took over 10 minutes.
    7. Now go to the home menu of Google Play Store and search for the “Google App”.
    8. Scroll all the way down to the beta program and tap on I’m in. Confirm again by tapping Join.
    9. Now, wait for a few good minutes to make sure the beta signup completes on both apps. After a while, tap the action button inside Google Play Store and go to My apps & games.
    10. From the following screen, expand the Beta tab and locate Google and Google Play Services.
    11. Tap on the Google app hit the Update button after making sure the beta signup is complete. You can for that by looking right under the Update tab. If it says “You’re a beta tester for this app“, then you’re good to go.
      [​IMG]Note: In the event that it says “Beta Sign up in progress” do NOT update the app yet. Instead, close Google Play Store and come back to this screen after a few minutes.
    12. After you’ve successfully updated the Google app, repeat the same procedure with Google Play services. Remember to make sure that the beta sign-up is complete before hitting Update.
    13. Once you got both apps updated, go to Settings > Apps (Applications) and make sure you select the All apps filter. Scroll down and tap on the Google entry.
    14. Go to Storage tap on Manage space and hit Clear All data.
    15. Now go back to Settings > Apps (Applications), enable the All apps filter again and tap on Google Play Services.
    16. Go to Storage > Manage Space and tap on Clear All Data.
    17. Now the setup is almost complete. You can finally open the Google app. You will be asked to insert your credentials straight away. After you insert them, tap on Get Started.
    18. Expand on the action menu (located in the top left corner) and tap on Settings.
    19. Now tap on Settings (under Google Assistant) and select Phone (under Devices).
    20. Now make sure Google Assistant is enabled. If it isn’t enabled, tap on the toggle next to it.
    21. That’s it. Google Assistant should now be enabled on your device. You can test it by saying “OK, Google” near the microphone. You don’t necessarily have to be in the Google app, it works in every screen.